aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
commit6f6fbe4bdf9851de1eb6ebef5287e3007846045e (patch)
tree3b556699991305af672fba96e0e8b6bb88bcc7da /java
parent86f8cde1da39aadc3efbc11e60998d886c86c36e (diff)
downloadports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.tar.gz
ports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Notes
Notes: svn path=/head/; revision=282282
Diffstat (limited to 'java')
-rw-r--r--java/cacao/Makefile4
-rw-r--r--java/classpath/Makefile2
-rw-r--r--java/jamvm/Makefile3
-rw-r--r--java/jc/Makefile4
-rw-r--r--java/sablevm-classpath/Makefile2
-rw-r--r--java/sablevm/Makefile3
6 files changed, 10 insertions, 8 deletions
diff --git a/java/cacao/Makefile b/java/cacao/Makefile
index 076b5b9c41c5..db6e0bb7715f 100644
--- a/java/cacao/Makefile
+++ b/java/cacao/Makefile
@@ -22,8 +22,8 @@ JAVA_VERSION= 1.5+
GNU_CONFIGURE= yes
MAN1= cacao.1
CONFIGURE_ARGS+= --with-classpath-prefix=${LOCALBASE}
-CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+LDFLAGS+= -L${LOCALBASE}/lib
+CFLAGS+= -I${LOCALBASE}/include
.include <bsd.port.pre.mk>
diff --git a/java/classpath/Makefile b/java/classpath/Makefile
index 47dbe7556200..698d1699dc2b 100644
--- a/java/classpath/Makefile
+++ b/java/classpath/Makefile
@@ -25,7 +25,7 @@ USE_XORG= x11 ice xtst xaw xproto xext
WANT_GNOME= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CXXFLAGS="${CXXFLAGS} -I${LOCALBASE}/include"
+CXXFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS= --enable-jni --disable-alsa --disable-dssi --disable-plugin
USE_GMAKE= yes
diff --git a/java/jamvm/Makefile b/java/jamvm/Makefile
index 4ab20683ed2e..020c5ffc2db0 100644
--- a/java/jamvm/Makefile
+++ b/java/jamvm/Makefile
@@ -27,7 +27,8 @@ OPTIONS= FFI "use libffi to call native methods" ON \
.if defined(WITH_FFI)
LIB_DEPENDS+= ffi:${PORTSDIR}/devel/libffi
CONFIGURE_ARGS+= --enable-ffi
-CONFIGURE_ENV+= CFLAGS="${CFLAGS} `pkg-config libffi --cflags`" LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+LDFLAGS+= -L${LOCALBASE}/lib
+CFLAGS+= `pkg-config libffi --cflags`
.endif
.if defined(WITH_ZIP)
diff --git a/java/jc/Makefile b/java/jc/Makefile
index 2f12e5ee89f7..17e8457fb471 100644
--- a/java/jc/Makefile
+++ b/java/jc/Makefile
@@ -27,8 +27,8 @@ JAVA_BUILD= jre
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-classpath=${LOCALBASE}
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
INFO= jc
ONLY_FOR_ARCHS= i386
diff --git a/java/sablevm-classpath/Makefile b/java/sablevm-classpath/Makefile
index 080a0c6305f1..5ff3cecacaf2 100644
--- a/java/sablevm-classpath/Makefile
+++ b/java/sablevm-classpath/Makefile
@@ -30,7 +30,7 @@ USE_GMAKE= yes
USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
PLIST_SUB+= PORTVERSION=${PORTVERSION}
-CONFIGURE_ENV= CFLAGS="-I${PREFIX}/include -L${PREFIX}/lib -I${LOCALBASE}/include -L${LOCALBASE}/lib"
+CFLAGS+= -I${PREFIX}/include -L${PREFIX}/lib -I${LOCALBASE}/include -L${LOCALBASE}/lib
.include <bsd.port.pre.mk>
diff --git a/java/sablevm/Makefile b/java/sablevm/Makefile
index 05cda4df4bac..e5fd80523678 100644
--- a/java/sablevm/Makefile
+++ b/java/sablevm/Makefile
@@ -26,7 +26,8 @@ USE_LDCONFIG= yes
USE_GNOME= pkgconfig
PKG_CONFIG?= ${LOCALBASE}/bin/pkg-config
-CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include `${PKG_CONFIG} libffi --cflags`" LDFLAGS="-L${LOCALBASE}/lib"
+LDFLAGS+= -L${LOCALBASE}/lib
+CFLAGS+= -I${LOCALBASE}/include `${PKG_CONFIG} libffi --cflags`
CONFIGURE_ARGS= --includedir=${PREFIX}/include/${PORTNAME}
OPTIONS= SVMCP "Install SableVM classpath" ON \