aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2010-11-21 20:11:51 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2010-11-21 20:11:51 +0000
commitf1e5c6edd45e2023803aed9cb9145db92342ef3a (patch)
tree1dae993906f1924198cc9b2710dfd0bee0b76ad4 /java
parentd37e24d8d76a986478ccf99c25b9589c75485291 (diff)
downloadports-f1e5c6edd45e2023803aed9cb9145db92342ef3a.tar.gz
ports-f1e5c6edd45e2023803aed9cb9145db92342ef3a.zip
Notes
Diffstat (limited to 'java')
-rw-r--r--java/eclipse-cdt/Makefile149
-rw-r--r--java/eclipse-cdt/distinfo6
-rw-r--r--java/eclipse-cdt/pkg-plist106
3 files changed, 169 insertions, 92 deletions
diff --git a/java/eclipse-cdt/Makefile b/java/eclipse-cdt/Makefile
index a552d9667d19..ad55527d340e 100644
--- a/java/eclipse-cdt/Makefile
+++ b/java/eclipse-cdt/Makefile
@@ -1,109 +1,82 @@
-# New ports collection makefile for: eclipse-cdt
-# Date created: March 1, 2004
-# Whom: gldisater@gldis.ca
+# New ports collection makefile for: eclipse-cdt
+# Date created: March 1, 2004
+# Whom: gldisater@gldis.ca
#
# $FreeBSD$
#
-PORTNAME= cdt
-PORTVERSION= 3.1.2
-PORTREVISION= 4
+PORTNAME= ${PLUGIN}
+PORTVERSION= 6.0.2
CATEGORIES= java devel
+#MASTER_SITES= http://download.eclipse.org/
MASTER_SITES= ${MASTER_SITE_ECLIPSE}
-MASTER_SITE_SUBDIR=tools/cdt/releases/callisto/dist/${PORTVERSION}
+MASTER_SITE_SUBDIR=tools/${PLUGIN}/releases/${ECLIPSE_CODENAME}/dist
+DISTNAME= ${PLUGIN}-master-${PORTVERSION}
PKGNAMEPREFIX= eclipse-
-DISTNAME= org.eclipse.cdt.sdk-${PORTVERSION}-linux.x86
-DIST_SUBDIR= eclipse
-MAINTAINER= girgen@FreeBSD.org
-COMMENT= C/C++ IDE for Eclipse
+MAINTAINER= aldis@bsdroot.lv
+COMMENT= C/C++ plugin for Eclipse IDE
-RUN_DEPENDS= ${LOCALBASE}/bin/eclipse:${PORTSDIR}/java/eclipse
-PATCH_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
+RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse
-BROKEN= bad dependency object for java/eclipse
-
-NO_WRKSUBDIR= yes
-USE_JAVA= yes
-JAVA_VERSION= 1.4+
+USE_ZIP= YES
+USE_JAVA= YES
JAVA_OS= native
-USE_GMAKE= yes
-PORTVERSION_TS= ${PORTVERSION}.200702150621
+JAVA_RUN= YES
+JAVA_VERSION= 1.6
+
+NO_BUILD= YES
+NO_WRKSUBDIR= YES
+
+ECLIPSE_CODENAME=galileo
+PLUGIN= cdt
+RM_VERSION= 5.1.0.201002161416
+RM_NAME= org.eclipse.cdt.core
+
+RM_XLC= features/org.eclipse.cdt.xlc.feature_6.0.0.201002161416.jar \
+ features/org.eclipse.cdt.xlc.sdk_6.0.0.201002161416.jar \
+ features/org.eclipse.cdt.xlc.source_6.0.0.201002161416.jar \
+ plugins/org.eclipse.cdt.core.lrparser.xlc.source_5.1.0.201002161416.jar \
+ plugins/org.eclipse.cdt.core.lrparser.xlc_5.1.0.201002161416.jar \
+ plugins/org.eclipse.cdt.errorparsers.xlc.source_5.0.100.201002161416.jar \
+ plugins/org.eclipse.cdt.errorparsers.xlc_5.0.100.201002161416.jar \
+ plugins/org.eclipse.cdt.make.xlc.core.source_5.0.0.201002161416.jar \
+ plugins/org.eclipse.cdt.make.xlc.core_5.0.0.201002161416.jar \
+ plugins/org.eclipse.cdt.managedbuilder.xlc.core.source_5.0.0.201002161416.jar \
+ plugins/org.eclipse.cdt.managedbuilder.xlc.core_5.0.0.201002161416.jar \
+ plugins/org.eclipse.cdt.managedbuilder.xlc.ui.source_6.0.0.201002161416.jar \
+ plugins/org.eclipse.cdt.managedbuilder.xlc.ui_6.0.0.201002161416.jar \
+ plugins/org.eclipse.cdt.managedbuilder.xlupc.ui.source_1.0.0.201002161416.jar \
+ plugins/org.eclipse.cdt.managedbuilder.xlupc.ui_1.0.0.201002161416.jar
.include <bsd.port.pre.mk>
-ECLIPSE_OS= freebsd
-.if (${ARCH} == "amd64")
-ECLIPSE_ARCH= amd64
-.else
-ECLIPSE_ARCH= x86
-PLIST_FILES+= lib/eclipse/plugins/org.eclipse.cdt.core.freebsd.x86_${PORTVERSION_TS}/os/freebsd/x86/libpty.so \
- lib/eclipse/plugins/org.eclipse.cdt.core.freebsd.x86_${PORTVERSION_TS}/os/freebsd/x86/libspawner.so
+.if ${ARCH} == "i386"
+RM_PLATFORM= win32 solaris qnx macosx aix linux.ppc linux.ia64 linux.x86_64
+PLIST_SUB+= RM_I386=""
+PLIST_SUB+= RM_AMD64="@comment "
.endif
-
-SCRIPTS_ENV= PORTVERSION_TS=${PORTVERSION_TS} UNZIP_CMD=${UNZIP_CMD}
-
-MAKE_ENV+= ECLIPSE_ARCH=${ECLIPSE_ARCH} \
- ECLIPSE_OS=${ECLIPSE_OS} \
- PORTVERSION=${PORTVERSION} \
- PORTVERSION_TS=${PORTVERSION_TS} \
- JAVA_HOME=${JAVA_HOME}
-PLIST_SUB+= PORTVERSION_TS=${PORTVERSION_TS}
-
-CDT_DIRS= eclipse/features/org.eclipse.cdt_${PORTVERSION_TS} \
- eclipse/plugins/org.eclipse.cdt.core.freebsd.x86_${PORTVERSION_TS} \
- eclipse/plugins/org.eclipse.cdt.core.freebsd_${PORTVERSION_TS} \
- eclipse/plugins/org.eclipse.cdt.core_${PORTVERSION_TS} \
- eclipse/plugins/org.eclipse.cdt.managedbuilder.gnu.ui_${PORTVERSION_TS} \
- eclipse/plugins/org.eclipse.cdt.source.freebsd.gtk.x86_${PORTVERSION_TS} \
- eclipse/plugins/org.eclipse.cdt.source.linux.gtk.x86_${PORTVERSION_TS} \
- eclipse/plugins/org.eclipse.cdt.source_${PORTVERSION_TS}
-
-CDT_JARS= eclipse/plugins/org.eclipse.cdt.core_${PORTVERSION_TS}.jar \
- eclipse/plugins/org.eclipse.cdt.debug.core_${PORTVERSION_TS}.jar \
- eclipse/plugins/org.eclipse.cdt.debug.mi.core_${PORTVERSION_TS}.jar \
- eclipse/plugins/org.eclipse.cdt.debug.mi.ui_${PORTVERSION_TS}.jar \
- eclipse/plugins/org.eclipse.cdt.debug.ui_${PORTVERSION_TS}.jar \
- eclipse/plugins/org.eclipse.cdt.doc.isv_${PORTVERSION_TS}.jar \
- eclipse/plugins/org.eclipse.cdt.doc.user_${PORTVERSION_TS}.jar \
- eclipse/plugins/org.eclipse.cdt.launch_${PORTVERSION_TS}.jar \
- eclipse/plugins/org.eclipse.cdt.make.core_${PORTVERSION_TS}.jar \
- eclipse/plugins/org.eclipse.cdt.make.ui_${PORTVERSION_TS}.jar \
- eclipse/plugins/org.eclipse.cdt.managedbuilder.core_${PORTVERSION_TS}.jar \
- eclipse/plugins/org.eclipse.cdt.managedbuilder.gnu.ui_${PORTVERSION_TS}.jar \
- eclipse/plugins/org.eclipse.cdt.managedbuilder.ui_${PORTVERSION_TS}.jar \
- eclipse/plugins/org.eclipse.cdt.refactoring_${PORTVERSION_TS}.jar \
- eclipse/plugins/org.eclipse.cdt.sdk_${PORTVERSION_TS}.jar \
- eclipse/plugins/org.eclipse.cdt.ui_${PORTVERSION_TS}.jar \
- eclipse/plugins/org.eclipse.cdt_${PORTVERSION_TS}.jar
-
-PLIST_FILES= ${CDT_JARS:S/^eclipse/lib\/eclipse/}
-
-do-build:
- @${FIND} ${WRKSRC} -name \*.orig -delete
-.if (${ARCH} == "i386")
- @(cd ${WRKSRC}/eclipse/plugins/org.eclipse.cdt.source.freebsd.gtk.x86_${PORTVERSION_TS}/src/org.eclipse.cdt.core.freebsd_${PORTVERSION_TS}/library; \
- ${SETENV} ${MAKE_ENV} ${GMAKE})
+.if ${ARCH} == "amd64"
+RM_PLATFORM= win32 solaris qnx macosx aix linux.ppc linux.ia64 linux.x86
+PLIST_SUB+= RM_I386="@comment "
+PLIST_SUB+= RM_AMD64=""
.endif
-.if !defined(INSTALL_AS_USER)
-pre-install:
- ${SU_CMD} "${CHMOD} -R go-w ${WRKSRC}"
- ${SU_CMD} "${CHOWN} -R 0:0 ${WRKSRC}"
-.endif
+do-patch:
+# remove unneeded files
+.for i in ${RM_PLATFORM}
+ @${RM} ${WRKDIR}/plugins/${RM_NAME}.${i}.source_${RM_VERSION}.jar
+ @${RM} ${WRKDIR}/plugins/${RM_NAME}.${i}_${RM_VERSION}.jar
+.endfor
+.for i in ${RM_XLC}
+ @${RM} ${WRKDIR}/${i}
+.endfor
do-install:
- @${MKDIR} ${PREFIX}/lib/eclipse
- @${MKDIR} ${PREFIX}/lib/eclipse/features
- @${MKDIR} ${PREFIX}/lib/eclipse/plugins
- cd ${WRKSRC} && ${INSTALL_DATA} ${CDT_JARS} ${PREFIX}/lib/eclipse/plugins
- cd ${WRKSRC} && ${FIND} ${CDT_DIRS} \
- -type f -not -name '*.o' -print0 | ${XARGS} -0 ${TAR} -cf - | ( cd ${PREFIX}/lib && ${TAR} -xf - )
-
-post-install:
- cd ${WRKSRC} && ${FIND} -d ${CDT_DIRS} \
- -type f -not -name '*.o' -print | ${SED} -e 's,^eclipse,lib/eclipse,' >> ${TMPPLIST}
- cd ${WRKSRC} && ${FIND} -d ${CDT_DIRS} \
- -type d -not -name '*.o' -print0 | ${XARGS} -0 printf '@dirrm lib/%s\n' >> ${TMPPLIST}
+ @${MKDIR} ${PREFIX}/lib/eclipse/features/${PLUGIN}/
+ @${MKDIR} ${PREFIX}/lib/eclipse/plugins/${PLUGIN}/
+.for i in features plugins
+ @(cd ${WRKDIR}/${i} && ${COPYTREE_SHARE} \* ${PREFIX}/lib/eclipse/${i}/)
+.endfor
.include <bsd.port.post.mk>
diff --git a/java/eclipse-cdt/distinfo b/java/eclipse-cdt/distinfo
index a0696ff20c55..f364f914e801 100644
--- a/java/eclipse-cdt/distinfo
+++ b/java/eclipse-cdt/distinfo
@@ -1,3 +1,3 @@
-MD5 (eclipse/org.eclipse.cdt.sdk-3.1.2-linux.x86.tar.gz) = 3c6a25246243683ac40c2a2beb0a2e57
-SHA256 (eclipse/org.eclipse.cdt.sdk-3.1.2-linux.x86.tar.gz) = d5e22e9db29a6f4f76fd7676e4d53b4fd64bca196660aa16246cc481fc869b9a
-SIZE (eclipse/org.eclipse.cdt.sdk-3.1.2-linux.x86.tar.gz) = 17767758
+MD5 (cdt-master-6.0.2.zip) = a9375b870ce627143b3eaa1e24b77b35
+SHA256 (cdt-master-6.0.2.zip) = 48ad201c4696791f8cb3a10c1a198b932a54e488a8170a63315f04695ac4ad21
+SIZE (cdt-master-6.0.2.zip) = 45840691
diff --git a/java/eclipse-cdt/pkg-plist b/java/eclipse-cdt/pkg-plist
index 435f005646ca..a3c9d8255cf2 100644
--- a/java/eclipse-cdt/pkg-plist
+++ b/java/eclipse-cdt/pkg-plist
@@ -1 +1,105 @@
-@comment automatically generated plist
+lib/eclipse/features/org.eclipse.cdt.build.crossgcc_1.0.0.201002161416.jar
+lib/eclipse/features/org.eclipse.cdt.core.lrparser.feature_5.1.0.201002161416.jar
+lib/eclipse/features/org.eclipse.cdt.core.lrparser.sdk_5.1.0.201002161416.jar
+lib/eclipse/features/org.eclipse.cdt.core.lrparser.source_5.1.0.201002161416.jar
+lib/eclipse/features/org.eclipse.cdt.core.parser.upc.feature_5.1.0.201002161416.jar
+lib/eclipse/features/org.eclipse.cdt.core.parser.upc.sdk_5.1.0.201002161416.jar
+lib/eclipse/features/org.eclipse.cdt.core.parser.upc.source_5.1.0.201002161416.jar
+lib/eclipse/features/org.eclipse.cdt.debug.gdbjtag_5.1.0.201002161416.jar
+lib/eclipse/features/org.eclipse.cdt.debug.ui.memory.source_1.2.0.201002161416.jar
+lib/eclipse/features/org.eclipse.cdt.debug.ui.memory_1.2.0.201002161416.jar
+lib/eclipse/features/org.eclipse.cdt.examples.dsf_2.0.0.201002161416.jar
+lib/eclipse/features/org.eclipse.cdt.gnu.build.source_6.0.0.201002161416.jar
+lib/eclipse/features/org.eclipse.cdt.gnu.build_6.0.0.201002161416.jar
+lib/eclipse/features/org.eclipse.cdt.gnu.debug.source_6.0.0.201002161416.jar
+lib/eclipse/features/org.eclipse.cdt.gnu.debug_6.0.0.201002161416.jar
+lib/eclipse/features/org.eclipse.cdt.gnu.dsf.source_2.0.0.201002161416.jar
+lib/eclipse/features/org.eclipse.cdt.gnu.dsf_2.0.0.201002161416.jar
+lib/eclipse/features/org.eclipse.cdt.launch.remote_6.0.0.201002161416.jar
+lib/eclipse/features/org.eclipse.cdt.master_6.0.1.jar
+lib/eclipse/features/org.eclipse.cdt.mylyn_5.1.0.201002161416.jar
+lib/eclipse/features/org.eclipse.cdt.p2_1.0.0.201002161416.jar
+lib/eclipse/features/org.eclipse.cdt.platform.source_6.0.2.201002161416.jar
+lib/eclipse/features/org.eclipse.cdt.platform_6.0.2.201002161416.jar
+lib/eclipse/features/org.eclipse.cdt.sdk_6.0.2.201002161416.jar
+lib/eclipse/features/org.eclipse.cdt.testing_6.0.0.201002161416.jar
+lib/eclipse/features/org.eclipse.cdt.util_5.1.0.201002161416.jar
+lib/eclipse/features/org.eclipse.cdt_6.0.2.201002161416.jar
+
+lib/eclipse/plugins/net.sourceforge.lpg.lpgjavaruntime_1.1.0.v200803061910.jar
+lib/eclipse/plugins/org.eclipse.ant.optional.junit_3.2.200.jar
+lib/eclipse/plugins/org.eclipse.cdt.build.crossgcc_1.0.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.core.linux.source_5.1.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.core.linux_5.1.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.core.lrparser.source_5.1.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.core.lrparser_5.1.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.core.parser.upc.source_5.1.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.core.parser.upc_5.1.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.core.source_5.1.2.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.core.tests_5.1.2.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.core_5.1.2.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.debug.core.source_6.0.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.debug.core_6.0.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.debug.gdbjtag.core_5.0.100.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.debug.gdbjtag.ui_5.0.100.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.debug.gdbjtag_5.0.100.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.debug.mi.core.source_6.0.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.debug.mi.core_6.0.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.debug.mi.ui.source_6.0.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.debug.mi.ui_6.0.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.debug.ui.memory.memorybrowser.source_1.2.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.debug.ui.memory.memorybrowser_1.2.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.debug.ui.memory.search.source_1.2.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.debug.ui.memory.search_1.2.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.debug.ui.memory.traditional.source_1.2.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.debug.ui.memory.traditional_1.2.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.debug.ui.memory.transport.source_1.2.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.debug.ui.memory.transport_1.2.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.debug.ui.source_6.0.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.debug.ui.tests_6.0.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.debug.ui_6.0.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.doc.isv_5.1.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.doc.user_5.1.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.dsf.gdb.source_2.0.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.dsf.gdb.ui.source_2.0.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.dsf.gdb.ui_2.0.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.dsf.gdb_2.0.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.dsf.source_2.0.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.dsf.ui.source_2.0.1.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.dsf.ui_2.0.1.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.dsf_2.0.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.examples.dsf.pda.ui_2.0.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.examples.dsf.pda_2.0.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.examples.dsf_2.0.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.launch.remote.source_2.2.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.launch.remote_2.2.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.launch.source_6.0.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.launch_6.0.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.make.core.source_6.0.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.make.core_6.0.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.make.ui.source_6.0.1.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.make.ui_6.0.1.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.managedbuilder.core.source_6.0.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.managedbuilder.core.tests_5.0.100.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.managedbuilder.core_6.0.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.managedbuilder.gnu.ui.source_5.0.100.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.managedbuilder.gnu.ui_5.0.100.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.managedbuilder.ui.source_5.1.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.managedbuilder.ui.tests_5.0.100.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.managedbuilder.ui_5.1.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.mylyn.ui_1.0.100.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.mylyn_1.0.100.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.p2_1.0.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.sdk_6.0.2.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.source_6.0.2.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.testing_6.0.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.ui.source_5.1.2.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.ui.tests_5.1.0.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.ui_5.1.2.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt.util_5.0.100.201002161416.jar
+lib/eclipse/plugins/org.eclipse.cdt_6.0.2.201002161416.jar
+lib/eclipse/plugins/org.eclipse.test_3.3.0.jar
+%%RM_AMD64%%lib/eclipse/plugins/org.eclipse.cdt.core.linux.x86_64.source_5.1.0.201002161416.jar
+%%RM_AMD64%%lib/eclipse/plugins/org.eclipse.cdt.core.linux.x86_64_5.1.0.201002161416.jar
+%%RM_I386%%lib/eclipse/plugins/org.eclipse.cdt.core.linux.x86.source_5.1.0.201002161416.jar
+%%RM_I386%%lib/eclipse/plugins/org.eclipse.cdt.core.linux.x86_5.1.0.201002161416.jar