aboutsummaryrefslogtreecommitdiff
path: root/korean/gdick
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2003-08-20 08:46:04 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2003-08-20 08:46:04 +0000
commitab17f82ad5510e30e754ee528366c99918bc772c (patch)
tree6ee9be901209b19bd9166508c38df1a094168f98 /korean/gdick
parent8132a74c0d42d20f225c6bb5ab13ec650a588191 (diff)
downloadports-ab17f82ad5510e30e754ee528366c99918bc772c.tar.gz
ports-ab17f82ad5510e30e754ee528366c99918bc772c.zip
Notes
Diffstat (limited to 'korean/gdick')
-rw-r--r--korean/gdick/Makefile44
-rw-r--r--korean/gdick/distinfo1
-rw-r--r--korean/gdick/files/setup.py7
-rw-r--r--korean/gdick/pkg-descr4
-rw-r--r--korean/gdick/pkg-plist12
5 files changed, 68 insertions, 0 deletions
diff --git a/korean/gdick/Makefile b/korean/gdick/Makefile
new file mode 100644
index 000000000000..e86fff58188a
--- /dev/null
+++ b/korean/gdick/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: ko-gdick
+# Date created: 20 August 2003
+# Whom: Hye-Shik Chang <perky@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gdick
+PORTVERSION= 0.6.1
+CATEGORIES= korean python
+MASTER_SITES= http://ddt.mirstyle.org/data/
+
+MAINTAINER= perky@FreeBSD.org
+COMMENT= English-Korean Dictionary Client for GNOME2
+
+RUN_DEPENDS= ${PYTHONPREFIX_SITELIBDIR}/gtk-2.0/atk.so:${PORTSDIR}/x11-toolkits/py-gtk2
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+USE_BZIP2= yes
+
+.if defined(WITH_GNOME)
+USE_GNOME= gnomehier
+RUN_DEPENDS+= ${PYTHONPREFIX_SITELIBDIR}/gtk-2.0/gconfmodule.so:${PORTSDIR}/x11-toolkits/py-gnome2
+PLIST_SUB= GNOMEONLY=""
+.else
+PLIST_SUB= GNOMEONLY="@comment "
+.endif
+
+post-extract:
+ ${INSTALL_DATA} ${FILESDIR}/setup.py ${WRKSRC}
+
+post-patch:
+.for f in gdick gdick_applet
+ ${SED} -e 's,/usr/bin/gdick.glade,${PREFIX}/share/gdick/gdick.glade,g' \
+ ${WRKSRC}/$f.py > ${WRKSRC}/$f
+.endfor
+
+post-install:
+.if defined(WITH_GNOME)
+ ${INSTALL_DATA} ${WRKSRC}/GNOME_GDick.server ${X11BASE}/libdata/bonobo/servers/
+.endif
+
+.include <bsd.port.mk>
diff --git a/korean/gdick/distinfo b/korean/gdick/distinfo
new file mode 100644
index 000000000000..2829e820a758
--- /dev/null
+++ b/korean/gdick/distinfo
@@ -0,0 +1 @@
+MD5 (gdick-0.6.1.tar.bz2) = 8004643749c5826d99df9fd7c418e9e3
diff --git a/korean/gdick/files/setup.py b/korean/gdick/files/setup.py
new file mode 100644
index 000000000000..ef450fa0a617
--- /dev/null
+++ b/korean/gdick/files/setup.py
@@ -0,0 +1,7 @@
+__version__ = "$FreeBSD$"
+from distutils.core import setup
+setup( name = "gdick",
+ py_modules = ["YahooDict", "YahooView"],
+ scripts = ["gdick", "gdick_applet"],
+ data_files = [("share/gdick", ("gdick.glade",))],
+)
diff --git a/korean/gdick/pkg-descr b/korean/gdick/pkg-descr
new file mode 100644
index 000000000000..2dabce7bc65b
--- /dev/null
+++ b/korean/gdick/pkg-descr
@@ -0,0 +1,4 @@
+GDick is a GTK+-2.0 based Korean dictionary client. It can serve
+as a simple GTK application as well as a GNOME applet.
+
+WWW: http://ddt.mirstyle.org/gdick.html
diff --git a/korean/gdick/pkg-plist b/korean/gdick/pkg-plist
new file mode 100644
index 000000000000..129af94fdea2
--- /dev/null
+++ b/korean/gdick/pkg-plist
@@ -0,0 +1,12 @@
+bin/gdick
+bin/gdick_applet
+%%PYTHON_SITELIBDIR%%/YahooDict.py
+%%PYTHON_SITELIBDIR%%/YahooDict.pyc
+%%PYTHON_SITELIBDIR%%/YahooDict.pyo
+%%PYTHON_SITELIBDIR%%/YahooView.py
+%%PYTHON_SITELIBDIR%%/YahooView.pyc
+%%PYTHON_SITELIBDIR%%/YahooView.pyo
+share/gdick/gdick.glade
+@dirrm share/gdick
+%%GNOMEONLY%%@cwd %%X11BASE%%
+%%GNOMEONLY%%libdata/bonobo/servers/GNOME_GDick.server