aboutsummaryrefslogtreecommitdiff
path: root/korean/ghostscript55httf/Makefile
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>2000-07-19 17:05:46 +0000
committerSatoshi Asami <asami@FreeBSD.org>2000-07-19 17:05:46 +0000
commitad1a91c040d7b68a513de5572e080dc20e6cd4ff (patch)
tree103c2effc1d28baabc2c25acd2811fb9ec9dbfb0 /korean/ghostscript55httf/Makefile
parentae17a4e01099b637e0cb1bac470b04e574820a65 (diff)
downloadports-ad1a91c040d7b68a513de5572e080dc20e6cd4ff.tar.gz
ports-ad1a91c040d7b68a513de5572e080dc20e6cd4ff.zip
Notes
Diffstat (limited to 'korean/ghostscript55httf/Makefile')
-rw-r--r--korean/ghostscript55httf/Makefile165
1 files changed, 81 insertions, 84 deletions
diff --git a/korean/ghostscript55httf/Makefile b/korean/ghostscript55httf/Makefile
index 29ecc17582d2..7a8765f60843 100644
--- a/korean/ghostscript55httf/Makefile
+++ b/korean/ghostscript55httf/Makefile
@@ -1,115 +1,112 @@
-# New ports collection makefile for: freetype-ghostscript
-# Date created: 27 Mar 1998
-# Whom: CHOI Junho <cjh@kr.freebsd.org>
+# New ports collection makefile for: ghostscript/ft
+# Date created: 3 Jul 2000
+# Whom: CHOI Junho <cjh@FreeBSD.org>
#
# $FreeBSD$
#
-# Based on print/ghostscript5 and japanese/vfghostscript5
-# use Adobe's CID-keyed Korean font because there are no wide accepted
-# default korean font yet
-#
PORTNAME= ghostscript
-PORTVERSION= 5.10
-CATEGORIES= korean print
-MASTER_SITES= ftp://ftp.pdb.sni.de/pub/utilities/misc/ \
- http://www.ozemail.com.au/~geoffk/pdfencrypt/ \
- ftp://ftp.cs.wisc.edu/ghost/gnu/gs510/ \
- $(MASTER_SITE_GNU) \
- http://www.ldl.jaist.ac.jp/~akr/nonresearch/free-software/ghostscript/ \
- http://itohws03.ee.noda.sut.ac.jp/~matsuda/VFlib-FT/ \
- ftp://ftp.kr.freebsd.org/pub/users/cjh/gs-ko/ \
- ftp://ftp.kr.freebsd.org/pub/users/cjh/gs-ko/misc/
-MASTER_SITE_SUBDIR= ghostscript
-PKGNAMESUFFIX= -ft
-DISTNAME= ${PKGNAME}
-DISTFILES= ${PCL3_DRV} ${DECRYPT_PDF} ${GS_SOURCES} \
- ${VFLIB_GS} ${KFFTYPE} ${KFFTYPE_PATCH} \
- ${HFFTYPE} ${GS_CID_PATCH}
-EXTRACT_ONLY= ${GS_SOURCES} ${PCL3_DRV}
+PORTVERSION= 5.50
+PKGNAMESUFFIX= -httf
+CATEGORIES= print
+MASTER_SITES= ftp://ftp.cs.wisc.edu/ghost/aladdin/gs550/ \
+ http://www.erdw.ethz.ch/~bonk/ftp/gs-driver-distrib/ \
+ http://www.ozemail.com.au/~geoffk/pdfencrypt/
+DISTFILES= ${GS_SOURCES} ${GS_FONTS_STD} ${GS_FONTS_OTHER} \
+ ${HP850_DRV} ${DECRYPT_PDF}
+
+PATCH_SITES= ftp://ftp.kr.FreeBSD.org/pub/users/cjh/gs-ko/
+PATCHFILES= gs5.50-httf-19990114.diff
+PATCH_DIST_STRIP= -p1
MAINTAINER= cjh@FreeBSD.org
-RUN_DEPENDS= $(LOCALBASE)/share/ghostscript/fonts:${PORTSDIR}/print/gsfonts \
- $(LOCALBASE)/share/ghostscript/fonts/CMap:${PORTSDIR}/korean/munhwafonts-cid \
- $(X11BASE)/lib/X11/fonts/TrueType/gulim.ttf:${PORTSDIR}/korean/baekmukfonts-ttf
+Y2K= http://www.cs.wisc.edu/~ghost/aladdin/y2k.html
+
BUILD_DEPENDS= /nonexistent:${PORTSDIR}/graphics/jpeg:extract \
- /nonexistent:${PORTSDIR}/graphics/png:extract
+ /nonexistent:${PORTSDIR}/graphics/png:extract \
+ unzip:${PORTSDIR}/archivers/unzip
LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png \
ttf.4:${PORTSDIR}/print/freetype
+RUN_DEPENDS= $(X11BASE)/lib/X11/fonts/TrueType/gulim.ttf:${PORTSDIR}/korean/baekmukfonts-ttf
-USE_XLIB= YES
-WRKSRC= ${WRKDIR}/gs5.10
-
+USE_XLIB= yes
+EXTRACT_ONLY= ${GS_SOURCES}
+WRKSRC= ${WRKDIR}/gs5.50
+USE_GMAKE= yes
MAKEFILE= unix-gcc.mak
-#MAKE_FLAGS= prefix=${PREFIX} CFLAGS="${CFLAGS}" -f
-MAKE_FLAGS= prefix=${PREFIX} -f
-MAN1= gs.1 pdf2dsc.1 pdf2ps.1 ps2ascii.1 ps2epsi.1 ps2pdf.1 gs-hpdj.1
-
-GS_SOURCES= ghostscript-5.10.tar.gz
-
-# Additional driver for HP PCL3 Printers
-PCL3_DRV= hpdj-2.6.tar.gz
-
-# replacement for pdf_sec.ps, that allows you to read encrypted PDF files
-DECRYPT_PDF= pdf_sec.ps
-
-# Korean patch files
-# vflib patch
-VFLIB_GS= gs5.10-vflib-1.1.tar.gz
-# kfftype
-KFFTYPE= gs5-kfftype.tar.gz
-# kfftype patches
-KFFTYPE_PATCH= gs5-kfftype-patch1.diff gs5-kfftype-patch2.diff
-# hfftype patch
-HFFTYPE= gs5-hfftype-0.2.tar.gz
-# cid-keyed font bug patch for 5.10
-GS_CID_PATCH= gs5.10-cid-bugfix.diff
+MAN1= gs.1 pdf2dsc.1 pdf2ps.1 ps2ascii.1 ps2epsi.1 ps2pdf.1 ps2ps.1
+
+GS_SOURCES= ghostscript-5.50.tar.gz
+GS_SOURCES+= ghostscript-5.50gnu.tar.gz
+# Note: the following two are real files that have symlinks with
+# later version numbers pointing to them. To avoid unnecessarily
+# downloading distfiles, do not change these when upgrading the port
+# unless the files really change.
+GS_FONTS_STD= ghostscript-fonts-std-5.50.tar.gz
+GS_FONTS_OTHER= ghostscript-fonts-other-5.50.tar.gz
+
+# Additional driver HP 850, see http://www.erdw.ethz.ch/~bonk/hp850/hp850.html
+HP850_DRV= hp8xxs13.zip
+
+.if defined(NO_A4)
+.else
+CFLAGS+= -DA4
+.endif
+
+pre-fetch:
+.if !defined(NO_A4)
+ @${ECHO_MSG} "Type \"make NO_A4=yes\" if you want not set A4 paper default."
+.else
+ @${ECHO_MSG} "Default paper size is A4."
+.endif
post-extract:
${LN} -s ${WRKDIRPREFIX}${.CURDIR}/../../graphics/jpeg/work/jpeg-* ${WRKSRC}/jpeg
${LN} -s ${WRKDIRPREFIX}${.CURDIR}/../../graphics/png/work/libpng-* ${WRKSRC}/libpng
- # additional PCL3 driver
- $(TAR) -xvf ${WRKDIR}/hpdj-2.6/hpdj.tar -C $(WRKSRC)
- @${CAT} ${WRKSRC}/devs.mak-5.10.add >> ${WRKSRC}/devs.mak
- @${PATCH} -d ${WRKSRC} --forward --quiet -E < ${WRKSRC}/zmedia2.c-5.10.diff
-
-pre-patch:
- cd ${WRKSRC} && tar -xzf ${DISTDIR}/${VFLIB_GS} && \
- ${PATCH} -s -p1 < gs5.10-vflib-1.1/gs5.10-vflib-1.1.diff
- cd ${WRKSRC} && tar -xzf ${DISTDIR}/${KFFTYPE} && \
- cd ${WRKSRC}/kfftype && \
- for file in ${KFFTYPE_PATCH}; do \
- ${PATCH} -s -p0 < ${DISTDIR}/$$file; \
- done && \
- ${CP} -r ${WRKSRC}/kfftype/* ${WRKSRC}/
- cd ${WRKSRC} && tar -xzf ${DISTDIR}/${HFFTYPE} && \
- ${CP} -r ${WRKSRC}/gs5-hfftype-0.2/* ${WRKSRC}/
- cd ${WRKSRC} && ${PATCH} -s -p1 < \
- ${WRKSRC}/gs5-hfftype-0.2/gs5.10-hfftype.diff
- cd ${WRKSRC} && ${PATCH} ${PATCH_DIST_ARGS} < \
- ${DISTDIR}/${GS_CID_PATCH}
+ ${MV} ${WRKSRC}/devs.mak ${WRKSRC}/devs.mak.bak
+ cd ${WRKSRC} && unzip -Lao ${DISTDIR}/${HP850_DRV}
+ ${MV} ${WRKSRC}/devs.mak.bak ${WRKSRC}/devs.mak
do-configure:
- @(cd ${WRKSRC}; ${SH} tar_cat )
+.if defined(BATCH)
+ @${SETENV} WRKSRC=${WRKSRC} ${SH} ${SCRIPTDIR}/configure.batch
+.else
+ @${SETENV} WRKSRC=${WRKSRC} ${SH} ${SCRIPTDIR}/configure
+.endif
pre-build:
- ${SED} -e "s@%%PREFIX%%@${X11BASE}@g" \
+ ${MKDIR} ${WRKSRC}/obj
+ ${SED} -e "s@%%PREFIX%%@${X11BASE}@g" \
${FILESDIR}/hconfig.ps.in > \
${WRKSRC}/hangul/hconfig.ps
pre-install:
@${MKDIR} ${PREFIX}/share/ghostscript ${PREFIX}/bin ${PREFIX}/man/man1
+ (cd ${PREFIX}/share/ghostscript ; \
+ ${TAR} -xzf ${DISTDIR}/${GS_FONTS_STD})
+ (cd ${PREFIX}/share/ghostscript/fonts ; \
+ ${TAR} -xzf ${DISTDIR}/${GS_FONTS_OTHER})
+# install the readme and license file of the hp8xxx driver as well
post-install:
strip ${PREFIX}/bin/gs
- ${INSTALL_DATA} ${DISTDIR}/${DECRYPT_PDF} \
- ${PREFIX}/share/ghostscript/5.10ft
- $(MKDIR) ${PREFIX}/libexec/lpr
- ${INSTALL_SCRIPT} $(WRKSRC)/pj-gs.sh ${PREFIX}/libexec/lpr
- ${INSTALL_SCRIPT} $(WRKSRC)/sysvlp.sh ${PREFIX}/libexec/lpr
- ${INSTALL_SCRIPT} $(WRKSRC)/if-hpdj ${PREFIX}/libexec/lpr
- ${INSTALL_DATA} ${WRKSRC}/gs5-hfftype-0.2/README \
- ${PREFIX}/share/ghostscript/5.10ft/doc/README.ko
+ ${INSTALL_SCRIPT} ${WRKSRC}/unix-lpr.sh ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/lprsetup.sh ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/license.hp8 \
+ ${PREFIX}/share/ghostscript/5.50httf/doc
+ ${INSTALL_DATA} ${WRKSRC}/readme.hp8 \
+ ${PREFIX}/share/ghostscript/5.50httf/doc
+ ${RMDIR} ${PREFIX}/share/ghostscript/5.50httf/hangul/fonts
+.if defined(PDFENCRYPT)
+ ${INSTALL_DATA} ${DISTDIR}/pdf_sec.ps ${PREFIX}/share/ghostscript/5.50httf
+.endif
+
+# encrypted PDF support. can't be packaged due to export control issues.
+.if defined(PDFENCRYPT)
+MASTER_SITES+= http://www.ozemail.com.au/~geoffk/pdfencrypt/
+DISTFILES+= pdf_sec.ps
+RESTRICTED= "Crypto; export controlled, RC4 in PostScript code included"
+.endif
.include <bsd.port.mk>