aboutsummaryrefslogtreecommitdiff
path: root/korean/hanterm-xf86/Makefile
diff options
context:
space:
mode:
authorCHOI Junho <cjh@FreeBSD.org>2001-05-11 12:09:52 +0000
committerCHOI Junho <cjh@FreeBSD.org>2001-05-11 12:09:52 +0000
commit0f0bc40ad443f68f643bb78194e9dfe6490c4a47 (patch)
treeb2aa023a58c1b8aeca72c5f382a1340d1844fbb6 /korean/hanterm-xf86/Makefile
parentd6cdce47b8244804aab8a7a990ef50640e3053aa (diff)
Notes
Diffstat (limited to 'korean/hanterm-xf86/Makefile')
-rw-r--r--korean/hanterm-xf86/Makefile21
1 files changed, 15 insertions, 6 deletions
diff --git a/korean/hanterm-xf86/Makefile b/korean/hanterm-xf86/Makefile
index d78c68b6102d..2ebca8f43946 100644
--- a/korean/hanterm-xf86/Makefile
+++ b/korean/hanterm-xf86/Makefile
@@ -6,23 +6,32 @@
#
PORTNAME= hanterm
-PORTVERSION= 18
+PORTVERSION= 19
CATEGORIES= korean x11
-MASTER_SITES= http://www.kr.FreeBSD.org/~hwang/hanterm/
+MASTER_SITES= http://www.kr.FreeBSD.org/~hwang/hanterm/ \
+ http://hanterm.org/download/hanterm-xf/
PKGNAMESUFFIX= -xf
-DISTNAME= hanterm-xf-p18
+DISTNAME= hanterm${PKGNAMESUFFIX}-p${PORTVERSION}
MAINTAINER= cjh@FreeBSD.org
+LIB_DEPENDS= iconv.2:${PORTSDIR}/converters/iconv
RUN_DEPENDS= ${X11BASE}/lib/X11/fonts/local/johabm16.pcf.gz:${PORTSDIR}/korean/johabfonts
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --with-x --enable-16-color
-CONFIGURE_ENV+= LIBS="-lxpg4"
+CONFIGURE_ARGS+= --enable-16-color
+CONFIGURE_ENV+= LIBS="${LDFLAGS} -L${LOCALBASE}/lib -liconv" \
+ CFLAGS="${CFLAGS} -I${LOCALBASE}/include"
NO_INSTALL_MANPAGES= yes
post-install:
- @${INSTALL_DATA} ${WRKSRC}/Hanterm.ad ${PREFIX}/lib/X11/app-defaults/Hanterm
+ @${INSTALL_DATA} ${WRKSRC}/Hanterm.ad \
+ ${PREFIX}/lib/X11/app-defaults/Hanterm
+ ${MKDIR} ${PREFIX}/share/doc/hanterm-xf
+ ${INSTALL_DATA} ${WRKSRC}/hanterm-doc/README.xf \
+ ${PREFIX}/share/doc/hanterm-xf
+ ${INSTALL_DATA} ${WRKSRC}/hanterm-doc/README.xf.old \
+ ${PREFIX}/share/doc/hanterm-xf
.include <bsd.port.mk>