aboutsummaryrefslogtreecommitdiff
path: root/korean/hanyangfonts/Makefile
diff options
context:
space:
mode:
authorMasafumi Max NAKANE <max@FreeBSD.org>1997-03-30 00:04:11 +0000
committerMasafumi Max NAKANE <max@FreeBSD.org>1997-03-30 00:04:11 +0000
commit7163c68bba7e0dba88730c5b095cdd0bb3c9b809 (patch)
tree5fd8a238a11f955ecf849c890a7d7b2c12452b7e /korean/hanyangfonts/Makefile
parentf7eeb9b5999ccf4c7528558cafd083aeb22c1c32 (diff)
downloadports-7163c68bba7e0dba88730c5b095cdd0bb3c9b809.tar.gz
ports-7163c68bba7e0dba88730c5b095cdd0bb3c9b809.zip
Notes
Diffstat (limited to 'korean/hanyangfonts/Makefile')
-rw-r--r--korean/hanyangfonts/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/korean/hanyangfonts/Makefile b/korean/hanyangfonts/Makefile
new file mode 100644
index 000000000000..b2b2ab0b2aea
--- /dev/null
+++ b/korean/hanyangfonts/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: hanyangfonts
+# Version required: ?
+# Date created: 22 Mar 1997
+# Whom: Choi Jun Ho <junker@jazz.snu.ac.kr>
+#
+# $Id$
+#
+
+DISTNAME= hanyang-font-pcf
+PKGNAME= kr-hanyangfonts-1.0
+CATEGORIES= korean x11
+MASTER_SITES= ftp://ftp.kaist.ac.kr/pub/hangul/fonts/ \
+ ftp://sunsite.kren.nm.kr/pub/packages/hangul/fonts/
+
+MAINTAINER= junker@jazz.snu.ac.kr
+
+USE_X11= yes
+NO_WRKSUBDIR= yes
+
+do-build:
+ @cd ${WRKSRC}; \
+ for fn in \
+ hgm10 hgm12 hgm14 hgm16 hgm18 hgm20 \
+ hmm10 hmm12 hmm14 hmm16 hmm18 hmm20; \
+ do \
+ compress $$fn.pcf; \
+ echo $$fn "compressed"; \
+ done; \
+ mkfontdir .
+
+do-install:
+ @cd ${WRKSRC}; \
+ ${MKDIR} ${PREFIX}/lib/X11/fonts/korean/hanyang; \
+ for fn in \
+ hgm10 hgm12 hgm14 hgm16 hgm18 hgm20 \
+ hmm10 hmm12 hmm14 hmm16 hmm18 hmm20; \
+ do \
+ ${INSTALL_DATA} $$fn.pcf.Z ${PREFIX}/lib/X11/fonts/korean/hanyang; \
+ done; \
+ ${INSTALL_DATA} fonts.dir ${PREFIX}/lib/X11/fonts/korean/hanyang
+
+post-install:
+ @/bin/sh ${PKGDIR}/REQ ${PKGNAME} INSTALL;
+
+.include <bsd.port.mk>