aboutsummaryrefslogtreecommitdiff
path: root/korean/hlatex-psfonts-uhc-extra/Makefile
diff options
context:
space:
mode:
authorCHOI Junho <cjh@FreeBSD.org>2000-07-04 17:55:17 +0000
committerCHOI Junho <cjh@FreeBSD.org>2000-07-04 17:55:17 +0000
commit7962c349ff36752fe2a2468bc6ce5f4c31fd91a9 (patch)
tree0e13a921621bb2a3a7d9fb70e8e48962f33679a4 /korean/hlatex-psfonts-uhc-extra/Makefile
parenta16138541ca38920f71727a47cc66f0a2f73aee5 (diff)
downloadports-7962c349ff36752fe2a2468bc6ce5f4c31fd91a9.tar.gz
ports-7962c349ff36752fe2a2468bc6ce5f4c31fd91a9.zip
Notes
Diffstat (limited to 'korean/hlatex-psfonts-uhc-extra/Makefile')
-rw-r--r--korean/hlatex-psfonts-uhc-extra/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/korean/hlatex-psfonts-uhc-extra/Makefile b/korean/hlatex-psfonts-uhc-extra/Makefile
new file mode 100644
index 000000000000..be18fabb0af3
--- /dev/null
+++ b/korean/hlatex-psfonts-uhc-extra/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: HLaTeX PS fonts(extra)
+# Date created: 2 Jul 2000
+# Whom: CHOI Junho <cjh@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HLaTeX-psfonts-${HLATEX_ENCODING}-extra
+PORTVERSION= 0.99
+CATEGORIES= korean print
+MASTER_SITES= ftp://ftp.linguistik.uni-erlangen.de/pub/hangul/HLaTeX/packed/
+DISTFILES= ${HLATEX_PSFONTS_EXTRA}
+DIST_SUBDIR= hlatex
+EXTRACT_ONLY=
+
+MAINTAINER= cjh@FreeBSD.org
+
+RUN_DEPENDS= ${LOCALBASE}/share/texmf/doc/latex/hlatex/uhc.ks:${PORTSDIR}/korean/hlatex
+
+# just install directly
+NO_BUILD= YES
+NO_WRKSUBDIR= YES
+
+TEXMF= ${PREFIX}/share/texmf
+
+# default encoding
+HLATEX_ENCODING= uhc
+
+# extra fonts
+HLATEX_PSFONTS_EXTRA= uhc-graphic.tar.gz uhc-bom.tar.gz \
+ uhc-gungseo.tar.gz uhc-pilgi.tar.gz \
+ uhc-pen.tar.gz uhc-shinmun.tar.gz \
+ uhc-yetgul.tar.gz uhc-jamo.tar.gz
+
+# Installation according to readme.ks
+do-install:
+ cd ${TEXMF}/fonts/; \
+ for fonts in ${HLATEX_PSFONTS_EXTRA}; \
+ do \
+ ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} \
+ ${_DISTDIR}/$$fonts ${EXTRACT_AFTER_ARGS}; \
+ done; \
+ ${PREFIX}/bin/texhash
+
+.include <bsd.port.mk>