aboutsummaryrefslogtreecommitdiff
path: root/korean/hlatex-wansung/Makefile
diff options
context:
space:
mode:
authorCHOI Junho <cjh@FreeBSD.org>2000-07-04 18:13:52 +0000
committerCHOI Junho <cjh@FreeBSD.org>2000-07-04 18:13:52 +0000
commit4f95dab943a9f6da51cf4847d9fe309e1983e487 (patch)
treeda88082f8baa45dc6814683acd605b5877af56ec /korean/hlatex-wansung/Makefile
parent68b0272a354aa0d0c622c542560c6d118c3c6d11 (diff)
downloadports-4f95dab943a9f6da51cf4847d9fe309e1983e487.tar.gz
ports-4f95dab943a9f6da51cf4847d9fe309e1983e487.zip
Notes
Diffstat (limited to 'korean/hlatex-wansung/Makefile')
-rw-r--r--korean/hlatex-wansung/Makefile130
1 files changed, 41 insertions, 89 deletions
diff --git a/korean/hlatex-wansung/Makefile b/korean/hlatex-wansung/Makefile
index 22fe5ab45555..3a58d74ddb71 100644
--- a/korean/hlatex-wansung/Makefile
+++ b/korean/hlatex-wansung/Makefile
@@ -1,119 +1,71 @@
-# New ports collection makefile for: HLaTeX PS fonts-wansungstd
-# Date created: Sun Aug 9 18:05:29 KST 1998
-# Whom: CHOI Junho <cjh@kr.freebsd.org>
+# New ports collection makefile for: HLaTeX wansung extension
+# Date created: 2 Jul 2000
+# Whom: CHOI Junho <cjh@FreeBSD.org>
#
# $FreeBSD$
#
-PORTNAME= HLaTeX-${HLATEX_ENCODING}std
-PORTVERSION= 0.98
-CATEGORIES= korean print
-MASTER_SITES= ftp://ftp.kr.freebsd.org/pub/FreeBSD-kr/distfiles/hlatex98/
-DISTNAME= HLaTeX-${HLATEX_ENCODING}-0.98
-DISTFILES= HLaTeX-0.98.tar.bz2 ${HLATEX_FONTS_BASE}
+PORTNAME= HLaTeX-wansung
+PORTVERSION= 0.991
+CATEGORIES= korean print
+MASTER_SITES= ftp://ftp.linguistik.uni-erlangen.de/pub/hangul/HLaTeX/packed/unsupported/
+DISTNAME= wansung
+DIST_SUBDIR= hlatex
-MAINTAINER= cjh@kr.freebsd.org
+MAINTAINER= cjh@FreeBSD.org
-# in fact, it need to install.
-# and it depends teTeX.
-BUILD_DEPENDS= latex:${PORTSDIR}/print/teTeX
-RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
+# it depends on HLaTeX(uhc)
+RUN_DEPENDS= ${LOCALBASE}/share/texmf/doc/latex/hlatex/uhc.ks:${PORTSDIR}/korean/hlatex
-USE_BZIP2= YES
-DIST_SUBDIR= hlatex98 # too many distfiles
-EXTRACT_ONLY= HLaTeX-0.98.tar.bz2
+TEXMF= ${PREFIX}/share/texmf
+WRKSRC= ${WRKDIR}/wansung
-TEXMF= ${PREFIX}/share/texmf
-HLATEX_ENCODING= wansung
-# default font. includes complete Myoungjo and Gothic fonts.
-HLATEX_FONTS_BASE = common.tar.bz2 \
- wsmj.tar.bz2 wsgt.tar.bz2 \
- hanja-myoungjo.tar.bz2 hanja-gothic.tar.bz2 \
- hsym.tar.bz2 taza.tar.bz2
-# installation files
-HLATEX_BASE = \
- hfont.tex hangul.sty hfont.sty josa.tab hfont.cfg hltx209.cfg \
- hsfonts.def VERSION0.98
-HLATEX_FD_BASE = \
- hhgs.fd hhgt.fd hhpgs.fd hhpgt.fd hhpsm.fd hhptt.fd hhsm.fd \
- hhtt.fd hsgt.fd hspgt.fd hspsm.fd hsptt.fd hssm.fd hstt.fd \
- hwbm.fd hwgr.fd hwgs.fd hwgt.fd hwmg.fd hwmgt.fd hwmj.fd \
- hwmmj.fd hwmnv.fd hwmsr.fd hwmtt.fd hwol.fd hwpbm.fd hwpg.fd \
- hwpgr.fd hwpgs.fd hwpgt.fd hwpmg.fd hwpmgt.fd hwpmj.fd hwpmmj.fd \
- hwpmnv.fd hwpmsr.fd hwpmtt.fd hwpn.fd hwpol.fd hwppg.fd hwppn.fd \
- hwpsm.fd hwpyt.fd hwsm.fd hwyt.fd
-HLATEX_DOC_BASE = \
- changelog.ks complang.tex hlguide.tex hlguide.dvi hlguide.bib \
- doc/compword.pdf.bz2 doc/compword.ps.bz2 doc/hlguide.ps.bz2 \
- news.ks onews.ks readme.eng readme.ks \
- ${HLATEX_ENCODING}/${HLATEX_ENCODING}.ks Fontmap
-HLATEX_SAMPLE_BASE = \
- sample/a.tex sample/p.tex sample/f.tex sample/readme.ks
+# documents.
+HLATEX_DOC_BASE= wansung.ks fonts/mkhfonts.tex
# psfonts.map, special.map
# it should be downloadable, so use wan-down.map
+# why? otherwise you need nasty gs Fontmap setup...
do-build:
- ${CAT} ${TEXMF}/fontname/special.map \
- ${WRKDIR}/${HLATEX_ENCODING}/config/special.map \
- > ${WRKDIR}/special.map
${CAT} ${TEXMF}/dvips/config/psfonts.map \
- ${WRKDIR}/${HLATEX_ENCODING}/config/wan-down.map \
+ ${WRKSRC}/config/wan-down.map \
> ${WRKDIR}/psfonts.map
- ${SED} 's@/usr/tex@/usr/local@' \
- ${WRKDIR}/${HLATEX_ENCODING}/config/Fontmap.wan \
+ ${SED} 's@/usr/tex/share/texmf@${PREFIX}/share/texmf@' \
+ ${WRKSRC}/config/Fontmap.wan \
> ${WRKDIR}/Fontmap
# Installation according to readme.ks
do-install:
- # Part 1: install psfonts, special, Fontmap
- # psfonts
- ${MV} ${TEXMF}/fontname/special.map \
- ${TEXMF}/fontname/special.map.beforehlatex
- ${INSTALL_DATA} ${WRKDIR}/special.map ${TEXMF}/fontname
- # special
+ # Part 1: install psfonts.map
+ # psfonts.map
${MV} ${TEXMF}/dvips/config/psfonts.map \
- ${TEXMF}/dvips/config/psfonts.map.beforehlatex
+ ${TEXMF}/dvips/config/psfonts.map.beforehlatex-wansung
${INSTALL_DATA} ${WRKDIR}/psfonts.map ${TEXMF}/dvips/config
- # Fontmap
- #[ -d ${PREFIX}/share/ghostscript/fonts ] && \
- # ${CP} ${WRKDIR}/Fontmap \
- # ${PREFIX}/share/ghostscript/fonts
- # Part 2: macros
- ${MKDIR} ${TEXMF}/tex/latex/hlatex
- for file in ${HLATEX_BASE}; \
- do \
- ${INSTALL_DATA} \
- ${WRKDIR}/$$file ${TEXMF}/tex/latex/hlatex; \
- done
- for file in ${HLATEX_FD_BASE}; \
- do \
- ${INSTALL_DATA} \
- ${WRKDIR}/${HLATEX_ENCODING}/$$file ${TEXMF}/tex/latex/hlatex; \
- done
+
+ # Part 2: macros, style, font descriptions
+ ${MKDIR} ${TEXMF}/tex/latex/hlatex/wansung
+
+ ## fd files
+ ${INSTALL_DATA} ${WRKSRC}/*.fd \
+ ${TEXMF}/tex/latex/hlatex/wansung
+
+ ## style, defs
+ ${INSTALL_DATA} ${WRKSRC}/wanfont.sty \
+ ${WRKSRC}/hsfonts.def \
+ ${TEXMF}/tex/latex/hlatex/wansung
# Part 3: documents and samples
- ${MKDIR} ${TEXMF}/doc/latex/hlatex/
for file in ${HLATEX_DOC_BASE}; \
do \
${INSTALL_DATA} \
- ${WRKDIR}/$$file ${TEXMF}/doc/latex/hlatex; \
- done
- ${MKDIR} ${TEXMF}/doc/latex/hlatex/sample
- for file in ${HLATEX_SAMPLE_BASE}; \
- do \
- ${INSTALL_DATA} \
- ${WRKDIR}/$$file ${TEXMF}/doc/latex/hlatex/sample; \
+ ${WRKSRC}/$$file ${TEXMF}/doc/latex/hlatex; \
done
- # Part 4: default mf fonts
- cd ${TEXMF}/fonts/; \
- for fonts in ${HLATEX_FONTS_BASE}; \
- do \
- ${EXTRACT_CMD} \
- ${EXTRACT_BEFORE_ARGS} \
- ${_DISTDIR}/$$fonts ${EXTRACT_AFTER_ARGS}; \
- done
- # Part 5: rehash
+ ### Fontmap...
+ ${INSTALL_DATA} ${WRKDIR}/Fontmap \
+ ${TEXMF}/doc/latex/hlatex/sample/Fontmap.wansung
+
+ # Part 4: rehash
${PREFIX}/bin/texhash
.include <bsd.port.mk>