aboutsummaryrefslogtreecommitdiff
path: root/korean/imhangul-gtk2
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2016-09-15 18:12:44 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2016-09-15 18:12:44 +0000
commitc2f2e891a9838ec1929dd1499738b9e92c8ec9d3 (patch)
tree781bec1d7a68a46750a7370c04a91f8820a905fb /korean/imhangul-gtk2
parent52c5d9c7fad3fdc302b7b686da5f76a19c87d5c3 (diff)
downloadports-c2f2e891a9838ec1929dd1499738b9e92c8ec9d3.tar.gz
ports-c2f2e891a9838ec1929dd1499738b9e92c8ec9d3.zip
Notes
Diffstat (limited to 'korean/imhangul-gtk2')
-rw-r--r--korean/imhangul-gtk2/Makefile41
-rw-r--r--korean/imhangul-gtk2/distinfo3
-rw-r--r--korean/imhangul-gtk2/pkg-descr7
-rw-r--r--korean/imhangul-gtk2/pkg-plist4
4 files changed, 55 insertions, 0 deletions
diff --git a/korean/imhangul-gtk2/Makefile b/korean/imhangul-gtk2/Makefile
new file mode 100644
index 000000000000..82c13187d85c
--- /dev/null
+++ b/korean/imhangul-gtk2/Makefile
@@ -0,0 +1,41 @@
+# Created by: Junho CHOI <junho.choi@gmail.com>
+# $FreeBSD$
+
+PORTNAME= imhangul
+PORTVERSION= 2.1.1
+CATEGORIES= korean
+PKGNAMESUFFIX= -gtk2
+
+MAINTAINER= jkim@FreeBSD.org
+COMMENT= Hangul input module for GTK+ 2.0
+
+LICENSE= LGPL21+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libhangul.so:korean/libhangul \
+ libfreetype.so:print/freetype2 \
+ libfontconfig.so:x11-fonts/fontconfig
+
+CONFLICTS_INSTALL= ko-imhangul-[0-2].*
+
+GH_ACCOUNT= choehwanjin
+GH_TAGNAME= d2f555d
+USE_GITHUB= yes
+
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+USE_GNOME= cairo gdkpixbuf2 gtk20
+USES= autoreconf gmake libtool pkgconfig
+
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
+NLS_USES= gettext localbase
+
+post-patch-NLS-off:
+ @${REINPLACE_CMD} -e '/^SUBDIRS /s| po||' ${WRKSRC}/Makefile.am
+ @${REINPLACE_CMD} -e '/^po\/Makefile\.in/d' ${WRKSRC}/configure.in
+
+pre-configure-NLS-on:
+ @(cd ${WRKSRC} && ${LOCALBASE}/bin/glib-gettextize)
+
+.include <bsd.port.mk>
diff --git a/korean/imhangul-gtk2/distinfo b/korean/imhangul-gtk2/distinfo
new file mode 100644
index 000000000000..d37e77938f5c
--- /dev/null
+++ b/korean/imhangul-gtk2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1473877928
+SHA256 (choehwanjin-imhangul-2.1.1-d2f555d_GH0.tar.gz) = e489cb293da229cb1e07d7f301e8fe4b65396cd762aca30aa54cd1555f354288
+SIZE (choehwanjin-imhangul-2.1.1-d2f555d_GH0.tar.gz) = 256752
diff --git a/korean/imhangul-gtk2/pkg-descr b/korean/imhangul-gtk2/pkg-descr
new file mode 100644
index 000000000000..9323eb15c7b1
--- /dev/null
+++ b/korean/imhangul-gtk2/pkg-descr
@@ -0,0 +1,7 @@
+Hangul Input Module for GTK+ 2.0
+
+Input method of GTK+ 2.0 widget. To select this modules, click
+right button in gtk20 text widget and select "Input Methods" -
+"Hangul" (not KSC5601).
+
+WWW: http://code.google.com/p/imhangul/
diff --git a/korean/imhangul-gtk2/pkg-plist b/korean/imhangul-gtk2/pkg-plist
new file mode 100644
index 000000000000..95d1537dfc78
--- /dev/null
+++ b/korean/imhangul-gtk2/pkg-plist
@@ -0,0 +1,4 @@
+lib/gtk-2.0/immodules/im-hangul.so
+%%NLS%%share/locale/ko/LC_MESSAGES/im-hangul.mo
+@postexec %D/bin/gtk-query-immodules-2.0 --update-cache
+@postunexec %D/bin/gtk-query-immodules-2.0 --update-cache