aboutsummaryrefslogtreecommitdiff
path: root/korean/nabi/Makefile
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2003-08-05 10:39:10 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2003-08-05 10:39:10 +0000
commitfb53d412c9b5b66ccbd22e66b01bc29d5099dab7 (patch)
tree78db25980cbe9d7a4ff26373a6c9d49494e0b41b /korean/nabi/Makefile
parentb572e778c1268c293e36e2568d2218020275662f (diff)
downloadports-fb53d412c9b5b66ccbd22e66b01bc29d5099dab7.tar.gz
ports-fb53d412c9b5b66ccbd22e66b01bc29d5099dab7.zip
Notes
Diffstat (limited to 'korean/nabi/Makefile')
-rw-r--r--korean/nabi/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/korean/nabi/Makefile b/korean/nabi/Makefile
new file mode 100644
index 000000000000..2df290fc68a9
--- /dev/null
+++ b/korean/nabi/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: nabi
+# Date created: 5 August 2003
+# Whom: Hye-Shik Chang <perky@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nabi
+PORTVERSION= 0.1
+CATEGORIES= korean gnome x11
+MASTER_SITES= http://download.kldp.net/imhangul/
+
+MAINTAINER= perky@FreeBSD.org
+COMMENT= Hangul X Input Method for Everywhere
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOME= gnomeprefix gnomehack gnomepanel
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" LIBS="-L${X11BASE}/lib"
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,#include <malloc.h>,,' ${WRKSRC}/IMdkit/IMConn.c
+
+post-install:
+ cd ${WRKSRC}/po && ${MAKE} install-data-yes
+
+.include <bsd.port.mk>