aboutsummaryrefslogtreecommitdiff
path: root/korean/texinfo/Makefile
diff options
context:
space:
mode:
authorCHOI Junho <cjh@FreeBSD.org>2000-09-25 16:06:44 +0000
committerCHOI Junho <cjh@FreeBSD.org>2000-09-25 16:06:44 +0000
commite231e5986aa5d23f562e018362a3cbc63d22ced1 (patch)
tree81bba9e5508a139a9ca81cea9b2075215ddace22 /korean/texinfo/Makefile
parent2e1ac8d84933bc250d5d6718be8ca262ae8ed527 (diff)
downloadports-e231e5986aa5d23f562e018362a3cbc63d22ced1.tar.gz
ports-e231e5986aa5d23f562e018362a3cbc63d22ced1.zip
Notes
Diffstat (limited to 'korean/texinfo/Makefile')
-rw-r--r--korean/texinfo/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/korean/texinfo/Makefile b/korean/texinfo/Makefile
new file mode 100644
index 000000000000..8bdcac39ea8d
--- /dev/null
+++ b/korean/texinfo/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: texinfo
+# Date created: 25 Sep 2000
+# Whom: cjh
+#
+# $FreeBSD$
+#
+
+PORTNAME= texinfo
+PORTVERSION= 0.4.1
+CATEGORIES= korean print
+MASTER_SITES= http://master.debian.or.kr/~cwryu/archive/texinfo-ko/
+DISTNAME= ${PORTNAME}-ko-${PORTVERSION}
+
+MAINTAINER= cjh@FreeBSD.org
+
+LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
+RUN_DEPENDS= ${LOCALBASE}/share/texmf/doc/latex/hlatex/uhc.ks:${PORTSDIR}/korean/hlatex
+
+GNU_CONFIGURE= YES
+USE_GMAKE= YES
+
+# local variables.
+TEXMF= ${PREFIX}/share/texmf
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/doc/texinfo-ko.tex \
+ ${WRKSRC}/doc/texinfo-ko-HLaTeX.tex \
+ ${TEXMF}/tex/texinfo
+ ${INSTALL_PROGRAM} ${WRKSRC}/util/texindex \
+ ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/makeinfo/makeinfo \
+ ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/share/doc/texinfo-ko
+ ${INSTALL_DATA} ${WRKSRC}/README.ko \
+ ${WRKSRC}/NEWS.ko \
+ ${WRKSRC}/TODO.ko \
+ ${PREFIX}/share/doc/texinfo-ko
+
+post-install:
+ ${PREFIX}/bin/texhash
+
+.include <bsd.port.mk>