aboutsummaryrefslogtreecommitdiff
path: root/korean
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2016-09-15 18:12:44 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2016-09-15 18:12:44 +0000
commitc2f2e891a9838ec1929dd1499738b9e92c8ec9d3 (patch)
tree781bec1d7a68a46750a7370c04a91f8820a905fb /korean
parent52c5d9c7fad3fdc302b7b686da5f76a19c87d5c3 (diff)
downloadports-c2f2e891a9838ec1929dd1499738b9e92c8ec9d3.tar.gz
ports-c2f2e891a9838ec1929dd1499738b9e92c8ec9d3.zip
Split korean/imhangul into korean/imhangul-gtk2 and korean/imhangul-gtk3.
Notes
Notes: svn path=/head/; revision=422221
Diffstat (limited to 'korean')
-rw-r--r--korean/Makefile3
-rw-r--r--korean/imhangul-gtk2/Makefile41
-rw-r--r--korean/imhangul-gtk2/distinfo (renamed from korean/imhangul/distinfo)2
-rw-r--r--korean/imhangul-gtk2/pkg-descr (renamed from korean/imhangul/pkg-descr)4
-rw-r--r--korean/imhangul-gtk2/pkg-plist4
-rw-r--r--korean/imhangul-gtk3/Makefile (renamed from korean/imhangul/Makefile)20
-rw-r--r--korean/imhangul-gtk3/distinfo3
-rw-r--r--korean/imhangul-gtk3/files/patch-Makefile.am (renamed from korean/imhangul/files/patch-Makefile.am)0
-rw-r--r--korean/imhangul-gtk3/pkg-descr7
-rw-r--r--korean/imhangul-gtk3/pkg-plist4
-rw-r--r--korean/imhangul/pkg-plist5
11 files changed, 70 insertions, 23 deletions
diff --git a/korean/Makefile b/korean/Makefile
index d3c77922a971..cb3323c9fa92 100644
--- a/korean/Makefile
+++ b/korean/Makefile
@@ -19,7 +19,8 @@
SUBDIR += hpscat
SUBDIR += hunspell
SUBDIR += ibus-hangul
- SUBDIR += imhangul
+ SUBDIR += imhangul-gtk2
+ SUBDIR += imhangul-gtk3
SUBDIR += kaistfonts
SUBDIR += kde4-l10n
SUBDIR += ko.TeX
diff --git a/korean/imhangul-gtk2/Makefile b/korean/imhangul-gtk2/Makefile
new file mode 100644
index 000000000000..82c13187d85c
--- /dev/null
+++ b/korean/imhangul-gtk2/Makefile
@@ -0,0 +1,41 @@
+# Created by: Junho CHOI <junho.choi@gmail.com>
+# $FreeBSD$
+
+PORTNAME= imhangul
+PORTVERSION= 2.1.1
+CATEGORIES= korean
+PKGNAMESUFFIX= -gtk2
+
+MAINTAINER= jkim@FreeBSD.org
+COMMENT= Hangul input module for GTK+ 2.0
+
+LICENSE= LGPL21+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libhangul.so:korean/libhangul \
+ libfreetype.so:print/freetype2 \
+ libfontconfig.so:x11-fonts/fontconfig
+
+CONFLICTS_INSTALL= ko-imhangul-[0-2].*
+
+GH_ACCOUNT= choehwanjin
+GH_TAGNAME= d2f555d
+USE_GITHUB= yes
+
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+USE_GNOME= cairo gdkpixbuf2 gtk20
+USES= autoreconf gmake libtool pkgconfig
+
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
+NLS_USES= gettext localbase
+
+post-patch-NLS-off:
+ @${REINPLACE_CMD} -e '/^SUBDIRS /s| po||' ${WRKSRC}/Makefile.am
+ @${REINPLACE_CMD} -e '/^po\/Makefile\.in/d' ${WRKSRC}/configure.in
+
+pre-configure-NLS-on:
+ @(cd ${WRKSRC} && ${LOCALBASE}/bin/glib-gettextize)
+
+.include <bsd.port.mk>
diff --git a/korean/imhangul/distinfo b/korean/imhangul-gtk2/distinfo
index 21709ceaa0f9..d37e77938f5c 100644
--- a/korean/imhangul/distinfo
+++ b/korean/imhangul-gtk2/distinfo
@@ -1,5 +1,3 @@
TIMESTAMP = 1473877928
SHA256 (choehwanjin-imhangul-2.1.1-d2f555d_GH0.tar.gz) = e489cb293da229cb1e07d7f301e8fe4b65396cd762aca30aa54cd1555f354288
SIZE (choehwanjin-imhangul-2.1.1-d2f555d_GH0.tar.gz) = 256752
-SHA256 (choehwanjin-imhangul-3.1.1-85f6d10_GH0.tar.gz) = a2bd9baf56c5b624c035ce6890553fb513feb6404453549a2f523691df86f2cc
-SIZE (choehwanjin-imhangul-3.1.1-85f6d10_GH0.tar.gz) = 256731
diff --git a/korean/imhangul/pkg-descr b/korean/imhangul-gtk2/pkg-descr
index d76e609492a4..9323eb15c7b1 100644
--- a/korean/imhangul/pkg-descr
+++ b/korean/imhangul-gtk2/pkg-descr
@@ -1,6 +1,6 @@
-GTK+-2.0 Hangul Input Module
+Hangul Input Module for GTK+ 2.0
-Input method of gtk-2.0 widget. To select this modules, click
+Input method of GTK+ 2.0 widget. To select this modules, click
right button in gtk20 text widget and select "Input Methods" -
"Hangul" (not KSC5601).
diff --git a/korean/imhangul-gtk2/pkg-plist b/korean/imhangul-gtk2/pkg-plist
new file mode 100644
index 000000000000..95d1537dfc78
--- /dev/null
+++ b/korean/imhangul-gtk2/pkg-plist
@@ -0,0 +1,4 @@
+lib/gtk-2.0/immodules/im-hangul.so
+%%NLS%%share/locale/ko/LC_MESSAGES/im-hangul.mo
+@postexec %D/bin/gtk-query-immodules-2.0 --update-cache
+@postunexec %D/bin/gtk-query-immodules-2.0 --update-cache
diff --git a/korean/imhangul/Makefile b/korean/imhangul-gtk3/Makefile
index dd17a133d9f1..dac05bb9a40b 100644
--- a/korean/imhangul/Makefile
+++ b/korean/imhangul-gtk3/Makefile
@@ -2,37 +2,31 @@
# $FreeBSD$
PORTNAME= imhangul
-PORTVERSION= ${GTKVER:R}.1.1
-PORTREVISION= 3
+PORTVERSION= 3.1.1
CATEGORIES= korean
+PKGNAMESUFFIX= -gtk3
MAINTAINER= jkim@FreeBSD.org
-COMMENT= GTK+ Hangul input module
+COMMENT= Hangul input module for GTK+ 3.0
LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libhangul.so:korean/libhangul
+CONFLICTS_INSTALL= ko-imhangul-3.*
+
GH_ACCOUNT= choehwanjin
+GH_TAGNAME= 85f6d10
USE_GITHUB= yes
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-PLIST_SUB= GTKVER=${GTKVER}
-USE_GNOME= cairo gdkpixbuf2 gtk${GTKVER:S|.||}
+USE_GNOME= cairo gdkpixbuf2 gtk30
USES= autoreconf gmake libtool pkgconfig
OPTIONS_DEFINE= NLS
-OPTIONS_DEFAULT= GTK3
-OPTIONS_SINGLE= GTK
-OPTIONS_SINGLE_GTK= GTK2 GTK3
OPTIONS_SUB= yes
-GTK_DESC= Select GTK+ version
-GTK2_LIB_DEPENDS= libfreetype.so:print/freetype2
-GTK2_LIB_DEPENDS+= libfontconfig.so:x11-fonts/fontconfig
-GTK2_VARS= GH_TAGNAME=d2f555d GTKVER=2.0
-GTK3_VARS= GH_TAGNAME=85f6d10 GTKVER=3.0
NLS_USES= gettext localbase
post-patch-NLS-off:
diff --git a/korean/imhangul-gtk3/distinfo b/korean/imhangul-gtk3/distinfo
new file mode 100644
index 000000000000..320730761188
--- /dev/null
+++ b/korean/imhangul-gtk3/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1473877928
+SHA256 (choehwanjin-imhangul-3.1.1-85f6d10_GH0.tar.gz) = a2bd9baf56c5b624c035ce6890553fb513feb6404453549a2f523691df86f2cc
+SIZE (choehwanjin-imhangul-3.1.1-85f6d10_GH0.tar.gz) = 256731
diff --git a/korean/imhangul/files/patch-Makefile.am b/korean/imhangul-gtk3/files/patch-Makefile.am
index 66effdce47c6..66effdce47c6 100644
--- a/korean/imhangul/files/patch-Makefile.am
+++ b/korean/imhangul-gtk3/files/patch-Makefile.am
diff --git a/korean/imhangul-gtk3/pkg-descr b/korean/imhangul-gtk3/pkg-descr
new file mode 100644
index 000000000000..6c2c5478ab4e
--- /dev/null
+++ b/korean/imhangul-gtk3/pkg-descr
@@ -0,0 +1,7 @@
+Hangul Input Module for GTK+ 3.0
+
+Input method of GTK+ 3.0 widget. To select this modules, click
+right button in gtk30 text widget and select "Input Methods" -
+"Hangul" (not KSC5601).
+
+WWW: http://code.google.com/p/imhangul/
diff --git a/korean/imhangul-gtk3/pkg-plist b/korean/imhangul-gtk3/pkg-plist
new file mode 100644
index 000000000000..124e906cebaf
--- /dev/null
+++ b/korean/imhangul-gtk3/pkg-plist
@@ -0,0 +1,4 @@
+lib/gtk-3.0/immodules/im-hangul.so
+%%NLS%%share/locale/ko/LC_MESSAGES/im-hangul-3.0.mo
+@postexec %D/bin/gtk-query-immodules-3.0 --update-cache
+@postunexec %D/bin/gtk-query-immodules-3.0 --update-cache
diff --git a/korean/imhangul/pkg-plist b/korean/imhangul/pkg-plist
deleted file mode 100644
index 56ec2cf0e685..000000000000
--- a/korean/imhangul/pkg-plist
+++ /dev/null
@@ -1,5 +0,0 @@
-lib/gtk-%%GTKVER%%/immodules/im-hangul.so
-%%GTK2%%%%NLS%%share/locale/ko/LC_MESSAGES/im-hangul.mo
-%%GTK3%%%%NLS%%share/locale/ko/LC_MESSAGES/im-hangul-%%GTKVER%%.mo
-@postexec %D/bin/gtk-query-immodules-%%GTKVER%% --update-cache
-@postunexec %D/bin/gtk-query-immodules-%%GTKVER%% --update-cache