aboutsummaryrefslogtreecommitdiff
path: root/korean
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2012-11-02 22:46:30 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2012-11-02 22:46:30 +0000
commit60afb940fa6f0c1cc2b871b3d6ee4d46a042f9e2 (patch)
treeeaca260c54fa583439e8b4b579e51cb66bed2aee /korean
parent07162c3703cd9d4efb4ad432a66fb44243dba2f2 (diff)
downloadports-60afb940fa6f0c1cc2b871b3d6ee4d46a042f9e2.tar.gz
ports-60afb940fa6f0c1cc2b871b3d6ee4d46a042f9e2.zip
Notes
Diffstat (limited to 'korean')
-rw-r--r--korean/scim-hangul/Makefile31
-rw-r--r--korean/scim-hangul/distinfo4
-rw-r--r--korean/scim-hangul/files/patch-src__scim_hangul_imengine_setup.cpp11
-rw-r--r--korean/scim-hangul/pkg-message4
-rw-r--r--korean/scim-hangul/pkg-plist2
5 files changed, 30 insertions, 22 deletions
diff --git a/korean/scim-hangul/Makefile b/korean/scim-hangul/Makefile
index 991bfb3a19bf..2bbcd97cf05c 100644
--- a/korean/scim-hangul/Makefile
+++ b/korean/scim-hangul/Makefile
@@ -1,40 +1,35 @@
-# New ports collection makefile for: ko-scim-hangul
-# Date created: 13 Oct 2005
-# Whom: CHOI Junho <cjh@FreeBSD.org>
-#
+# Created by: CHOI Junho <cjh@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= scim-hangul
-PORTVERSION= 0.3.2
-PORTREVISION= 1
+PORTVERSION= 0.4.0
CATEGORIES= korean
MASTER_SITES= SF/scim/${PORTNAME}/${PORTVERSION}
MAINTAINER= jkim@FreeBSD.org
COMMENT= SCIM IMEngine module for Korean(Hangul) input
-BUILD_DEPENDS= scim:${PORTSDIR}/textproc/scim
-LIB_DEPENDS= hangul.1:${PORTSDIR}/korean/libhangul
-RUN_DEPENDS= scim:${PORTSDIR}/textproc/scim
+LICENSE= GPLv2
+
+LIB_DEPENDS= hangul:${PORTSDIR}/korean/libhangul \
+ scim-1.0:${PORTSDIR}/textproc/scim
-USE_ICONV= yes
-USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_PKGCONFIG= build
-.if !defined(WITHOUT_NLS)
+OPTIONS_DEFINE= NLS
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
-LDFLAGS+= -L${LOCALBASE}/lib
-CPPFLAGS+= -I${LOCALBASE}/include
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/configure ${WRKSRC}/skim/configure
-
post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO}
diff --git a/korean/scim-hangul/distinfo b/korean/scim-hangul/distinfo
index 81921ebe0692..5a2ccb06cb63 100644
--- a/korean/scim-hangul/distinfo
+++ b/korean/scim-hangul/distinfo
@@ -1,2 +1,2 @@
-SHA256 (scim-hangul-0.3.2.tar.gz) = b7c67778f5dd8ec29b96c1477ef008e10fae436928975fc46fbeb7a546d4462b
-SIZE (scim-hangul-0.3.2.tar.gz) = 1176577
+SHA256 (scim-hangul-0.4.0.tar.gz) = 7f116c87e78da51363fb4968d627364718de6ec02aa6c6119451fdf403e668c0
+SIZE (scim-hangul-0.4.0.tar.gz) = 456953
diff --git a/korean/scim-hangul/files/patch-src__scim_hangul_imengine_setup.cpp b/korean/scim-hangul/files/patch-src__scim_hangul_imengine_setup.cpp
new file mode 100644
index 000000000000..bc1fd4b673ee
--- /dev/null
+++ b/korean/scim-hangul/files/patch-src__scim_hangul_imengine_setup.cpp
@@ -0,0 +1,11 @@
+--- src/scim_hangul_imengine_setup.cpp.orig 2012-07-08 07:52:07.000000000 -0400
++++ src/scim_hangul_imengine_setup.cpp 2012-11-02 14:13:14.000000000 -0400
+@@ -346,7 +346,7 @@
+ for (i = 0; i < n; i++) {
+ const char* name = hangul_ic_get_keyboard_name(i);
+ #if GTK_CHECK_VERSION(2, 24, 0)
+- gtk_combo_box_text_append(GTK_COMBO_BOX_TEXT(combo_box), NULL, name);
++ gtk_combo_box_text_append_text(GTK_COMBO_BOX_TEXT(combo_box), name);
+ #else
+ gtk_combo_box_append_text(GTK_COMBO_BOX(combo_box), name);
+ #endif
diff --git a/korean/scim-hangul/pkg-message b/korean/scim-hangul/pkg-message
index ed8696ee8cda..9d263404a293 100644
--- a/korean/scim-hangul/pkg-message
+++ b/korean/scim-hangul/pkg-message
@@ -1,8 +1,8 @@
--------------------------------------------------------------------
Remember to set environment variables XMODIFIERS and LANG:
- csh/tcsh: setenv XMODIFIERS @im=SCIM ; setenv LANG ko_KR.eucKR
- sh/bash: export XMODIFIERS='@im=SCIM'; export LANG=ko_KR.eucKR
+ csh/tcsh: setenv XMODIFIERS @im=SCIM ; setenv LANG ko_KR.UTF-8
+ sh/bash: export XMODIFIERS='@im=SCIM'; export LANG=ko_KR.UTF-8
To start the SCIM input method daemon, use command:
diff --git a/korean/scim-hangul/pkg-plist b/korean/scim-hangul/pkg-plist
index 58b6c5d7c45e..bdf7e109c364 100644
--- a/korean/scim-hangul/pkg-plist
+++ b/korean/scim-hangul/pkg-plist
@@ -11,5 +11,7 @@ lib/scim-1.0/1.4.0/SetupUI/hangul-imengine-setup.so
%%NLS%%share/locale/zh_CN/LC_MESSAGES/scim-hangul.mo
share/scim/hangul/symbol.txt
share/scim/icons/scim-hangul.png
+share/scim/icons/scim-hangul-off.png
+share/scim/icons/scim-hangul-on.png
@dirrm share/scim/hangul
@dirrmtry share/scim/icons