aboutsummaryrefslogtreecommitdiff
path: root/korean
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2014-01-07 01:36:45 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2014-01-07 01:36:45 +0000
commitfb9e399c88f8dbaa2ab3845abfb79c7f9fa3cdad (patch)
tree05487f886a3a863eea9c08725677481ce761da49 /korean
parente475c58e449b11da2cab89c8600ae8a125f9482a (diff)
downloadports-fb9e399c88f8dbaa2ab3845abfb79c7f9fa3cdad.tar.gz
ports-fb9e399c88f8dbaa2ab3845abfb79c7f9fa3cdad.zip
- Stagefy, convert to USES=gmake, convert LIB_DEPENDS to new format.
- Use options framework to select the default keyboard layout.
Notes
Notes: svn path=/head/; revision=338971
Diffstat (limited to 'korean')
-rw-r--r--korean/nabi/Makefile23
1 files changed, 14 insertions, 9 deletions
diff --git a/korean/nabi/Makefile b/korean/nabi/Makefile
index 5e326e60f44d..6d55b673d8a0 100644
--- a/korean/nabi/Makefile
+++ b/korean/nabi/Makefile
@@ -11,29 +11,34 @@ COMMENT= Hangul X Input Method for Everywhere
LICENSE= GPLv2
-LIB_DEPENDS= hangul:${PORTSDIR}/korean/libhangul
+LIB_DEPENDS= libhangul.so:${PORTSDIR}/korean/libhangul
-USE_GMAKE= yes
USE_GNOME= gtk20
GNU_CONFIGURE= yes
-USES= pathfix pkgconfig
+USES= gmake pathfix pkgconfig
+
+OPTIONS_DEFINE= NLS
+OPTIONS_RADIO= LAYOUT
+OPTIONS_RADIO_LAYOUT= LAYOUT_390 LAYOUT_FINAL
+LAYOUT_DESC= Select 3-beolsik layout (default: 2-beolsik)
+LAYOUT_390_DESC= 3-beolsik 390 keyboard
+LAYOUT_FINAL_DESC= 3-beolsik final keyboard
+OPTIONS_SUB= NLS
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
USES+= gettext
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-PLIST_SUB= NLS=""
-.else
-PLIST_SUB= NLS="@comment "
.endif
-.if defined(WITH_LAYOUT_390)
+.if ${PORT_OPTIONS:MLAYOUT_390}
CONFIGURE_ARGS= --with-default-keyboard=39
-.elif defined(WITH_LAYOUT_3FINAL)
+.elif ${PORT_OPTIONS:MLAYOUT_FINAL}
CONFIGURE_ARGS= --with-default-keyboard=3f
+.else
+CONFIGURE_ARGS= --with-default-keyboard=2
.endif
.include <bsd.port.mk>