aboutsummaryrefslogtreecommitdiff
path: root/korean
diff options
context:
space:
mode:
authorCHOI Junho <cjh@FreeBSD.org>2001-03-23 06:55:08 +0000
committerCHOI Junho <cjh@FreeBSD.org>2001-03-23 06:55:08 +0000
commitcc7a03613244ce02902322647cb0f24f4975eb3a (patch)
tree47d97892f96b1a9800082565833a0b2d42feefbf /korean
parentef3502c4973d80511bd2dd6bc7a1958718ac0370 (diff)
downloadports-cc7a03613244ce02902322647cb0f24f4975eb3a.tar.gz
ports-cc7a03613244ce02902322647cb0f24f4975eb3a.zip
Notes
Diffstat (limited to 'korean')
-rw-r--r--korean/Makefile1
-rw-r--r--korean/w3m/Makefile17
-rw-r--r--korean/w3m/files/patch-config_h12
-rw-r--r--korean/w3m/files/patch-menu_c44
-rw-r--r--korean/w3m/files/patch-rc_c11
-rw-r--r--korean/w3m/files/patch-terms_h11
-rw-r--r--korean/w3m/files/w3m-0.1.11-hangul.patch105
7 files changed, 201 insertions, 0 deletions
diff --git a/korean/Makefile b/korean/Makefile
index 6f5b78ff2e7c..5d4fdbdb7ab2 100644
--- a/korean/Makefile
+++ b/korean/Makefile
@@ -1,5 +1,6 @@
# $FreeBSD$
#
+ SUBDIR += w3m
SUBDIR += uniksc
SUBDIR += texinfo
diff --git a/korean/w3m/Makefile b/korean/w3m/Makefile
new file mode 100644
index 000000000000..366d7b5f3b83
--- /dev/null
+++ b/korean/w3m/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: ko-w3m
+# Date created: 23 Mar 2001
+# Whom: cjh
+#
+# $FreeBSD$
+#
+
+MASTERDIR= ${.CURDIR}/../../www/w3m
+
+CATEGORIES= korean www
+
+MAINTAINER= cjh@FreeBSD.org
+
+EXTRA_PATCHES= ${.CURDIR}/files/w3m-0.1.11-hangul.patch \
+ ${.CURDIR}/files/patch-*
+
+.include "${MASTERDIR}/Makefile"
diff --git a/korean/w3m/files/patch-config_h b/korean/w3m/files/patch-config_h
new file mode 100644
index 000000000000..5ecdf061a98d
--- /dev/null
+++ b/korean/w3m/files/patch-config_h
@@ -0,0 +1,12 @@
+--- config.h.orig Fri Mar 23 15:11:07 2001
++++ config.h Fri Mar 23 15:12:08 2001
+@@ -172,3 +172,9 @@
+ #endif /* makefile_parameter */
+ #endif /* _CONFIGURED_ */
+
++/* Korean configuration */
++#define KO 2
++#define KOREAN
++#undef LANG
++#undef KANJI_SYMBOLS
++#define LANG KO
diff --git a/korean/w3m/files/patch-menu_c b/korean/w3m/files/patch-menu_c
new file mode 100644
index 000000000000..012e4012f162
--- /dev/null
+++ b/korean/w3m/files/patch-menu_c
@@ -0,0 +1,44 @@
+--- menu.c.old Fri Mar 23 14:35:33 2001
++++ menu.c Fri Mar 23 14:46:55 2001
+@@ -305,6 +305,31 @@
+ {MENU_END, "", NULL, 0, nulcmd, NULL, "", NULL},
+ };
+ #else /* LANG != JA */
++#if LANG == KO /* LANG == KO */
++static MenuItem MainMenuItem[] =
++{
++/* type label variable value func popup keys data */
++ {MENU_FUNC, " µÚ·Î (b) ", NULL, 0, backBf, NULL, "b", NULL},
++ {MENU_FUNC, " ¹öÆÛ ¼±Åà (s) ", NULL, 0, selBuf, NULL, "s", NULL},
++ {MENU_FUNC, " ¼Ò½º º¸±â (v) ", NULL, 0, vwSrc, NULL, "vV", NULL},
++ {MENU_FUNC, " ¼Ò½º ÆíÁý (e) ", NULL, 0, editBf, NULL, "eE", NULL},
++ {MENU_FUNC, " ¼Ò½º ÀúÀå (S) ", NULL, 0, svSrc, NULL, "S", NULL},
++ {MENU_FUNC, " ´Ù½Ã Àбâ (r) ", NULL, 0, reload, NULL, "rR", NULL},
++ {MENU_NOP, " ---------------- ", NULL, 0, nulcmd, NULL, "", NULL},
++ {MENU_FUNC, " ¸µÅ© µû¶ó°¡±â(a) ", NULL, 0, followA, NULL, "a", NULL},
++ {MENU_FUNC, " ¸µÅ© ÀúÀå (A) ", NULL, 0, svA, NULL, "A", NULL},
++ {MENU_FUNC, " À̹ÌÁö º¸±â (i) ", NULL, 0, followI, NULL, "i", NULL},
++ {MENU_FUNC, " À̹ÌÁö ÀúÀå (I) ", NULL, 0, svI, NULL, "I", NULL},
++ {MENU_FUNC, " ÇÁ·¹ÀÓ º¸±â (f) ", NULL, 0, rFrame, NULL, "fF", NULL},
++ {MENU_NOP, " ---------------- ", NULL, 0, nulcmd, NULL, "", NULL},
++ {MENU_FUNC, " Ã¥°¥ÇÇ (B) ", NULL, 0, ldBmark, NULL, "B", NULL},
++ {MENU_FUNC, " µµ¿ò¸» (h) ", NULL, 0, ldhelp, NULL, "hH", NULL},
++ {MENU_FUNC, " ¿É¼Ç (o) ", NULL, 0, ldOpt, NULL, "oO", NULL},
++ {MENU_NOP, " ---------------- ", NULL, 0, nulcmd, NULL, "", NULL},
++ {MENU_FUNC, " Á¾·á (q) ", NULL, 0, qquitfm, NULL, "qQ", NULL},
++ {MENU_END, "", NULL, 0, nulcmd, NULL, "", NULL},
++};
++#else /* LANG != JA/KO */
+ static MenuItem MainMenuItem[] =
+ {
+ /* type label variable value func popup keys data */
+@@ -328,7 +353,8 @@
+ {MENU_FUNC, " Quit (q) ", NULL, 0, qquitfm, NULL, "qQ", NULL},
+ {MENU_END, "", NULL, 0, nulcmd, NULL, "", NULL},
+ };
+-#endif /* LANG != JA */
++#endif
++#endif /* LANG != JA/KO */
+
+ /* --- MainMenu (END) --- */
+
diff --git a/korean/w3m/files/patch-rc_c b/korean/w3m/files/patch-rc_c
new file mode 100644
index 000000000000..399e17a03ec1
--- /dev/null
+++ b/korean/w3m/files/patch-rc_c
@@ -0,0 +1,11 @@
+--- rc.c.o Fri Mar 23 15:22:57 2001
++++ rc.c Fri Mar 23 15:23:07 2001
+@@ -184,7 +184,7 @@
+ #define CMT_FTPPASS "Password for FTP(use your mail address)"
+ #define CMT_USERAGENT "User-Agent"
+ #define CMT_ACCEPTLANG "Accept-Language"
+-/* #define CMT_DOCUMENTCODE "Document Charset" */
++#define CMT_DOCUMENTCODE "Document Charset"
+ #define CMT_WRAP "Wrap search"
+ #define CMT_VIEW_UNSEENOBJECTS "Display unseenobjects (e.g. bgimage) tag"
+ #ifdef __EMX__
diff --git a/korean/w3m/files/patch-terms_h b/korean/w3m/files/patch-terms_h
new file mode 100644
index 000000000000..9b336c5fcfee
--- /dev/null
+++ b/korean/w3m/files/patch-terms_h
@@ -0,0 +1,11 @@
+--- terms.h.o Fri Mar 23 15:30:21 2001
++++ terms.h Fri Mar 23 15:30:49 2001
+@@ -16,7 +16,7 @@
+ #define CODE_INNER_EUC 'I'
+
+ #define STR_ASCII "US_ASCII"
+-#define STR_EUC "EUC-JP"
++#define STR_EUC "EUC(-JP,-KR)"
+ #define STR_SJIS "Shift_JIS"
+ #define STR_JIS_n "ISO-2022-JP (JIS X 0208 + US_ASCII)"
+ #define STR_JIS_m "ISO-2022-JP (JIS C 6226 + US_ASCII)"
diff --git a/korean/w3m/files/w3m-0.1.11-hangul.patch b/korean/w3m/files/w3m-0.1.11-hangul.patch
new file mode 100644
index 000000000000..6588a55d51f0
--- /dev/null
+++ b/korean/w3m/files/w3m-0.1.11-hangul.patch
@@ -0,0 +1,105 @@
+diff -Naur w3m-0.1.10.orig/configure w3m-0.1.10/configure
+--- w3m-0.1.10.orig/configure Mon Jun 5 18:41:35 2000
++++ configure Fri Jun 9 22:17:04 2000
+@@ -309,10 +309,14 @@
+
+ echo "Which language do you prefer?"
+ echo " 1 - Japanese (charset ISO-2022-JP, EUC-JP, Shift_JIS)"
+-echo " 2 - English (charset US_ASCII, ISO-8859-1, etc.)"
++echo " 2 - Korean (charset EUC-KR ISO-2022-KR is not yet supported)"
++echo " 3 - English (charset US_ASCII, ISO-8859-1, etc.)"
+ if [ "$pref_lang" = 2 ]; then
+ Echo '[2]? '
+ def_lg=2
++elif [ "$pref_lang" = 3 ]; then
++ Echo '[3]? '
++ def_lg=3
+ else
+ Echo '[1]? '
+ def_lg=1
+@@ -320,8 +324,8 @@
+ while :
+ do
+ readanswer lg_ans "$def_lg"
+- if [ "$lg_ans" != 1 -a "$lg_ans" != 2 ]; then
+- echo "Please choose 1 or 2."
++ if [ "$lg_ans" -lt 1 -o "$lg_ans" -gt 3 ]; then
++ echo "Please choose 1,2 or 3."
+ Echo "[$def_lg]? "
+ continue
+ else
+@@ -333,6 +337,9 @@
+ if [ "$lg_ans" = 1 ]; then
+ use_lang="#define LANG JA"
+ lang=ja
++elif [ "$lg_ans" = 2 ]; then
++ use_lang="#define LANG KO"
++ lang=ko
+ else
+ use_lang="#define LANG EN"
+ lang=en
+@@ -366,6 +373,8 @@
+ break
+ done
+ echo "def_dcode=$ncode" >> config.param
++elif [ "$lang" = ko ]; then
++ ncode=E
+ else
+ ncode=x
+ fi
+@@ -1466,7 +1475,8 @@
+ #define DISPLAY_CODE '$ncode'
+
+ #define JA 0
+-#define EN 1
++#define KO 1
++#define EN 2
+ $use_lang
+ $def_kanji_symbols
+ $def_color
+diff -Naur w3m-0.1.10.orig/file.c w3m-0.1.10/file.c
+--- w3m-0.1.10.orig/file.c.orig Mon Feb 5 01:05:34 2001
++++ file.c Mon Feb 5 01:07:31 2001
+@@ -4252,7 +4252,7 @@
+ str++;
+ }
+ else {
+-#ifdef JP_CHARSET
++#if defined(JP_CHARSET) && !defined(KR_CHARSET)
+ if (mode == PC_KANJI &&
+ obuf->pos > h_env->envs[h_env->envc].indent &&
+ Strlastchar(obuf->line) == ' ') {
+diff -Naur w3m-0.1.10.orig/fm.h w3m-0.1.10/fm.h
+--- w3m-0.1.10.orig/fm.h Tue Jun 6 14:54:35 2000
++++ fm.h Fri Jun 9 22:17:04 2000
+@@ -50,6 +50,9 @@
+
+ #if LANG == JA
+ #define JP_CHARSET
++#elif LANG == KO
++#define JP_CHARSET
++#define KR_CHARSET
+ #endif /* LANG == JA */
+
+ /*
+@@ -521,7 +524,7 @@
+ */
+
+ extern int LINES, COLS;
+-#if defined(CYGWIN) && LANG == JA
++#if defined(CYGWIN) && (LANG == JA || LANG == KO)
+ #define LASTLINE (LINES-2)
+ #else /* not defined(CYGWIN) && LANG == JA */
+ #define LASTLINE (LINES-1)
+diff -Naur w3m-0.1.10.orig/rc.c w3m-0.1.10/rc.c
+--- w3m-0.1.10.orig/rc.c Mon Jun 5 20:17:04 2000
++++ rc.c Fri Jun 9 22:17:04 2000
+@@ -128,7 +128,7 @@
+ #define CMT_PAGERLINE "# of reserved line when w3m is used as a pager"
+ #define CMT_HISTSIZE "# of reserved URL"
+ #define CMT_SAVEHIST "Save URL history"
+-/* #define CMT_KANJICODE "Display Kanji Code" */
++#define CMT_KANJICODE "Display Kanji Code"
+ #define CMT_FRAME "Automatic rendering of frame"
+ #define CMT_TSELF "use _self as default target"
+ #define CMT_DISPLINK "Automatic display of link URL"