aboutsummaryrefslogtreecommitdiff
path: root/korean
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2018-10-22 20:08:54 +0000
committerThierry Thomas <thierry@FreeBSD.org>2018-10-22 20:08:54 +0000
commit9daefa8d15d303651e4b882b53fb1001c3b1f614 (patch)
treec781ce2ac7432fb24e67ccf5ce7008e54086d3f8 /korean
parenteea0292045c58a020687b41fb1fcb3ca8e290e13 (diff)
downloadports-9daefa8d15d303651e4b882b53fb1001c3b1f614.tar.gz
ports-9daefa8d15d303651e4b882b53fb1001c3b1f614.zip
Upgrade to 0.7.1.
Approved by: maintainer time-out
Notes
Notes: svn path=/head/; revision=482778
Diffstat (limited to 'korean')
-rw-r--r--korean/hunspell/Makefile25
-rw-r--r--korean/hunspell/distinfo6
-rw-r--r--korean/hunspell/files/patch-Makefile21
-rw-r--r--korean/hunspell/files/patch-tests_runtest.py10
4 files changed, 42 insertions, 20 deletions
diff --git a/korean/hunspell/Makefile b/korean/hunspell/Makefile
index 5ae3c9ff9c21..f2e3ceb81249 100644
--- a/korean/hunspell/Makefile
+++ b/korean/hunspell/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= hunspell
-PORTVERSION= 0.5.6
-PORTREVISION= 3
+PORTVERSION= 0.7.1
CATEGORIES= korean textproc
MAINTAINER= jkim@FreeBSD.org
@@ -15,26 +14,28 @@ LICENSE_FILE_LGPL21+ = ${WRKSRC}/LICENSE.LGPL
LICENSE_FILE_MPL11= ${WRKSRC}/LICENSE.MPL
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>=0:devel/py-lxml@${PY_FLAVOR}
-TEST_DEPENDS= hunspell:textproc/hunspell
+TEST_DEPENDS= hunspell:textproc/hunspell \
+ gmake:devel/gmake
-GH_ACCOUNT= changwoo
+GH_ACCOUNT= spellcheck-ko
GH_PROJECT= ${PORTNAME}-dict-ko
USE_GITHUB= yes
NO_ARCH= yes
-USES= python:2.7,build,test
+USES= python:3.3+,build,test shebangfix
+SHEBANG_FILES= tests/runtest.py
PLIST_FILES= %%DATADIR%%/ko_KR.aff \
%%DATADIR%%/ko_KR.dic
-do-build:
- @(cd ${WRKSRC} && ${PYTHON_CMD} make-aff-dic.py ko_KR.aff ko_KR.dic \
- dict-ko-builtins.xml dict-ko-galkwi.xml)
+TEST_TARGET= test
+TEST_ENV+= GMAKE=${GMAKE} LC_ALL=en_US.UTF-8
+
+pre-build:
+.for f in Makefile tests/Makefile
+ ${REINPLACE_CMD} -e 's|python3|${PYTHON_CMD}|' ${WRKSRC}/${f}
+.endfor
-do-test:
- @(cd ${WRKSRC}/tests && for T in $$(ls -1 *.test); do \
- echo "Testing $$T..."; \
- ${PYTHON_CMD} runtest.py $$T || exit 1; done)
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKSRC}/ko_KR.aff ${WRKSRC}/ko_KR.dic \
diff --git a/korean/hunspell/distinfo b/korean/hunspell/distinfo
index 8ef3a606d9f0..642070d36a4c 100644
--- a/korean/hunspell/distinfo
+++ b/korean/hunspell/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1473875379
-SHA256 (changwoo-hunspell-dict-ko-0.5.6_GH0.tar.gz) = 2caf3b0775d8d6c49866be2682cdf17b2c76d4c151bd1923adbe0b5661b94ee8
-SIZE (changwoo-hunspell-dict-ko-0.5.6_GH0.tar.gz) = 457791
+TIMESTAMP = 1527707668
+SHA256 (spellcheck-ko-hunspell-dict-ko-0.7.1_GH0.tar.gz) = 5b7fbbc92db39d2454607d1de385104229fb86a606c2c1a1f4ea51b67ed42f5c
+SIZE (spellcheck-ko-hunspell-dict-ko-0.7.1_GH0.tar.gz) = 324625
diff --git a/korean/hunspell/files/patch-Makefile b/korean/hunspell/files/patch-Makefile
new file mode 100644
index 000000000000..35c715dba4d4
--- /dev/null
+++ b/korean/hunspell/files/patch-Makefile
@@ -0,0 +1,21 @@
+--- Makefile.orig 2017-12-25 07:30:13 UTC
++++ Makefile
+@@ -1,8 +1,8 @@
+ PYTHON := python3
+ ZIP := zip -r
+
+-AFFIX := ko.aff
+-DICT := ko.dic
++AFFIX := ko_KR.aff
++DICT := ko_KR.dic
+
+ CLEANFILES := $(AFFIX) $(DICT)
+
+@@ -43,6 +43,6 @@ dist:: distdir $(BIN_DISTCONTENT)
+ rm -rf $(BIN_DISTNAME)
+
+ test:
+- $(MAKE) -C tests test
++ $(GMAKE) -C tests test
+
+ .PHONY: all clean dist distdir test
diff --git a/korean/hunspell/files/patch-tests_runtest.py b/korean/hunspell/files/patch-tests_runtest.py
index 8855277d4fa7..8cab228c6e03 100644
--- a/korean/hunspell/files/patch-tests_runtest.py
+++ b/korean/hunspell/files/patch-tests_runtest.py
@@ -1,11 +1,11 @@
---- tests/runtest.py.orig 2012-10-06 23:29:32 UTC
+--- tests/runtest.py.orig 2017-12-25 07:30:13 UTC
+++ tests/runtest.py
-@@ -19,7 +19,7 @@ def main():
+@@ -27,7 +27,7 @@ def main():
hunspell_cmd = './hunspell'
else:
hunspell_cmd = 'hunspell'
-- hunspell = subprocess.Popen([hunspell_cmd, '-i', 'UTF-8', '-a', '-d', '../ko'],
-+ hunspell = subprocess.Popen([hunspell_cmd, '-i', 'UTF-8', '-a', '-d', '../ko_KR'],
+- args = [hunspell_cmd, '-i', 'UTF-8', '-d', '../ko']
++ args = [hunspell_cmd, '-i', 'UTF-8', '-d', '../ko_KR']
+ hunspell = subprocess.Popen(args,
stdin=subprocess.PIPE, stdout=subprocess.PIPE)
hunspell.stdout.readline() # the first line "Hunspell 1.2.8 ..."
- lineno = 0