aboutsummaryrefslogtreecommitdiff
path: root/korean
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2011-08-05 21:40:44 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2011-08-05 21:40:44 +0000
commitb181d5770c302d9e22118d7c5f2742e6661aa446 (patch)
tree3259fc8739ea8fc7ee2999c5a31e1dc9dd7e27b5 /korean
parent8158b2b0ee60aa21081bb018937d70880e842b74 (diff)
downloadports-b181d5770c302d9e22118d7c5f2742e6661aa446.tar.gz
ports-b181d5770c302d9e22118d7c5f2742e6661aa446.zip
Notes
Diffstat (limited to 'korean')
-rw-r--r--korean/Makefile1
-rw-r--r--korean/nanumcoding-ttf/Makefile50
-rw-r--r--korean/nanumcoding-ttf/distinfo2
-rw-r--r--korean/nanumcoding-ttf/files/LICENSE96
-rw-r--r--korean/nanumcoding-ttf/pkg-descr5
-rw-r--r--korean/nanumcoding-ttf/pkg-plist7
6 files changed, 161 insertions, 0 deletions
diff --git a/korean/Makefile b/korean/Makefile
index 5122ec9f72b5..f2a8c129028a 100644
--- a/korean/Makefile
+++ b/korean/Makefile
@@ -41,6 +41,7 @@
SUBDIR += mizifont
SUBDIR += munhwafonts-cid
SUBDIR += nabi
+ SUBDIR += nanumcoding-ttf
SUBDIR += nanumfonts-otf
SUBDIR += nanumfonts-ttf
SUBDIR += nhpf
diff --git a/korean/nanumcoding-ttf/Makefile b/korean/nanumcoding-ttf/Makefile
new file mode 100644
index 000000000000..7670902de520
--- /dev/null
+++ b/korean/nanumcoding-ttf/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: Nanum Gothic Coding Hangul font
+# Date created: August 4, 2011
+# Whom: Jung-uk Kim <jkim@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nanumcoding
+PORTVERSION= 2.0
+CATEGORIES= korean
+MASTER_SITES= http://dev.naver.com/frs/download.php/441/
+PKGNAMESUFFIX= -ttf
+DISTNAME= NanumGothicCoding-${PORTVERSION}
+
+MAINTAINER= jkim@FreeBSD.org
+COMMENT= Nanum Gothic Coding Hangul font (TrueType)
+
+LICENSE= OFL
+LICENSE_NAME= Open Font License version 1.1
+LICENSE_FILE= ${FILESDIR}/LICENSE
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+BUILD_DEPENDS+= ${LOCALBASE}/bin/mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
+ ${LOCALBASE}/bin/mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale
+
+NO_WRKSUBDIR= yes
+USE_ZIP= yes
+FONTSDIR= lib/X11/fonts/nanum-coding-ttf
+PLIST_SUB+= FONTSDIR=${FONTSDIR}
+
+post-extract:
+ @# XXX File names are encoded in EUC-KR.
+ ${MV} ${WRKSRC}/*-Bold.ttf ${WRKSRC}/NanumGothicCoding-Bold.tmp
+ ${MV} ${WRKSRC}/*.ttf ${WRKSRC}/NanumGothicCoding.ttf
+ ${MV} ${WRKSRC}/*-Bold.tmp ${WRKSRC}/NanumGothicCoding-Bold.ttf
+
+do-build:
+ ${LOCALBASE}/bin/mkfontscale ${WRKSRC}
+ ${LOCALBASE}/bin/mkfontdir ${WRKSRC}
+
+do-install:
+ ${MKDIR} ${PREFIX}/${FONTSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.ttf ${PREFIX}/${FONTSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/fonts.dir ${PREFIX}/${FONTSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/fonts.scale ${PREFIX}/${FONTSDIR}
+
+post-install:
+ @-${LOCALBASE}/bin/fc-cache -s ${PREFIX}/${FONTSDIR} 2>/dev/null
+
+.include <bsd.port.mk>
diff --git a/korean/nanumcoding-ttf/distinfo b/korean/nanumcoding-ttf/distinfo
new file mode 100644
index 000000000000..cbdd58f08111
--- /dev/null
+++ b/korean/nanumcoding-ttf/distinfo
@@ -0,0 +1,2 @@
+SHA256 (NanumGothicCoding-2.0.zip) = 177317f060e305fa1dca079d453584d9ca7880153c992b188128c6b3b75ece2a
+SIZE (NanumGothicCoding-2.0.zip) = 2038498
diff --git a/korean/nanumcoding-ttf/files/LICENSE b/korean/nanumcoding-ttf/files/LICENSE
new file mode 100644
index 000000000000..a1bf5fb9d0b7
--- /dev/null
+++ b/korean/nanumcoding-ttf/files/LICENSE
@@ -0,0 +1,96 @@
+Copyright (c) 2010, NHN Corporation (http://www.nhncorp.com),
+with Reserved Font Name Nanum, Naver Nanum, NanumGothic, Naver NanumGothic,
+NanumMyeongjo, Naver NanumMyeongjo, NanumBrush, Naver NanumBrush, NanumPen,
+Naver NanumPen.
+
+This Font Software is licensed under the SIL Open Font License, Version 1.1.
+This license is copied below, and is also available with a FAQ at:
+http://scripts.sil.org/OFL
+
+
+-----------------------------------------------------------
+SIL OPEN FONT LICENSE Version 1.1 - 26 February 2007
+-----------------------------------------------------------
+
+PREAMBLE
+The goals of the Open Font License (OFL) are to stimulate worldwide
+development of collaborative font projects, to support the font creation
+efforts of academic and linguistic communities, and to provide a free and
+open framework in which fonts may be shared and improved in partnership
+with others.
+
+The OFL allows the licensed fonts to be used, studied, modified and
+redistributed freely as long as they are not sold by themselves. The
+fonts, including any derivative works, can be bundled, embedded,
+redistributed and/or sold with any software provided that any reserved
+names are not used by derivative works. The fonts and derivatives,
+however, cannot be released under any other type of license. The
+requirement for fonts to remain under this license does not apply
+to any document created using the fonts or their derivatives.
+
+DEFINITIONS
+"Font Software" refers to the set of files released by the Copyright
+Holder(s) under this license and clearly marked as such. This may
+include source files, build scripts and documentation.
+
+"Reserved Font Name" refers to any names specified as such after the
+copyright statement(s).
+
+"Original Version" refers to the collection of Font Software components as
+distributed by the Copyright Holder(s).
+
+"Modified Version" refers to any derivative made by adding to, deleting,
+or substituting -- in part or in whole -- any of the components of the
+Original Version, by changing formats or by porting the Font Software to a
+new environment.
+
+"Author" refers to any designer, engineer, programmer, technical
+writer or other person who contributed to the Font Software.
+
+PERMISSION & CONDITIONS
+Permission is hereby granted, free of charge, to any person obtaining
+a copy of the Font Software, to use, study, copy, merge, embed, modify,
+redistribute, and sell modified and unmodified copies of the Font
+Software, subject to the following conditions:
+
+1) Neither the Font Software nor any of its individual components,
+in Original or Modified Versions, may be sold by itself.
+
+2) Original or Modified Versions of the Font Software may be bundled,
+redistributed and/or sold with any software, provided that each copy
+contains the above copyright notice and this license. These can be
+included either as stand-alone text files, human-readable headers or
+in the appropriate machine-readable metadata fields within text or
+binary files as long as those fields can be easily viewed by the user.
+
+3) No Modified Version of the Font Software may use the Reserved Font
+Name(s) unless explicit written permission is granted by the corresponding
+Copyright Holder. This restriction only applies to the primary font name as
+presented to the users.
+
+4) The name(s) of the Copyright Holder(s) or the Author(s) of the Font
+Software shall not be used to promote, endorse or advertise any
+Modified Version, except to acknowledge the contribution(s) of the
+Copyright Holder(s) and the Author(s) or with their explicit written
+permission.
+
+5) The Font Software, modified or unmodified, in part or in whole,
+must be distributed entirely under this license, and must not be
+distributed under any other license. The requirement for fonts to
+remain under this license does not apply to any document created
+using the Font Software.
+
+TERMINATION
+This license becomes null and void if any of the above conditions are
+not met.
+
+DISCLAIMER
+THE FONT SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO ANY WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT
+OF COPYRIGHT, PATENT, TRADEMARK, OR OTHER RIGHT. IN NO EVENT SHALL THE
+COPYRIGHT HOLDER BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+INCLUDING ANY GENERAL, SPECIAL, INDIRECT, INCIDENTAL, OR CONSEQUENTIAL
+DAMAGES, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+FROM, OUT OF THE USE OR INABILITY TO USE THE FONT SOFTWARE OR FROM
+OTHER DEALINGS IN THE FONT SOFTWARE.
diff --git a/korean/nanumcoding-ttf/pkg-descr b/korean/nanumcoding-ttf/pkg-descr
new file mode 100644
index 000000000000..c352ca65abd6
--- /dev/null
+++ b/korean/nanumcoding-ttf/pkg-descr
@@ -0,0 +1,5 @@
+Nanum Gothic Coding font family is free Hangul fonts developed by
+NHN Corporation and distributed under SIL Open Font License (OFL).
+This font was specifically designed for Hangul terminals.
+
+WWW: http://dev.naver.com/projects/nanumfont
diff --git a/korean/nanumcoding-ttf/pkg-plist b/korean/nanumcoding-ttf/pkg-plist
new file mode 100644
index 000000000000..a47b0d9ed858
--- /dev/null
+++ b/korean/nanumcoding-ttf/pkg-plist
@@ -0,0 +1,7 @@
+%%FONTSDIR%%/NanumGothicCoding-Bold.ttf
+%%FONTSDIR%%/NanumGothicCoding.ttf
+%%FONTSDIR%%/fonts.dir
+%%FONTSDIR%%/fonts.scale
+@dirrm %%FONTSDIR%%
+@exec fc-cache -s %D/%%FONTSDIR%% 2>/dev/null || true
+@unexec fc-cache -s %D/%%FONTSDIR%% 2>/dev/null || true