aboutsummaryrefslogtreecommitdiff
path: root/korean
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2015-09-09 23:23:06 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2015-09-09 23:23:06 +0000
commit4cd062fb7bfa155114b8d004bf6f13bfe433dc76 (patch)
treefe0a21e67e525c44ee608951c697d61e91d7a6ed /korean
parentb987ab20848a9c89c5ee0938b94bef321d458a84 (diff)
downloadports-4cd062fb7bfa155114b8d004bf6f13bfe433dc76.tar.gz
ports-4cd062fb7bfa155114b8d004bf6f13bfe433dc76.zip
Update to 1.5.0.
Notes
Notes: svn path=/head/; revision=396543
Diffstat (limited to 'korean')
-rw-r--r--korean/ibus-hangul/Makefile26
-rw-r--r--korean/ibus-hangul/distinfo4
-rw-r--r--korean/ibus-hangul/files/patch-setup-main.py13
-rw-r--r--korean/ibus-hangul/files/patch-src-i18n.h21
-rw-r--r--korean/ibus-hangul/files/patch-src_engine.c10
-rw-r--r--korean/ibus-hangul/pkg-plist13
6 files changed, 23 insertions, 64 deletions
diff --git a/korean/ibus-hangul/Makefile b/korean/ibus-hangul/Makefile
index c70bab1545ca..035c5a4443c2 100644
--- a/korean/ibus-hangul/Makefile
+++ b/korean/ibus-hangul/Makefile
@@ -1,10 +1,9 @@
# $FreeBSD$
PORTNAME= ibus-hangul
-PORTVERSION= 1.4.2
-PORTREVISION= 2
+PORTVERSION= 1.5.0
CATEGORIES= korean
-MASTER_SITES= GOOGLE_CODE
+MASTER_SITES= https://github.com/choehwanjin/ibus-hangul/releases/download/${PORTVERSION}/
MAINTAINER= jkim@FreeBSD.org
COMMENT= Hangul input engine for IBus
@@ -14,25 +13,10 @@ LICENSE= GPLv2
LIB_DEPENDS= libhangul.so:${PORTSDIR}/korean/libhangul \
libibus-1.0.so:${PORTSDIR}/textproc/ibus
-PROJECTHOST= ibus
-
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
INSTALLS_ICONS= yes
-USES= gmake libtool pkgconfig python
-USE_GNOME= intlhack pygobject3
-
-OPTIONS_DEFINE= NLS
-OPTIONS_SUB= NLS
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-CONFIGURE_ARGS= --enable-nls
-.else
-CONFIGURE_ARGS= --disable-nls
-.endif
+INSTALL_TARGET= install-strip
+USE_GNOME= gtk30 intlhack pygobject3
+USES= gettext gmake libtool pkgconfig python
.include <bsd.port.mk>
diff --git a/korean/ibus-hangul/distinfo b/korean/ibus-hangul/distinfo
index 4d0f78ff6ad3..f2e33b1dead3 100644
--- a/korean/ibus-hangul/distinfo
+++ b/korean/ibus-hangul/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ibus-hangul-1.4.2.tar.gz) = de79dff94028673f1a00b24f9af35f37f59c12b1737d171a24ac4d34fad20b89
-SIZE (ibus-hangul-1.4.2.tar.gz) = 483967
+SHA256 (ibus-hangul-1.5.0.tar.gz) = a22d4030bb20f73914a9d8a28c71b823123a5d1902a30f8328111af50f4f1788
+SIZE (ibus-hangul-1.5.0.tar.gz) = 505707
diff --git a/korean/ibus-hangul/files/patch-setup-main.py b/korean/ibus-hangul/files/patch-setup-main.py
deleted file mode 100644
index 09486476b8a6..000000000000
--- a/korean/ibus-hangul/files/patch-setup-main.py
+++ /dev/null
@@ -1,13 +0,0 @@
---- setup/main.py.orig 2012-04-15 10:46:37.000000000 -0400
-+++ setup/main.py 2012-04-30 17:57:09.000000000 -0400
-@@ -191,8 +191,8 @@
- return self.__config.set_value("engine/Hangul", name, v)
-
- if __name__ == "__main__":
-- locale.bindtextdomain(config.gettext_package, config.localedir)
-- locale.bind_textdomain_codeset(config.gettext_package, "UTF-8")
-+ gettext.bindtextdomain(config.gettext_package, config.localedir)
-+ gettext.bind_textdomain_codeset(config.gettext_package, "UTF-8")
-
- try:
- bus = ibus.Bus()
diff --git a/korean/ibus-hangul/files/patch-src-i18n.h b/korean/ibus-hangul/files/patch-src-i18n.h
deleted file mode 100644
index f4f66f732f6b..000000000000
--- a/korean/ibus-hangul/files/patch-src-i18n.h
+++ /dev/null
@@ -1,21 +0,0 @@
---- src/i18n.h.orig 2009-10-31 02:59:39.000000000 -0400
-+++ src/i18n.h 2011-08-25 19:58:34.000000000 -0400
-@@ -3,9 +3,18 @@
- #ifndef ibus_hangul_i18n_h
- #define ibus_hangul_i18n_h
-
-+#ifdef ENABLE_NLS
-+
- #include <libintl.h>
-
- #define _(str) gettext(str)
- #define N_(str) (str)
-
-+#else /* ENABLE_NLS */
-+
-+#define _(str) (str)
-+#define N_(str) str
-+
-+#endif /* ENABLE_NLS */
-+
- #endif /* ibus_hangul_i18n_h */
diff --git a/korean/ibus-hangul/files/patch-src_engine.c b/korean/ibus-hangul/files/patch-src_engine.c
new file mode 100644
index 000000000000..8c0b510df964
--- /dev/null
+++ b/korean/ibus-hangul/files/patch-src_engine.c
@@ -0,0 +1,10 @@
+--- src/engine.c.orig 2014-10-12 14:36:08 UTC
++++ src/engine.c
+@@ -338,6 +338,7 @@ ibus_hangul_init (IBusBus *bus)
+ value = ibus_config_get_value (config, "panel", "lookup-table-orientation");
+ if (value != NULL) {
+ lookup_table_orientation = g_variant_get_int32(value);
++ g_variant_unref (value);
+ }
+
+ keymap = ibus_keymap_get("us");
diff --git a/korean/ibus-hangul/pkg-plist b/korean/ibus-hangul/pkg-plist
index dad0cebd01c7..fa9e6b1f0f5d 100644
--- a/korean/ibus-hangul/pkg-plist
+++ b/korean/ibus-hangul/pkg-plist
@@ -1,13 +1,8 @@
bin/ibus-setup-hangul
-lib/ibus-hangul/setup/hangul_keyboard_list
libexec/ibus-engine-hangul
libexec/ibus-setup-hangul
share/applications/ibus-setup-hangul.desktop
share/ibus/component/hangul.xml
-share/icons/hicolor/64x64/apps/ibus-hangul.png
-share/icons/hicolor/64x64/apps/ibus-setup-hangul.png
-share/icons/hicolor/scalable/apps/ibus-hangul.svg
-share/icons/hicolor/scalable/apps/ibus-setup-hangul.svg
%%DATADIR%%/data/symbol.txt
%%DATADIR%%/icons/ibus-hangul.png
%%DATADIR%%/icons/ibus-hangul.svg
@@ -21,5 +16,9 @@ share/icons/hicolor/scalable/apps/ibus-setup-hangul.svg
%%DATADIR%%/setup/main.pyc
%%DATADIR%%/setup/main.pyo
%%DATADIR%%/setup/setup.ui
-%%NLS%%share/locale/ko/LC_MESSAGES/ibus-hangul.mo
-%%NLS%%share/locale/zh_CN/LC_MESSAGES/ibus-hangul.mo
+share/icons/hicolor/64x64/apps/ibus-hangul.png
+share/icons/hicolor/64x64/apps/ibus-setup-hangul.png
+share/icons/hicolor/scalable/apps/ibus-hangul.svg
+share/icons/hicolor/scalable/apps/ibus-setup-hangul.svg
+share/locale/ko/LC_MESSAGES/ibus-hangul.mo
+share/locale/zh_CN/LC_MESSAGES/ibus-hangul.mo