aboutsummaryrefslogtreecommitdiff
path: root/korean
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2016-09-14 21:51:57 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2016-09-14 21:51:57 +0000
commit5356433cdc8b2815686e2403202e99636b15ddcb (patch)
treed8f75a099fbe8a0a01f1e05dcccae53feb16f643 /korean
parentceab260574c994af26610e047b3b30c03d263cfb (diff)
downloadports-5356433cdc8b2815686e2403202e99636b15ddcb.tar.gz
ports-5356433cdc8b2815686e2403202e99636b15ddcb.zip
Unbreak the port and modernize.
Notes
Notes: svn path=/head/; revision=422162
Diffstat (limited to 'korean')
-rw-r--r--korean/hunspell/Makefile32
-rw-r--r--korean/hunspell/distinfo5
-rw-r--r--korean/hunspell/files/patch-Makefile8
-rw-r--r--korean/hunspell/files/patch-tests_runtest.py11
4 files changed, 35 insertions, 21 deletions
diff --git a/korean/hunspell/Makefile b/korean/hunspell/Makefile
index 44d0d8fe5863..9f87e699b079 100644
--- a/korean/hunspell/Makefile
+++ b/korean/hunspell/Makefile
@@ -2,32 +2,42 @@
PORTNAME= hunspell
PORTVERSION= 0.5.6
+PORTREVISION= 1
CATEGORIES= korean textproc
-MASTER_SITES= GOOGLE_CODE
-DISTNAME= ${PORTNAME}-dict-ko-${PORTVERSION}
MAINTAINER= jkim@FreeBSD.org
COMMENT= Korean hunspell dictionaries
-LICENSE= GPLv2 LGPL21 MPL
+LICENSE= GPLv2+ LGPL21+ MPL
LICENSE_COMB= dual
+LICENSE_FILE_GPLv2+ = ${WRKSRC}/LICENSE.GPL
+LICENSE_FILE_LGPL21+ = ${WRKSRC}/LICENSE.LGPL
+LICENSE_FILE_MPL= ${WRKSRC}/LICENSE.MPL
-BROKEN= Unfetchable (google code has gone away)
+BUILD_DEPENDS= py${PYTHON_SUFFIX}-lxml>=0:devel/py-lxml
+TEST_DEPENDS= hunspell:textproc/hunspell
-BUILD_DEPENDS+= py*-lxml>=0:devel/py-lxml
+GH_ACCOUNT= changwoo
+GH_PROJECT= ${PORTNAME}-dict-ko
+USE_GITHUB= yes
-USES= gmake python:build tar:xz
+NO_ARCH= yes
+USES= python:build,test
PLIST_FILES= %%DATADIR%%/ko_KR.aff \
%%DATADIR%%/ko_KR.dic
-PROJECTHOST= spellcheck-ko
-
-MAKE_ENV+= PYTHON=${PYTHON_CMD}
+do-build:
+ @(cd ${WRKSRC} && ${PYTHON_CMD} make-aff-dic.py ko_KR.aff ko_KR.dic \
+ dict-ko-builtins.xml dict-ko-galkwi.xml)
+do-test:
+ @(cd ${WRKSRC}/tests && for T in $$(ls -1 *.test); do \
+ echo "Testing $$T..."; \
+ ${PYTHON_CMD} runtest.py $$T || exit 1; done)
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/ko.aff ${STAGEDIR}${DATADIR}/ko_KR.aff
- ${INSTALL_DATA} ${WRKSRC}/ko.dic ${STAGEDIR}${DATADIR}/ko_KR.dic
+ ${INSTALL_DATA} ${WRKSRC}/ko_KR.aff ${WRKSRC}/ko_KR.dic \
+ ${STAGEDIR}${DATADIR}
.include <bsd.port.mk>
diff --git a/korean/hunspell/distinfo b/korean/hunspell/distinfo
index b78520f2f382..8ef3a606d9f0 100644
--- a/korean/hunspell/distinfo
+++ b/korean/hunspell/distinfo
@@ -1,2 +1,3 @@
-SHA256 (hunspell-dict-ko-0.5.6.tar.xz) = 20d5774956504fafbe4be1b225ce9a264d8582648886790a3ad2f6efbdea3a1c
-SIZE (hunspell-dict-ko-0.5.6.tar.xz) = 336100
+TIMESTAMP = 1473875379
+SHA256 (changwoo-hunspell-dict-ko-0.5.6_GH0.tar.gz) = 2caf3b0775d8d6c49866be2682cdf17b2c76d4c151bd1923adbe0b5661b94ee8
+SIZE (changwoo-hunspell-dict-ko-0.5.6_GH0.tar.gz) = 457791
diff --git a/korean/hunspell/files/patch-Makefile b/korean/hunspell/files/patch-Makefile
deleted file mode 100644
index 11a064d3d9c2..000000000000
--- a/korean/hunspell/files/patch-Makefile
+++ /dev/null
@@ -1,8 +0,0 @@
---- Makefile.orig 2011-07-17 16:15:50.000000000 -0400
-+++ Makefile 2011-08-09 13:54:44.000000000 -0400
-@@ -1,4 +1,4 @@
--PYTHON = python
-+PYTHON ?= python
- ZIP = zip -r
-
- AFFIX = ko.aff
diff --git a/korean/hunspell/files/patch-tests_runtest.py b/korean/hunspell/files/patch-tests_runtest.py
new file mode 100644
index 000000000000..8855277d4fa7
--- /dev/null
+++ b/korean/hunspell/files/patch-tests_runtest.py
@@ -0,0 +1,11 @@
+--- tests/runtest.py.orig 2012-10-06 23:29:32 UTC
++++ tests/runtest.py
+@@ -19,7 +19,7 @@ def main():
+ hunspell_cmd = './hunspell'
+ else:
+ hunspell_cmd = 'hunspell'
+- hunspell = subprocess.Popen([hunspell_cmd, '-i', 'UTF-8', '-a', '-d', '../ko'],
++ hunspell = subprocess.Popen([hunspell_cmd, '-i', 'UTF-8', '-a', '-d', '../ko_KR'],
+ stdin=subprocess.PIPE, stdout=subprocess.PIPE)
+ hunspell.stdout.readline() # the first line "Hunspell 1.2.8 ..."
+ lineno = 0