aboutsummaryrefslogtreecommitdiff
path: root/korean
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-07-22 09:00:33 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-07-22 09:00:33 +0000
commit75ce42f49dcaa53f2a58c54c1fd27e10f198f547 (patch)
treead4717cbe820b07176d8690c062eb2d38d8e68e1 /korean
parent507c83b05bfb4227680fe390a557683c991fc55c (diff)
downloadports-75ce42f49dcaa53f2a58c54c1fd27e10f198f547.tar.gz
ports-75ce42f49dcaa53f2a58c54c1fd27e10f198f547.zip
- Switch to options helpers
- Regenerate patches with `make makepatch`
Notes
Notes: svn path=/head/; revision=418913
Diffstat (limited to 'korean')
-rw-r--r--korean/hmconv/Makefile8
-rw-r--r--korean/hmconv/files/patch-hmconv1.0pl3.c8
2 files changed, 9 insertions, 7 deletions
diff --git a/korean/hmconv/Makefile b/korean/hmconv/Makefile
index 10fdc3430db8..f34996caa6d9 100644
--- a/korean/hmconv/Makefile
+++ b/korean/hmconv/Makefile
@@ -20,8 +20,8 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
OPTIONS_DEFINE= DOCS
post-patch:
- ${REINPLACE_CMD} -e 's|^HEDITOR=.*|HEDITOR=$$EDITOR|' \
- ${WRKSRC}/hmailedit
+ @${REINPLACE_CMD} -e 's|^HEDITOR=.*|HEDITOR=$$EDITOR|' \
+ ${WRKSRC}/hmailedit
do-build:
${CC} ${CFLAGS} -o ${WRKSRC}/hmconv ${WRKSRC}/hmconv1.0pl3.c
@@ -29,6 +29,8 @@ do-build:
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/hmailedit ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/hmconv ${STAGEDIR}${PREFIX}/bin
- cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDOCS}" ${STAGEDIR}${DOCSDIR}
+
+do-install-DOCS-on:
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDOCS}" ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/korean/hmconv/files/patch-hmconv1.0pl3.c b/korean/hmconv/files/patch-hmconv1.0pl3.c
index 56c11913798b..0c41be6ef6bd 100644
--- a/korean/hmconv/files/patch-hmconv1.0pl3.c
+++ b/korean/hmconv/files/patch-hmconv1.0pl3.c
@@ -1,5 +1,5 @@
---- hmconv1.0pl3.c.orig 1996-07-22 23:16:14.000000000 -0400
-+++ hmconv1.0pl3.c 2013-06-12 14:24:05.000000000 -0400
+--- hmconv1.0pl3.c.orig 1996-07-23 03:16:14 UTC
++++ hmconv1.0pl3.c
@@ -46,6 +46,7 @@
@@ -8,7 +8,7 @@
#include <string.h>
#define isksc(c) ( (unsigned char) (c) > (unsigned char) '\240' && \
-@@ -125,6 +126,7 @@
+@@ -125,6 +126,7 @@ char *optstring;
}
#ifndef KNR
@@ -16,7 +16,7 @@
main (int argc, char **argv)
#else
main (argc,argv)
-@@ -208,7 +210,7 @@
+@@ -208,7 +210,7 @@ int convert()
if ( !ishangul) { /* KSC 5601 doesn't appear, yet */
fputs((char *) line,out); /* no conversion */