aboutsummaryrefslogtreecommitdiff
path: root/lang/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2008-11-30 14:03:58 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2008-11-30 14:03:58 +0000
commit687c7eb2b59872bebc6a930ccf8367207eb41b7e (patch)
tree1883361fb076ba35eea8596facc11656d5ba1895 /lang/Makefile
parent49b411e020e1c7842d7eca675d56c27b0b64a0db (diff)
Tiny C Compiler
Features: * SMALL! You can compile and execute C code everywhere, for example on rescue disks (about 100KB for x86 TCC executable, including C preprocessor, C compiler, assembler and linker). * FAST! tcc generates x86 code. No byte code overhead. Compile, assemble and link several times faster than GCC. * UNLIMITED! Any C dynamic library can be used directly. TCC is heading torward full ISOC99 compliance. TCC can of course compile itself. * SAFE! tcc includes an optional memory and bound checker. Bound checked code can be mixed freely with standard code. * Compile and execute C source directly. No linking or assembly necessary. Full C preprocessor and GNU-like assembler included. * C script supported : just add '#!/usr/local/bin/tcc -run' at the first line of your C source, and execute it directly from the command line. * With libtcc, you can use TCC as a backend for dynamic code generation. WWW: http://bellard.org/tcc/
Notes
Notes: svn path=/head/; revision=223624
Diffstat (limited to 'lang/Makefile')
-rw-r--r--lang/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 3e546da9a296..89e08bca146c 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -326,6 +326,7 @@
SUBDIR += swi-pl
SUBDIR += sxm
SUBDIR += t3x
+ SUBDIR += tcc
SUBDIR += tcl-manual
SUBDIR += tcl-wrapper
SUBDIR += tcl80