aboutsummaryrefslogtreecommitdiff
path: root/lang/afnix/Makefile
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2007-04-19 12:42:27 +0000
committerJohan van Selst <johans@FreeBSD.org>2007-04-19 12:42:27 +0000
commitf093c02ceb24b89088deabfdd2db90a6f9d54c74 (patch)
tree196b335fe8534d9d95b22fd8846d300202bfbf53 /lang/afnix/Makefile
parent5799bb16048053a564ffc8a99c86b2d39a960d3c (diff)
Notes
Diffstat (limited to 'lang/afnix/Makefile')
-rw-r--r--lang/afnix/Makefile26
1 files changed, 24 insertions, 2 deletions
diff --git a/lang/afnix/Makefile b/lang/afnix/Makefile
index d61aece993d4..4f8b067a0094 100644
--- a/lang/afnix/Makefile
+++ b/lang/afnix/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= afnix
-PORTVERSION= 1.4.3
+PORTVERSION= 1.5.0
CATEGORIES= lang
MASTER_SITES= http://www.afnix.org/ftp/%SUBDIR%/ \
ftp://ftp.stack.nl/pub/users/johans/afnix/
@@ -26,9 +26,15 @@ CONFIGURE_ARGS= -o --prefix "${PREFIX}" --compiler freebsd
MAKE_ENV= CXX="${CXX}" PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
+PORTDOCS= *
PLIST_SUB= PORTVER=${PORTVERSION:R}
-MAN1= axc.1 axd.1 axi.1 axl.1 axs.1
+MAN1= adp::afnix.1 amd::afnix.1 axc::afnix.1 axd::afnix.1 \
+ axi::afnix.1 axl::afnix.1 axs::afnix.1
+MAN3= gfx::afnix.3 net::afnix.3 nwg::afnix.3 pim::afnix.3 \
+ sio::afnix.3 sps::afnix.3 sys::afnix.3 txt::afnix.3 xml::afnix.3
+MAN4= wax::afnix.4 xpe::afnix.4
+MAN7= eul::afnix.7 vol-0::afnix.7 vol-1::afnix.7 vol-2::afnix.7
.include <bsd.port.pre.mk>
@@ -44,4 +50,20 @@ post-patch:
@${REINPLACE_CMD} -e '/uname -r/s/\\\./[.-]/' \
${WRKSRC}/cnf/bin/afnix-guess
+post-install:
+.ifdef NOPORTDOCS
+# install all manuals, but no other documentation
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} doc
+. for i in prj/amd/doc prj/adp/doc src/mod/xml src/srv/xpe
+ @cd ${WRKSRC}/${i} && ${SETENV} ${MAKE_ENV} ${GMAKE} doc
+. endfor
+. for i in ${MAN1} ${MAN3} ${MAN4} ${MAN7}
+ ${INSTALL_MAN} \
+ ${WRKSRC}/bld/${PORTNAME}-doc-${PORTVERSION:S,.,-,g}/man/$i \
+ ${MANPREFIX}/man/man${i:E}/
+. endfor
+.else
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} instdoc
+.endif
+
.include <bsd.port.post.mk>