aboutsummaryrefslogtreecommitdiff
path: root/lang/afnix
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2006-09-20 18:24:24 +0000
committerJohan van Selst <johans@FreeBSD.org>2006-09-20 18:24:24 +0000
commit16bbbe6d2e9a78f106f547130d6fbe1505f9ae59 (patch)
tree3da3391d2a5eed86b3bd5540605d836f2723f56c /lang/afnix
parenta8530dd5743a4e74e67d539c16700a3f6e0bac5a (diff)
downloadports-16bbbe6d2e9a78f106f547130d6fbe1505f9ae59.tar.gz
ports-16bbbe6d2e9a78f106f547130d6fbe1505f9ae59.zip
Notes
Diffstat (limited to 'lang/afnix')
-rw-r--r--lang/afnix/Makefile6
-rw-r--r--lang/afnix/distinfo6
-rw-r--r--lang/afnix/files/patch-cnf__bin__afnix-guess10
-rw-r--r--lang/afnix/files/patch-cnf_mak_afnix-freebsd.mak33
-rw-r--r--lang/afnix/files/patch-cnf_mak_afnix-rule.mak53
-rw-r--r--lang/afnix/files/patch-src_lib_plt_shl_cclk.cxx13
-rw-r--r--lang/afnix/pkg-plist51
7 files changed, 102 insertions, 70 deletions
diff --git a/lang/afnix/Makefile b/lang/afnix/Makefile
index 9de86f5ecec8..990f679ea9ae 100644
--- a/lang/afnix/Makefile
+++ b/lang/afnix/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= afnix
-PORTVERSION= 1.2.2
+PORTVERSION= 1.3.0
CATEGORIES= lang
MASTER_SITES= http://www.afnix.org/ftp/%SUBDIR%/ \
ftp://ftp.stack.nl/pub/users/johans/afnix/
@@ -25,6 +25,7 @@ CONFIGURE_SCRIPT= cnf/bin/afnix-setup
CONFIGURE_ARGS= -o --prefix "${PREFIX}" --compiler freebsd
MAKE_ENV= CXX="${CXX}" PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
+INSTALLS_SHLIB= yes
PLIST_SUB= PORTVER=${PORTVERSION:R}
@@ -38,5 +39,8 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e 's|$$(CP)|$$(BSD_INSTALL_PROGRAM)|' \
${WRKSRC}/src/*/*/exe/Makefile
+ @${REINPLACE_CMD} -e '/\.rtf/d' ${WRKSRC}/etc/Makefile
+ @${REINPLACE_CMD} -e '/^MANDIR/s/SHRDIR/MANPREFIX/' \
+ ${WRKSRC}/cnf/mak/afnix-defs.mak
.include <bsd.port.post.mk>
diff --git a/lang/afnix/distinfo b/lang/afnix/distinfo
index 432626346680..30121ba36234 100644
--- a/lang/afnix/distinfo
+++ b/lang/afnix/distinfo
@@ -1,3 +1,3 @@
-MD5 (afnix-src-1-2-2.tgz) = 57f72e1d39c6fb76ecea6a3ae98528d6
-SHA256 (afnix-src-1-2-2.tgz) = 931c80590357dba214b7bdb251247fea4889d19b664b863838228ce69ab2fca6
-SIZE (afnix-src-1-2-2.tgz) = 577477
+MD5 (afnix-src-1-3-0.tgz) = bdeab68e2903fbe29915c16c529ccca0
+SHA256 (afnix-src-1-3-0.tgz) = f083cd24f807b122407d9950559a40d3872b04c591bb927ad8eef3d86ca94a48
+SIZE (afnix-src-1-3-0.tgz) = 674794
diff --git a/lang/afnix/files/patch-cnf__bin__afnix-guess b/lang/afnix/files/patch-cnf__bin__afnix-guess
deleted file mode 100644
index 22eacaa3c576..000000000000
--- a/lang/afnix/files/patch-cnf__bin__afnix-guess
+++ /dev/null
@@ -1,10 +0,0 @@
---- cnf/bin/afnix-guess.orig Mon Oct 10 11:02:54 2005
-+++ cnf/bin/afnix-guess Mon Oct 10 11:03:10 2005
-@@ -116,6 +116,7 @@
- ia64) proc_name=ia64;;
- s390*) proc_name=s390;;
- x86_64) proc_name=x64;;
-+ amd64) proc_name=x64;;
- esac
- }
-
diff --git a/lang/afnix/files/patch-cnf_mak_afnix-freebsd.mak b/lang/afnix/files/patch-cnf_mak_afnix-freebsd.mak
index feaf4b9234e6..baaecc60cb34 100644
--- a/lang/afnix/files/patch-cnf_mak_afnix-freebsd.mak
+++ b/lang/afnix/files/patch-cnf_mak_afnix-freebsd.mak
@@ -1,14 +1,5 @@
--- cnf/mak/afnix-freebsd.mak.orig Wed Aug 31 21:59:00 2005
+++ cnf/mak/afnix-freebsd.mak Wed Aug 31 22:00:29 2005
-@@ -1,6 +1,6 @@
- # ----------------------------------------------------------------------------
--# - afnix-gcc-3 -
--# - afnix compiler configuration - gcc configuration -
-+# - afnix-freebsd -
-+# - afnix compiler configuration - FreeBSD system compiler configuration -
- # ----------------------------------------------------------------------------
- # - This program is free software; you can redistribute it and/or modify -
- # - it provided that this copyright notice is kept intact. -
@@ -18,21 +18,21 @@
# - compiler and linker section -
# ----------------------------------------------------------------------------
@@ -19,14 +10,14 @@
+CC = $(CXX)
+LD = $(CXX)
+LK = $(CXX)
- AR = ar rc
+ AR = ar
STDCCFLAGS = -Wall -Werror -MMD -fno-builtin
STACCFLAGS =
DYNCCFLAGS = -fPIC
PLTCCFLAGS =
DEBUGFLAGS = -g
-OPTCCFLAGS = -O2
-+OPTCCFLAGS =
++OPTCCFLAGS =
PFLCCFLAGS = -g -pg
COVCCFLAGS = -g -fprofile-arcs -ftest-coverage
CPPCCFLAGS = -nostdinc -nostdinc++
@@ -36,7 +27,7 @@
DBGDEFINES = -DDEBUG
OPTDEFINES =
STDINCLUDE =
-@@ -68,8 +68,8 @@
+@@ -75,8 +75,8 @@
# adjust for freebsd platform
ifeq ($(PLATNAME),freebsd)
@@ -44,10 +35,10 @@
-LK = g++
+LD = $(CXX)
+LK = $(CXX)
+ ARFLAGS = rc
LDFLAGS = -shared
AFXCPPLIBS =
- ifeq ($(LKMODE),soname)
-@@ -85,7 +85,7 @@
+@@ -93,7 +93,7 @@
# adjust linker flags for freebsd
ifeq ($(PLATNAME),freebsd)
@@ -56,17 +47,3 @@
endif
# ----------------------------------------------------------------------------
-@@ -102,13 +102,10 @@
-
- # adjust intel processor
- ifeq ($(PROCNAME)-$(PROCTYPE),ia-586)
--PLTCCFLAGS += -mcpu=i586
- endif
- ifeq ($(PROCNAME)-$(PROCTYPE),ia-686)
--PLTCCFLAGS += -mcpu=i686
- endif
-
- # adjust sparc processor
- ifeq ($(PROCNAME)-$(PROCTYPE),sparc-ultra)
--PLTCCFLAGS += -mcpu=ultrasparc -mtune=ultrasparc
- endif
diff --git a/lang/afnix/files/patch-cnf_mak_afnix-rule.mak b/lang/afnix/files/patch-cnf_mak_afnix-rule.mak
index af6613c482fa..1e7b27a9f249 100644
--- a/lang/afnix/files/patch-cnf_mak_afnix-rule.mak
+++ b/lang/afnix/files/patch-cnf_mak_afnix-rule.mak
@@ -1,47 +1,58 @@
--- cnf/mak/afnix-rule.mak.orig Thu Aug 25 07:13:37 2005
+++ cnf/mak/afnix-rule.mak Wed Aug 31 22:43:14 2005
-@@ -22,7 +22,7 @@
-
+@@ -24,7 +24,7 @@
ifeq ($(CCMODE),optimized)
+ ENVFLAGS = $(STDEVFLAGS) $(PLTEVFLAGS)
CPPFLAGS = $(STDCCFLAGS) $(PLTCCFLAGS) $(CPPCCFLAGS) $(OPTCCFLAGS)
- CXXFLAGS = $(STDCCFLAGS) $(PLTCCFLAGS) $(CXXCCFLAGS) $(OPTCCFLAGS)
-+ CXXFLAGS += $(STDCCFLAGS) $(PLTCCFLAGS) $(CXXCCFLAGS) $(OPTCCFLAGS)
++ CXXFLAGS += $(STDCCFLAGS) $(PLTCCFLAGS) $(CXXCCFLAGS) $(OPTCCFLAGS)
CCDEFINE = $(STDDEFINES) $(PLTDEFINES) $(OPTDEFINES)
endif
-@@ -78,7 +78,7 @@
+@@ -89,7 +89,7 @@
-include *.d
%.o : %.cpp
-- $(CC) $(PPFLAGS) $(DEFINES) $(PPINCLS) -o $@ -c $<
-+ $(CC) $(CXXFLAGS) $(PPFLAGS) $(DEFINES) $(PPINCLS) -o $@ -c $<
+- $(ENVFLAGS) $(CC) $(PPFLAGS) $(DEFINES) $(PPINCLS) -o $@ -c $<
++ $(ENVFLAGS) $(CC) $(CXXFLAGS) $(PPFLAGS) $(DEFINES) $(PPINCLS) -o $@ -c $<
%.o : %.cxx
- $(CC) $(XXFLAGS) $(DEFINES) $(XXINCLS) -o $@ -c $<
-@@ -95,7 +95,7 @@
+ $(ENVFLAGS) $(CC) $(XXFLAGS) $(DEFINES) $(XXINCLS) -o $@ -c $<
+@@ -117,7 +117,7 @@
install-arlib: $(ARLIB)
@$(MKDIR) $(LIBDIR)
- @$(CP) $(ARLIB) $(LIBDIR)
-+ @$(BSD_INSTALL_DATA) $(ARLIB) $(LIBDIR)
++ @$(BSD_INSTALL_PROGRAM) $(ARLIB) $(LIBDIR)
.PHONY: install-arlib
else
install-arlib: $(ARLIB)
-@@ -117,7 +117,7 @@
+@@ -141,7 +141,7 @@
- install-solib : $(SOLIB)
+ install-dylib : $(DYLIB)
@$(MKDIR) $(LIBDIR)
-- @$(CP) $(SOLIB) $(LIBDIR)
-+ @$(BSD_INSTALL_PROGRAM) $(SOLIB) $(LIBDIR)
- .PHONY: install-solib
+- @$(CP) $(DYLIB) $(LIBDIR)
++ @$(BSD_INSTALL_PROGRAM) $(DYLIB) $(LIBDIR)
+ .PHONY: install-dylib
endif
-@@ -136,7 +136,7 @@
+@@ -160,8 +160,5 @@
- install-solib : $(SOVERS)
+ install-dylib : $(DYLIB)
+ @$(MKDIR) $(LIBDIR)
+- @$(CP) $(SOVRS) $(LIBDIR)
+- @$(RM) $(LIBDIR)/$(SOMIN)
+- @$(RM) $(LIBDIR)/$(DYLIB)
+- @$(LN) $(SOVRS) $(LIBDIR)/$(SOMIN)
+- @$(LN) $(SOMIN) $(LIBDIR)/$(DYLIB)
++ @$(BSD_INSTALL_PROGRAM) $(SOVRS) $(LIBDIR)/$(SOMAJ)
++ @$(LN) $(SOMAJ) $(LIBDIR)/$(DYLIB)
+@@ -187,7 +187,7 @@
+
+ install-dylib : $(DYLIB)
@$(MKDIR) $(LIBDIR)
-- @$(CP) $(SOVERS) $(LIBDIR)
-+ @$(BSD_INSTALL_PROGRAM) $(SOVERS) $(LIBDIR)
- @$(RM) $(LIBDIR)/$(SONAME)
- @$(RM) $(LIBDIR)/$(SOLIB)
- @$(LN) $(SOVERS) $(LIBDIR)/$(SONAME)
+- @$(CP) $(DYVRS) $(LIBDIR)
++ @$(BSD_INSTALL_PROGRAM) $(DYVRS) $(LIBDIR)
+ @$(RM) $(LIBDIR)/$(DYLIB)
+ @$(RM) $(LIBDIR)/$(DYMAJ)
+ @$(RM) $(LIBDIR)/$(DYMIN)
diff --git a/lang/afnix/files/patch-src_lib_plt_shl_cclk.cxx b/lang/afnix/files/patch-src_lib_plt_shl_cclk.cxx
new file mode 100644
index 000000000000..ca22d624dbd4
--- /dev/null
+++ b/lang/afnix/files/patch-src_lib_plt_shl_cclk.cxx
@@ -0,0 +1,13 @@
+--- src/lib/plt/shl/cclk.cxx.orig Fri Jul 14 12:03:50 2006
++++ src/lib/plt/shl/cclk.cxx Thu Aug 3 13:58:51 2006
+@@ -58,8 +58,8 @@ namespace afnix {
+ // initialize local and utc structure
+ struct tm utm;
+ struct tm ltm;
+- if (gmtime_r (&(tval.tv_sec), &utm) == NULL) return 0;
+- if (localtime_r (&(tval.tv_sec), &ltm) == NULL) return 0;
++ if (gmtime_r ((time_t *)&(tval.tv_sec), &utm) == NULL) return 0;
++ if (localtime_r ((time_t *)&(tval.tv_sec), &ltm) == NULL) return 0;
+ // compute local time in second
+ t_long lts = (ltm.tm_yday * 86400) + (ltm.tm_hour * 3600) +
+ (ltm.tm_min * 60) + ltm.tm_sec;
diff --git a/lang/afnix/pkg-plist b/lang/afnix/pkg-plist
index fd92661663a4..05a70fb5998c 100644
--- a/lang/afnix/pkg-plist
+++ b/lang/afnix/pkg-plist
@@ -26,7 +26,6 @@ include/afnix/eng/Localset.hpp
include/afnix/eng/Meta.hpp
include/afnix/eng/Module.hpp
include/afnix/eng/Nameset.hpp
-include/afnix/eng/Options.hpp
include/afnix/eng/Printer.hpp
include/afnix/eng/Promise.hpp
include/afnix/eng/Qualified.hpp
@@ -37,6 +36,11 @@ include/afnix/eng/Return.hpp
include/afnix/eng/Superset.hpp
include/afnix/eng/Symbol.hpp
include/afnix/eng/Token.hpp
+include/afnix/gfx/Edge.hpp
+include/afnix/gfx/Graph.hpp
+include/afnix/gfx/Libgfx.hpp
+include/afnix/gfx/Predgfx.hpp
+include/afnix/gfx/Vertex.hpp
include/afnix/net/Address.hpp
include/afnix/net/Datagram.hpp
include/afnix/net/Libnet.hpp
@@ -51,6 +55,11 @@ include/afnix/net/TcpSocket.hpp
include/afnix/net/UdpClient.hpp
include/afnix/net/UdpServer.hpp
include/afnix/net/UdpSocket.hpp
+include/afnix/pim/Appointer.hpp
+include/afnix/pim/Assistant.hpp
+include/afnix/pim/Libpim.hpp
+include/afnix/pim/Predpim.hpp
+include/afnix/pim/Slot.hpp
include/afnix/plt/cclk.hpp
include/afnix/plt/ccnf.hpp
include/afnix/plt/ccnv.hpp
@@ -74,19 +83,20 @@ include/afnix/sci/Hasher.hpp
include/afnix/sci/InputCipher.hpp
include/afnix/sci/Key.hpp
include/afnix/sci/Md5.hpp
-include/afnix/sci/Privsci.hpp
include/afnix/sci/Sha1.hpp
include/afnix/sci/Sha256.hpp
include/afnix/sci/Sha384.hpp
include/afnix/sci/Sha512.hpp
include/afnix/sio/Directory.hpp
include/afnix/sio/Libsio.hpp
-include/afnix/sio/Pathsio.hpp
+include/afnix/sio/Logtee.hpp
include/afnix/sio/Predsio.hpp
include/afnix/sio/Selector.hpp
+include/afnix/sio/SioCalls.hpp
include/afnix/sps/Cell.hpp
include/afnix/sps/Folio.hpp
include/afnix/sps/Importer.hpp
+include/afnix/sps/Index.hpp
include/afnix/sps/Libsps.hpp
include/afnix/sps/Persist.hpp
include/afnix/sps/Predsps.hpp
@@ -94,6 +104,7 @@ include/afnix/sps/Record.hpp
include/afnix/sps/Sheet.hpp
include/afnix/sps/SpsCalls.hpp
include/afnix/sps/Spssid.hpp
+include/afnix/sps/Xref.hpp
include/afnix/std/Ascii.hpp
include/afnix/std/BitSet.hpp
include/afnix/std/Boolean.hpp
@@ -104,10 +115,11 @@ include/afnix/std/Cilo.hpp
include/afnix/std/Condvar.hpp
include/afnix/std/Cons.hpp
include/afnix/std/Cursor.hpp
+include/afnix/std/Date.hpp
include/afnix/std/Exception.hpp
include/afnix/std/Finalize.hpp
-include/afnix/std/Graph.hpp
include/afnix/std/HashTable.hpp
+include/afnix/std/Heap.hpp
include/afnix/std/Input.hpp
include/afnix/std/InputFile.hpp
include/afnix/std/InputMapped.hpp
@@ -123,11 +135,13 @@ include/afnix/std/List.hpp
include/afnix/std/Literal.hpp
include/afnix/std/Loader.hpp
include/afnix/std/Lockrw.hpp
+include/afnix/std/Logger.hpp
include/afnix/std/Method.hpp
include/afnix/std/Monitor.hpp
include/afnix/std/Mutex.hpp
include/afnix/std/NameTable.hpp
include/afnix/std/Object.hpp
+include/afnix/std/Options.hpp
include/afnix/std/Output.hpp
include/afnix/std/OutputFile.hpp
include/afnix/std/OutputString.hpp
@@ -135,6 +149,7 @@ include/afnix/std/OutputTerm.hpp
include/afnix/std/PrintTable.hpp
include/afnix/std/Qarray.hpp
include/afnix/std/QuarkTable.hpp
+include/afnix/std/QuarkZone.hpp
include/afnix/std/Queue.hpp
include/afnix/std/Reactor.hpp
include/afnix/std/Real.hpp
@@ -146,6 +161,7 @@ include/afnix/std/Serial.hpp
include/afnix/std/Set.hpp
include/afnix/std/Sorter.hpp
include/afnix/std/Stack.hpp
+include/afnix/std/Strbuf.hpp
include/afnix/std/Stream.hpp
include/afnix/std/String.hpp
include/afnix/std/Strvec.hpp
@@ -154,9 +170,11 @@ include/afnix/std/Terminal.hpp
include/afnix/std/Thread.hpp
include/afnix/std/Thrmap.hpp
include/afnix/std/Time.hpp
-include/afnix/std/UnicodeTable.hpp
-include/afnix/std/UnicodeMapper.hpp
+include/afnix/std/Transcoder.hpp
include/afnix/std/Unicode.hpp
+include/afnix/std/Unimapper.hpp
+include/afnix/std/Unitabler.hpp
+include/afnix/std/Utility.hpp
include/afnix/std/Vector.hpp
include/afnix/sys/Libsys.hpp
include/afnix/sys/Predsys.hpp
@@ -176,33 +194,52 @@ include/afnix/www/HtmlPage.hpp
include/afnix/www/HtmlRef.hpp
include/afnix/www/HtmlTable.hpp
include/afnix/www/HtmlTag.hpp
+include/afnix/www/HtmlTd.hpp
+include/afnix/www/HtmlTr.hpp
include/afnix/www/Libwww.hpp
include/afnix/www/Predwww.hpp
include/afnix/www/Url.hpp
-include/afnix/www/XHtmlPage.hpp
lib/libafnix-eng.a
lib/libafnix-eng.so
+lib/libafnix-eng.so.1
+lib/libafnix-gfx.a
+lib/libafnix-gfx.so
+lib/libafnix-gfx.so.1
lib/libafnix-net.a
lib/libafnix-net.so
+lib/libafnix-net.so.1
+lib/libafnix-pim.a
+lib/libafnix-pim.so
+lib/libafnix-pim.so.1
lib/libafnix-plt.a
lib/libafnix-plt.so
+lib/libafnix-plt.so.1
lib/libafnix-sci.a
lib/libafnix-sci.so
+lib/libafnix-sci.so.1
lib/libafnix-sio.a
lib/libafnix-sio.so
+lib/libafnix-sio.so.1
lib/libafnix-sps.a
lib/libafnix-sps.so
+lib/libafnix-sps.so.1
lib/libafnix-std.a
lib/libafnix-std.so
+lib/libafnix-std.so.1
lib/libafnix-sys.a
lib/libafnix-sys.so
+lib/libafnix-sys.so.1
lib/libafnix-txt.a
lib/libafnix-txt.so
+lib/libafnix-txt.so.1
lib/libafnix-www.a
lib/libafnix-www.so
+lib/libafnix-www.so.1
@dirrm etc/afnix
@dirrm include/afnix/eng
+@dirrm include/afnix/gfx
@dirrm include/afnix/net
+@dirrm include/afnix/pim
@dirrm include/afnix/plt
@dirrm include/afnix/sci
@dirrm include/afnix/sio