aboutsummaryrefslogtreecommitdiff
path: root/lang/afnix
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-08-31 21:47:54 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-08-31 21:47:54 +0000
commitd522ade7a89002a6d002a0c9c034d9d6d7ac2709 (patch)
tree7290ec2ed61e0068a0d734bae87290a61378243e /lang/afnix
parent1080ef5db07694a3ef76c0444e2f1bcd269b13fd (diff)
downloadports-d522ade7a89002a6d002a0c9c034d9d6d7ac2709.tar.gz
ports-d522ade7a89002a6d002a0c9c034d9d6d7ac2709.zip
Notes
Diffstat (limited to 'lang/afnix')
-rw-r--r--lang/afnix/Makefile19
-rw-r--r--lang/afnix/distinfo4
-rw-r--r--lang/afnix/files/patch-cnf_bin_afnix-guess10
-rw-r--r--lang/afnix/files/patch-cnf_mak_afnix-defs.mak14
-rw-r--r--lang/afnix/files/patch-cnf_mak_afnix-freebsd.mak72
-rw-r--r--lang/afnix/files/patch-cnf_mak_afnix-gcc-3.mak20
-rw-r--r--lang/afnix/files/patch-cnf_mak_afnix-rule.mak62
-rw-r--r--lang/afnix/files/patch-src_lib_plt_acf_Makefile11
-rw-r--r--lang/afnix/files/patch-src_plt_acf_ccnf.cpp37
-rw-r--r--lang/afnix/files/patch-src_plt_lib_cclk.cxx22
-rw-r--r--lang/afnix/files/patch-src_plt_lib_cdir.cxx10
-rw-r--r--lang/afnix/pkg-plist120
12 files changed, 198 insertions, 203 deletions
diff --git a/lang/afnix/Makefile b/lang/afnix/Makefile
index 77113c6ea2a1..5554f2fbf685 100644
--- a/lang/afnix/Makefile
+++ b/lang/afnix/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= afnix
-PORTVERSION= 1.0.3
+PORTVERSION= 1.1.1
CATEGORIES= lang
MASTER_SITES= http://www.afnix.org/ftp/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTNAME}-${PORTVERSION:S,.,-,g}
@@ -17,19 +17,26 @@ EXTRACT_SUFX= .tgz
MAINTAINER= johans@stack.nl
COMMENT= A multi-threaded functional programming language
+USE_REINPLACE= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
+HAS_CONFIGURE= yes
+CONFIGURE_SCRIPT= cnf/bin/afnix-setup
+CONFIGURE_ARGS= -o --prefix "${PREFIX}" --compiler freebsd
+MAKE_ENV= CXX="${CXX}" PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}"
PLIST_SUB= PORTVER=${PORTVERSION:R}
-MAN1= afnix.1 axc.1 axd.1 axl.1
+MAN1= axc.1 axd.1 axi.1 axl.1 axs.1
.include <bsd.port.pre.mk>
-do-configure:
- @${WRKSRC}/cnf/bin/${PORTNAME}-setup -o
+post-extract:
+ @cd ${WRKSRC}/cnf/mak && ${CP} -f afnix-gcc-3.mak afnix-freebsd.mak
-post-install:
- @${STRIP_CMD} ${PREFIX}/bin/${PORTNAME}
+post-patch:
+ @${REINPLACE_CMD} -e 's|$$(CP)|$$(BSD_INSTALL_PROGRAM)|' \
+ ${WRKSRC}/src/*/*/exe/Makefile
.include <bsd.port.post.mk>
diff --git a/lang/afnix/distinfo b/lang/afnix/distinfo
index a5ec64b08284..bead1f7a3f59 100644
--- a/lang/afnix/distinfo
+++ b/lang/afnix/distinfo
@@ -1,2 +1,2 @@
-MD5 (afnix-src-1-0-3.tgz) = 84b5af474c095b4c1c6e59ecaf61232a
-SIZE (afnix-src-1-0-3.tgz) = 521211
+MD5 (afnix-src-1-1-1.tgz) = 2f5bd3739c18f2e1bc0026a812121c5c
+SIZE (afnix-src-1-1-1.tgz) = 547099
diff --git a/lang/afnix/files/patch-cnf_bin_afnix-guess b/lang/afnix/files/patch-cnf_bin_afnix-guess
deleted file mode 100644
index e0b9521c4794..000000000000
--- a/lang/afnix/files/patch-cnf_bin_afnix-guess
+++ /dev/null
@@ -1,10 +0,0 @@
---- cnf/bin/afnix-guess.orig Wed Jan 12 06:05:00 2005
-+++ cnf/bin/afnix-guess Wed Feb 16 19:18:04 2005
-@@ -113,6 +113,7 @@
- mips) proc_name=mips;;
- mipsel) proc_name=mipsel;;
- parisc*) proc_name=pa64;;
-+ amd64) proc_name=amd64;;
- ia64) proc_name=ia64;;
- s390*) proc_name=s390;;
- x86_64) proc_name=x64;;
diff --git a/lang/afnix/files/patch-cnf_mak_afnix-defs.mak b/lang/afnix/files/patch-cnf_mak_afnix-defs.mak
deleted file mode 100644
index 667e04179cac..000000000000
--- a/lang/afnix/files/patch-cnf_mak_afnix-defs.mak
+++ /dev/null
@@ -1,14 +0,0 @@
---- cnf/mak/afnix-defs.mak.orig Wed Feb 16 19:35:18 2005
-+++ cnf/mak/afnix-defs.mak Wed Feb 16 19:37:55 2005
-@@ -58,9 +58,9 @@
- BINDIR = $(PREFIX)/bin
- LIBDIR = $(PREFIX)/lib
- HDRDIR = $(SHRDIR)/include/afnix
--DOCDIR = $(SHRDIR)/doc/afnix
-+DOCDIR = $(SHRDIR)/share/doc/afnix
- MANDIR = $(SHRDIR)/man
--ETCDIR = $(SHRDIR)/etc/afnix
-+ETCDIR = $(SHRDIR)/share/doc/afnix
-
- # ----------------------------------------------------------------------------
- # - other shared commands and scripts -
diff --git a/lang/afnix/files/patch-cnf_mak_afnix-freebsd.mak b/lang/afnix/files/patch-cnf_mak_afnix-freebsd.mak
new file mode 100644
index 000000000000..feaf4b9234e6
--- /dev/null
+++ b/lang/afnix/files/patch-cnf_mak_afnix-freebsd.mak
@@ -0,0 +1,72 @@
+--- cnf/mak/afnix-freebsd.mak.orig Wed Aug 31 21:59:00 2005
++++ cnf/mak/afnix-freebsd.mak Wed Aug 31 22:00:29 2005
+@@ -1,6 +1,6 @@
+ # ----------------------------------------------------------------------------
+-# - afnix-gcc-3 -
+-# - afnix compiler configuration - gcc configuration -
++# - afnix-freebsd -
++# - afnix compiler configuration - FreeBSD system compiler configuration -
+ # ----------------------------------------------------------------------------
+ # - This program is free software; you can redistribute it and/or modify -
+ # - it provided that this copyright notice is kept intact. -
+@@ -18,21 +18,21 @@
+ # - compiler and linker section -
+ # ----------------------------------------------------------------------------
+
+-CC = g++
+-LD = gcc
+-LK = gcc
++CC = $(CXX)
++LD = $(CXX)
++LK = $(CXX)
+ AR = ar rc
+ STDCCFLAGS = -Wall -Werror -MMD -fno-builtin
+ STACCFLAGS =
+ DYNCCFLAGS = -fPIC
+ PLTCCFLAGS =
+ DEBUGFLAGS = -g
+-OPTCCFLAGS = -O2
++OPTCCFLAGS =
+ PFLCCFLAGS = -g -pg
+ COVCCFLAGS = -g -fprofile-arcs -ftest-coverage
+ CPPCCFLAGS = -nostdinc -nostdinc++
+ CXXCCFLAGS =
+-STDDEFINES = -D_REENTRANT
++STDDEFINES = $(PTHREAD_CFLAGS)
+ DBGDEFINES = -DDEBUG
+ OPTDEFINES =
+ STDINCLUDE =
+@@ -68,8 +68,8 @@
+
+ # adjust for freebsd platform
+ ifeq ($(PLATNAME),freebsd)
+-LD = g++
+-LK = g++
++LD = $(CXX)
++LK = $(CXX)
+ LDFLAGS = -shared
+ AFXCPPLIBS =
+ ifeq ($(LKMODE),soname)
+@@ -85,7 +85,7 @@
+
+ # adjust linker flags for freebsd
+ ifeq ($(PLATNAME),freebsd)
+-LKFLAGS = -pthread
++LKFLAGS = $(PTHREAD_LIBS)
+ endif
+
+ # ----------------------------------------------------------------------------
+@@ -102,13 +102,10 @@
+
+ # adjust intel processor
+ ifeq ($(PROCNAME)-$(PROCTYPE),ia-586)
+-PLTCCFLAGS += -mcpu=i586
+ endif
+ ifeq ($(PROCNAME)-$(PROCTYPE),ia-686)
+-PLTCCFLAGS += -mcpu=i686
+ endif
+
+ # adjust sparc processor
+ ifeq ($(PROCNAME)-$(PROCTYPE),sparc-ultra)
+-PLTCCFLAGS += -mcpu=ultrasparc -mtune=ultrasparc
+ endif
diff --git a/lang/afnix/files/patch-cnf_mak_afnix-gcc-3.mak b/lang/afnix/files/patch-cnf_mak_afnix-gcc-3.mak
deleted file mode 100644
index bc8fdbd82820..000000000000
--- a/lang/afnix/files/patch-cnf_mak_afnix-gcc-3.mak
+++ /dev/null
@@ -1,20 +0,0 @@
---- cnf/mak/afnix-gcc-3.mak.orig Wed Jan 12 06:05:00 2005
-+++ cnf/mak/afnix-gcc-3.mak Wed Feb 16 19:18:04 2005
-@@ -22,7 +22,7 @@
- LD = gcc
- LK = gcc
- AR = ar rc
--STDCCFLAGS = -Wall -Werror -MMD -fno-builtin
-+STDCCFLAGS = -Wall -MMD -fno-builtin
- STACCFLAGS =
- DYNCCFLAGS = -fPIC
- PLTCCFLAGS =
-@@ -43,7 +43,7 @@
- # - compiler dependant libraries -
- # ----------------------------------------------------------------------------
-
--AFXCPPLIBS = -lsupc++
-+AFXCPPLIBS = -lstdc++
-
- # ----------------------------------------------------------------------------
- # - platform dependant linking flags -
diff --git a/lang/afnix/files/patch-cnf_mak_afnix-rule.mak b/lang/afnix/files/patch-cnf_mak_afnix-rule.mak
index d93beadbac85..af6613c482fa 100644
--- a/lang/afnix/files/patch-cnf_mak_afnix-rule.mak
+++ b/lang/afnix/files/patch-cnf_mak_afnix-rule.mak
@@ -1,31 +1,47 @@
---- cnf/mak/afnix-rule.mak.orig Wed Jan 12 06:05:00 2005
-+++ cnf/mak/afnix-rule.mak Wed Feb 16 19:18:04 2005
-@@ -62,8 +62,8 @@
+--- cnf/mak/afnix-rule.mak.orig Thu Aug 25 07:13:37 2005
++++ cnf/mak/afnix-rule.mak Wed Aug 31 22:43:14 2005
+@@ -22,7 +22,7 @@
+
+ ifeq ($(CCMODE),optimized)
+ CPPFLAGS = $(STDCCFLAGS) $(PLTCCFLAGS) $(CPPCCFLAGS) $(OPTCCFLAGS)
+- CXXFLAGS = $(STDCCFLAGS) $(PLTCCFLAGS) $(CXXCCFLAGS) $(OPTCCFLAGS)
++ CXXFLAGS += $(STDCCFLAGS) $(PLTCCFLAGS) $(CXXCCFLAGS) $(OPTCCFLAGS)
+ CCDEFINE = $(STDDEFINES) $(PLTDEFINES) $(OPTDEFINES)
endif
- ifeq ($(LKMODE),soname)
--SONAME = $(SOLIB).$(MAJOR).$(MINOR)
--SOVERS = $(SOLIB).$(MAJOR).$(MINOR).$(PATCH)
-+SONAME = $(SOLIB).$(MAJOR)
-+SOVERS = $(SOLIB).$(MAJOR)
+@@ -78,7 +78,7 @@
+ -include *.d
+
+ %.o : %.cpp
+- $(CC) $(PPFLAGS) $(DEFINES) $(PPINCLS) -o $@ -c $<
++ $(CC) $(CXXFLAGS) $(PPFLAGS) $(DEFINES) $(PPINCLS) -o $@ -c $<
+
+ %.o : %.cxx
+ $(CC) $(XXFLAGS) $(DEFINES) $(XXINCLS) -o $@ -c $<
+@@ -95,7 +95,7 @@
+
+ install-arlib: $(ARLIB)
+ @$(MKDIR) $(LIBDIR)
+- @$(CP) $(ARLIB) $(LIBDIR)
++ @$(BSD_INSTALL_DATA) $(ARLIB) $(LIBDIR)
+ .PHONY: install-arlib
+ else
+ install-arlib: $(ARLIB)
+@@ -117,7 +117,7 @@
+
+ install-solib : $(SOLIB)
+ @$(MKDIR) $(LIBDIR)
+- @$(CP) $(SOLIB) $(LIBDIR)
++ @$(BSD_INSTALL_PROGRAM) $(SOLIB) $(LIBDIR)
+ .PHONY: install-solib
endif
- # ----------------------------------------------------------------------------
-@@ -124,17 +124,13 @@
- $(SOLIB) : $(SOVERS)
- @$(MKDIR) $(BLDLIB)
- @$(CP) $(SOVERS) $(BLDLIB)
-- @$(RM) $(BLDLIB)/$(SOLIB)
- @$(RM) $(BLDLIB)/$(SONAME)
-- @$(LN) $(SOVERS) $(BLDLIB)/$(SONAME)
- @$(LN) $(SONAME) $(BLDLIB)/$(SOLIB)
+@@ -136,7 +136,7 @@
install-solib : $(SOVERS)
@$(MKDIR) $(LIBDIR)
- @$(CP) $(SOVERS) $(LIBDIR)
-- @$(RM) $(LIBDIR)/$(SONAME)
+- @$(CP) $(SOVERS) $(LIBDIR)
++ @$(BSD_INSTALL_PROGRAM) $(SOVERS) $(LIBDIR)
+ @$(RM) $(LIBDIR)/$(SONAME)
@$(RM) $(LIBDIR)/$(SOLIB)
-- @$(LN) $(SOVERS) $(LIBDIR)/$(SONAME)
- @$(LN) $(SONAME) $(LIBDIR)/$(SOLIB)
- .PHONY: install-solib
- endif
+ @$(LN) $(SOVERS) $(LIBDIR)/$(SONAME)
diff --git a/lang/afnix/files/patch-src_lib_plt_acf_Makefile b/lang/afnix/files/patch-src_lib_plt_acf_Makefile
new file mode 100644
index 000000000000..4ef939e84ae3
--- /dev/null
+++ b/lang/afnix/files/patch-src_lib_plt_acf_Makefile
@@ -0,0 +1,11 @@
+--- src/lib/plt/acf/Makefile.orig Wed Aug 31 22:36:40 2005
++++ src/lib/plt/acf/Makefile Wed Aug 31 22:36:40 2005
+@@ -48,7 +48,7 @@
+ # build the ccnf generator
+
+ ccnf: ccnf.cpp
+- @$(CC) $(CNFDEFINES) -o ccnf ccnf.cpp
++ @$(CC) $(CXXFLAGS) $(CNFDEFINES) -o ccnf ccnf.cpp
+
+ # rule: distri
+ # this rule install the acf directory in the distribution
diff --git a/lang/afnix/files/patch-src_plt_acf_ccnf.cpp b/lang/afnix/files/patch-src_plt_acf_ccnf.cpp
deleted file mode 100644
index 162375105ba8..000000000000
--- a/lang/afnix/files/patch-src_plt_acf_ccnf.cpp
+++ /dev/null
@@ -1,37 +0,0 @@
---- src/plt/acf/ccnf.cpp.orig Wed Jan 12 06:05:00 2005
-+++ src/plt/acf/ccnf.cpp Wed Feb 16 19:18:04 2005
-@@ -42,6 +42,7 @@
- #define AFNIX_PROCTYPE_IA64 10
- #define AFNIX_PROCTYPE_S390 11
- #define AFNIX_PROCTYPE_X64 12
-+#define AFNIX_PROCTYPE_AMD64 12
-
- // recognized processor name
- #define AFNIX_PROCNAME_UNKNOWN "unknown"
-@@ -57,6 +58,7 @@
- #define AFNIX_PROCNAME_IA64 "ia64"
- #define AFNIX_PROCNAME_S390 "s390"
- #define AFNIX_PROCNAME_X64 "x64"
-+#define AFNIX_PROCNAME_AMD64 "amd64"
-
- // force size type with S390
- #if defined(__s390__)
-@@ -117,6 +119,9 @@
- // s390
- if (strcmp (proc, AFNIX_PROCNAME_S390) == 0)
- return AFNIX_PROCTYPE_S390;
-+ // amd64
-+ if (strcmp (proc, AFNIX_PROCNAME_AMD64) == 0)
-+ return AFNIX_PROCTYPE_AMD64;
- // x86-64
- if (strcmp (proc, AFNIX_PROCNAME_X64) == 0) {
- switch (sizeof(void*)) {
-@@ -260,6 +265,8 @@
- AFNIX_PROCTYPE_IA64);
- fprintf (stdout, "#define AFNIX_PROCTYPE_S390 %d\n",
- AFNIX_PROCTYPE_S390);
-+ fprintf (stdout, "#define AFNIX_PROCTYPE_AMD64 %d\n",
-+ AFNIX_PROCTYPE_AMD64);
- fprintf (stdout, "#define AFNIX_PROCTYPE_X64 %d\n",
- AFNIX_PROCTYPE_X64);
- fprintf (stdout, "\n");
diff --git a/lang/afnix/files/patch-src_plt_lib_cclk.cxx b/lang/afnix/files/patch-src_plt_lib_cclk.cxx
deleted file mode 100644
index eeb4caa1971f..000000000000
--- a/lang/afnix/files/patch-src_plt_lib_cclk.cxx
+++ /dev/null
@@ -1,22 +0,0 @@
---- src/plt/lib/cclk.cxx.orig Wed Jan 12 06:05:00 2005
-+++ src/plt/lib/cclk.cxx Wed Feb 16 19:18:04 2005
-@@ -53,7 +53,8 @@
- s_tinfo* c_getlocal (const long tclk) {
- // extract time info
- struct tm* tval;
-- if ((tval = localtime (&tclk)) == NULL) return 0;
-+ time_t t = tclk;
-+ if (t != tclk || (tval = localtime (&t)) == NULL) return 0;
- // fill in the data structure
- s_tinfo* tinfo = new s_tinfo;
- tinfo->d_secs = tval->tm_sec;
-@@ -72,7 +73,8 @@
- s_tinfo* c_getutc (const long tclk) {
- // extract time info
- struct tm* tval;
-- if ((tval = gmtime (&tclk)) == NULL) return 0;
-+ time_t t = tclk;
-+ if (t != tclk || (tval = gmtime (&t)) == NULL) return 0;
- // fill in the data structure
- s_tinfo* tinfo = new s_tinfo;
- tinfo->d_secs = tval->tm_sec;
diff --git a/lang/afnix/files/patch-src_plt_lib_cdir.cxx b/lang/afnix/files/patch-src_plt_lib_cdir.cxx
deleted file mode 100644
index 8bcc8b3ea3fd..000000000000
--- a/lang/afnix/files/patch-src_plt_lib_cdir.cxx
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/plt/lib/cdir.cxx.orig Wed Jan 12 06:05:00 2005
-+++ src/plt/lib/cdir.cxx Wed Feb 16 19:05:03 2005
-@@ -14,6 +14,7 @@
- // - copyright (c) 1999-2005 amaury darsch -
- // ---------------------------------------------------------------------------
-
-+#include <stdio.h>
- #include "cdir.hpp"
- #include "cstr.hpp"
- #include "cdir.hxx"
diff --git a/lang/afnix/pkg-plist b/lang/afnix/pkg-plist
index d3929a594128..5e431b13b0e6 100644
--- a/lang/afnix/pkg-plist
+++ b/lang/afnix/pkg-plist
@@ -1,14 +1,13 @@
-bin/afnix
bin/axc
bin/axd
+bin/axi
bin/axl
-bin/axo
-share/doc/afnix/afnix-gud.el
-share/doc/afnix/afnix-mode.el
-share/doc/afnix/license.txt
-share/doc/afnix/what-long.txt
-share/doc/afnix/what-short.txt
-@dirrm share/doc/afnix
+bin/axs
+etc/afnix/afnix-gud.el
+etc/afnix/afnix-mode.el
+etc/afnix/license.txt
+etc/afnix/what-long.txt
+etc/afnix/what-short.txt
include/afnix/eng/Argument.hpp
include/afnix/eng/Builtin.hpp
include/afnix/eng/Class.hpp
@@ -23,9 +22,9 @@ include/afnix/eng/Function.hpp
include/afnix/eng/Globalset.hpp
include/afnix/eng/Instance.hpp
include/afnix/eng/Interp.hpp
-include/afnix/eng/Item.hpp
include/afnix/eng/Lexer.hpp
include/afnix/eng/Lexical.hpp
+include/afnix/eng/Librarian.hpp
include/afnix/eng/Localset.hpp
include/afnix/eng/Meta.hpp
include/afnix/eng/Module.hpp
@@ -38,15 +37,16 @@ include/afnix/eng/Reader.hpp
include/afnix/eng/Reserved.hpp
include/afnix/eng/Resolver.hpp
include/afnix/eng/Return.hpp
+include/afnix/eng/Superset.hpp
include/afnix/eng/Symbol.hpp
include/afnix/eng/Token.hpp
include/afnix/net/Address.hpp
include/afnix/net/Datagram.hpp
-include/afnix/net/Libanet.hpp
+include/afnix/net/Libnet.hpp
include/afnix/net/Mail.hpp
include/afnix/net/Multicast.hpp
-include/afnix/net/Netcalls.hpp
-include/afnix/net/Predanet.hpp
+include/afnix/net/NetCalls.hpp
+include/afnix/net/Prednet.hpp
include/afnix/net/Socket.hpp
include/afnix/net/TcpClient.hpp
include/afnix/net/TcpServer.hpp
@@ -54,21 +54,12 @@ include/afnix/net/TcpSocket.hpp
include/afnix/net/UdpClient.hpp
include/afnix/net/UdpServer.hpp
include/afnix/net/UdpSocket.hpp
-include/afnix/odc/Cell.hpp
-include/afnix/odc/Collection.hpp
-include/afnix/odc/Importer.hpp
-include/afnix/odc/Libaodc.hpp
-include/afnix/odc/Odccalls.hpp
-include/afnix/odc/Odcsid.hpp
-include/afnix/odc/Persist.hpp
-include/afnix/odc/Predaodc.hpp
-include/afnix/odc/Record.hpp
-include/afnix/odc/Table.hpp
include/afnix/plt/cclk.hpp
include/afnix/plt/ccnf.hpp
include/afnix/plt/ccnv.hpp
include/afnix/plt/cdir.hpp
include/afnix/plt/cerr.hpp
+include/afnix/plt/cgen.hpp
include/afnix/plt/cmem.hpp
include/afnix/plt/cmth.hpp
include/afnix/plt/cnet.hpp
@@ -78,14 +69,33 @@ include/afnix/plt/cstr.hpp
include/afnix/plt/csys.hpp
include/afnix/plt/cthr.hpp
include/afnix/plt/ctrm.hpp
-include/afnix/sci/Digest.hpp
+include/afnix/sci/Aes.hpp
+include/afnix/sci/Cipher.hpp
+include/afnix/sci/Crypto.hpp
+include/afnix/sci/Hasher.hpp
+include/afnix/sci/InputCipher.hpp
+include/afnix/sci/Key.hpp
include/afnix/sci/Md5.hpp
+include/afnix/sci/Privsci.hpp
include/afnix/sci/Sha1.hpp
+include/afnix/sci/Sha256.hpp
+include/afnix/sci/Sha384.hpp
+include/afnix/sci/Sha512.hpp
include/afnix/sio/Directory.hpp
-include/afnix/sio/Libasio.hpp
-include/afnix/sio/Pathasio.hpp
-include/afnix/sio/Predasio.hpp
+include/afnix/sio/Libsio.hpp
+include/afnix/sio/Pathsio.hpp
+include/afnix/sio/Predsio.hpp
include/afnix/sio/Selector.hpp
+include/afnix/sps/Cell.hpp
+include/afnix/sps/Folio.hpp
+include/afnix/sps/Importer.hpp
+include/afnix/sps/Libsps.hpp
+include/afnix/sps/Persist.hpp
+include/afnix/sps/Predsps.hpp
+include/afnix/sps/Record.hpp
+include/afnix/sps/Sheet.hpp
+include/afnix/sps/SpsCalls.hpp
+include/afnix/sps/Spssid.hpp
include/afnix/std/BitSet.hpp
include/afnix/std/Boolean.hpp
include/afnix/std/Buffer.hpp
@@ -101,15 +111,17 @@ include/afnix/std/HashTable.hpp
include/afnix/std/Input.hpp
include/afnix/std/InputFile.hpp
include/afnix/std/InputMapped.hpp
+include/afnix/std/InputOutput.hpp
include/afnix/std/InputString.hpp
include/afnix/std/InputTerm.hpp
include/afnix/std/Integer.hpp
+include/afnix/std/Item.hpp
include/afnix/std/Iterable.hpp
include/afnix/std/Iterator.hpp
-include/afnix/std/Librarian.hpp
include/afnix/std/Library.hpp
include/afnix/std/List.hpp
include/afnix/std/Literal.hpp
+include/afnix/std/Loader.hpp
include/afnix/std/Lockrw.hpp
include/afnix/std/Method.hpp
include/afnix/std/Monitor.hpp
@@ -131,6 +143,7 @@ include/afnix/std/Regex.hpp
include/afnix/std/Relatif.hpp
include/afnix/std/Runnable.hpp
include/afnix/std/Serial.hpp
+include/afnix/std/Set.hpp
include/afnix/std/Sorter.hpp
include/afnix/std/Stack.hpp
include/afnix/std/String.hpp
@@ -141,18 +154,16 @@ include/afnix/std/Thread.hpp
include/afnix/std/Thrmap.hpp
include/afnix/std/Time.hpp
include/afnix/std/Vector.hpp
-include/afnix/sys/Libasys.hpp
-include/afnix/sys/Predasys.hpp
-include/afnix/sys/Syscalls.hpp
-include/afnix/txt/Hasher.hpp
+include/afnix/sys/Libsys.hpp
+include/afnix/sys/Predsys.hpp
+include/afnix/sys/SysCalls.hpp
include/afnix/txt/Lexeme.hpp
-include/afnix/txt/Libatxt.hpp
+include/afnix/txt/Libtxt.hpp
include/afnix/txt/Literate.hpp
include/afnix/txt/Pattern.hpp
-include/afnix/txt/Predatxt.hpp
+include/afnix/txt/Predtxt.hpp
include/afnix/txt/Scanner.hpp
include/afnix/txt/Sort.hpp
-include/afnix/txt/Txtcalls.hpp
include/afnix/www/CgiQuery.hpp
include/afnix/www/Cookie.hpp
include/afnix/www/HtmlDiv.hpp
@@ -161,48 +172,39 @@ include/afnix/www/HtmlPage.hpp
include/afnix/www/HtmlRef.hpp
include/afnix/www/HtmlTable.hpp
include/afnix/www/HtmlTag.hpp
-include/afnix/www/Libawww.hpp
-include/afnix/www/Predawww.hpp
+include/afnix/www/Libwww.hpp
+include/afnix/www/Predwww.hpp
include/afnix/www/Url.hpp
include/afnix/www/XHtmlPage.hpp
-@dirrm include/afnix/eng
-@dirrm include/afnix/net
-@dirrm include/afnix/odc
-@dirrm include/afnix/plt
-@dirrm include/afnix/sci
-@dirrm include/afnix/sio
-@dirrm include/afnix/std
-@dirrm include/afnix/sys
-@dirrm include/afnix/txt
-@dirrm include/afnix/www
-@dirrm include/afnix
lib/libafnix-eng.a
lib/libafnix-eng.so
-lib/libafnix-eng.so.%%PORTVER%%
lib/libafnix-net.a
lib/libafnix-net.so
-lib/libafnix-net.so.%%PORTVER%%
-lib/libafnix-odc.a
-lib/libafnix-odc.so
-lib/libafnix-odc.so.%%PORTVER%%
lib/libafnix-plt.a
lib/libafnix-plt.so
-lib/libafnix-plt.so.%%PORTVER%%
lib/libafnix-sci.a
lib/libafnix-sci.so
-lib/libafnix-sci.so.%%PORTVER%%
lib/libafnix-sio.a
lib/libafnix-sio.so
-lib/libafnix-sio.so.%%PORTVER%%
+lib/libafnix-sps.a
+lib/libafnix-sps.so
lib/libafnix-std.a
lib/libafnix-std.so
-lib/libafnix-std.so.%%PORTVER%%
lib/libafnix-sys.a
lib/libafnix-sys.so
-lib/libafnix-sys.so.%%PORTVER%%
lib/libafnix-txt.a
lib/libafnix-txt.so
-lib/libafnix-txt.so.%%PORTVER%%
lib/libafnix-www.a
lib/libafnix-www.so
-lib/libafnix-www.so.%%PORTVER%%
+@dirrm etc/afnix
+@dirrm include/afnix/eng
+@dirrm include/afnix/net
+@dirrm include/afnix/plt
+@dirrm include/afnix/sci
+@dirrm include/afnix/sio
+@dirrm include/afnix/sps
+@dirrm include/afnix/std
+@dirrm include/afnix/sys
+@dirrm include/afnix/txt
+@dirrm include/afnix/www
+@dirrm include/afnix