aboutsummaryrefslogtreecommitdiff
path: root/lang/afnix
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2015-01-09 19:41:06 +0000
committerJohan van Selst <johans@FreeBSD.org>2015-01-09 19:41:06 +0000
commitfe148103c3e04483301faef68b01d5800d8fa789 (patch)
treec01ac9c1aae29bcf587048b7e883f64fe3f7c1ef /lang/afnix
parentad758556d75f58bd68648e107c280232e31d92ad (diff)
downloadports-fe148103c3e04483301faef68b01d5800d8fa789.tar.gz
ports-fe148103c3e04483301faef68b01d5800d8fa789.zip
Notes
Diffstat (limited to 'lang/afnix')
-rw-r--r--lang/afnix/Makefile7
-rw-r--r--lang/afnix/distinfo4
-rw-r--r--lang/afnix/pkg-plist57
3 files changed, 30 insertions, 38 deletions
diff --git a/lang/afnix/Makefile b/lang/afnix/Makefile
index 344241ba138b..44dbb4fa2150 100644
--- a/lang/afnix/Makefile
+++ b/lang/afnix/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= afnix
-PORTVERSION= 2.4.0
+PORTVERSION= 2.5.1
CATEGORIES= lang
MASTER_SITES= http://www.afnix.org/ftp/ \
ftp://ftp.stack.nl/pub/users/johans/afnix/
@@ -16,7 +16,7 @@ USE_LDCONFIG= yes
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= cnf/bin/afnix-setup
CONFIGURE_ARGS= -o --prefix "${PREFIX}" --altdir "${PREFIX}" \
- --shrdir "${PREFIX}/share" --compiler freebsd
+ --shrdir "${PREFIX}/share" --compiler clang++
MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
@@ -31,9 +31,6 @@ OPTIONS_DEFINE= DOCS
BROKEN= Does not configure on powerpc
.endif
-post-extract:
- @cd ${WRKSRC}/cnf/mak && ${CP} -f afnix-gcc-4.mak afnix-freebsd.mak
-
post-patch:
@${REINPLACE_CMD} -e 's|$$(CP)|$$(BSD_INSTALL_PROGRAM)|' \
${WRKSRC}/src/*/*/exe/Makefile
diff --git a/lang/afnix/distinfo b/lang/afnix/distinfo
index 0f6085a16bea..df8295d16ade 100644
--- a/lang/afnix/distinfo
+++ b/lang/afnix/distinfo
@@ -1,2 +1,2 @@
-SHA256 (afnix-src-2.4.0.tgz) = 59885a5c1b4a211ff38313c22c45c7953711e1267beaa20c244287ad9de28b3c
-SIZE (afnix-src-2.4.0.tgz) = 2112317
+SHA256 (afnix-src-2.5.1.tgz) = 1bd005018497997da336e1257025e77410cbe8dfb90a17267315708fc685255f
+SIZE (afnix-src-2.5.1.tgz) = 2161249
diff --git a/lang/afnix/pkg-plist b/lang/afnix/pkg-plist
index 79c744de5b61..8007b2209678 100644
--- a/lang/afnix/pkg-plist
+++ b/lang/afnix/pkg-plist
@@ -6,6 +6,7 @@ include/afnix/csm/Appointer.hpp
include/afnix/csm/Assistant.hpp
include/afnix/csm/Cart.hpp
include/afnix/csm/CartSet.hpp
+include/afnix/csm/CsmCalls.hpp
include/afnix/csm/Ico.hpp
include/afnix/csm/Libcsm.hpp
include/afnix/csm/LocalSpace.hpp
@@ -80,6 +81,7 @@ include/afnix/itu/Libitu.hpp
include/afnix/itu/Oid.hpp
include/afnix/itu/Preditu.hpp
include/afnix/mth/Algebra.hpp
+include/afnix/mth/Analytic.hpp
include/afnix/mth/Bcs.hpp
include/afnix/mth/Cgs.hpp
include/afnix/mth/Direct.hpp
@@ -88,6 +90,7 @@ include/afnix/mth/Iterative.hpp
include/afnix/mth/Libmth.hpp
include/afnix/mth/Linear.hpp
include/afnix/mth/LinearFactory.hpp
+include/afnix/mth/Mgs.hpp
include/afnix/mth/Mpia.hpp
include/afnix/mth/Newton.hpp
include/afnix/mth/Parallel.hpp
@@ -209,7 +212,7 @@ include/afnix/sps/Folio.hpp
include/afnix/sps/Importer.hpp
include/afnix/sps/Index.hpp
include/afnix/sps/Libsps.hpp
-include/afnix/sps/Persist.hpp
+include/afnix/sps/Lstack.hpp
include/afnix/sps/Predsps.hpp
include/afnix/sps/Record.hpp
include/afnix/sps/Sheet.hpp
@@ -284,6 +287,7 @@ include/afnix/std/Real.hpp
include/afnix/std/Regex.hpp
include/afnix/std/Relatif.hpp
include/afnix/std/Runnable.hpp
+include/afnix/std/Saveas.hpp
include/afnix/std/Serial.hpp
include/afnix/std/Set.hpp
include/afnix/std/Sorter.hpp
@@ -293,6 +297,7 @@ include/afnix/std/Stream.hpp
include/afnix/std/Strfifo.hpp
include/afnix/std/String.hpp
include/afnix/std/Strvec.hpp
+include/afnix/std/Style.hpp
include/afnix/std/System.hpp
include/afnix/std/Terminal.hpp
include/afnix/std/Thread.hpp
@@ -324,16 +329,30 @@ include/afnix/svg/SvgRoot.hpp
include/afnix/svg/SvgStyling.hpp
include/afnix/svg/Transform.hpp
include/afnix/sys/Libsys.hpp
+include/afnix/sys/Meter.hpp
include/afnix/sys/Predsys.hpp
include/afnix/sys/SysCalls.hpp
include/afnix/tls/Libtls.hpp
include/afnix/tls/Predtls.hpp
-include/afnix/tls/TlsHandshake.hpp
+include/afnix/tls/TlsAlert.hpp
+include/afnix/tls/TlsBlock.hpp
+include/afnix/tls/TlsChello.hpp
+include/afnix/tls/TlsChunk.hpp
+include/afnix/tls/TlsConnect.hpp
+include/afnix/tls/TlsHblock.hpp
include/afnix/tls/TlsHeader.hpp
+include/afnix/tls/TlsInfos.hpp
include/afnix/tls/TlsMessage.hpp
+include/afnix/tls/TlsParams.hpp
+include/afnix/tls/TlsProto.hpp
include/afnix/tls/TlsRecord.hpp
include/afnix/tls/TlsServer.hpp
+include/afnix/tls/TlsShake.hpp
+include/afnix/tls/TlsShello.hpp
include/afnix/tls/TlsSocket.hpp
+include/afnix/tls/TlsState.hpp
+include/afnix/tls/TlsSuite.hpp
+include/afnix/tls/TlsUtils.hpp
include/afnix/tls/X509.hpp
include/afnix/tls/Xalgo.hpp
include/afnix/tls/Xextn.hpp
@@ -349,11 +368,13 @@ include/afnix/txt/Scanner.hpp
include/afnix/txt/TxtCalls.hpp
include/afnix/txt/TxtUtils.hpp
include/afnix/txt/Worder.hpp
+include/afnix/wax/JsonMime.hpp
include/afnix/wax/Libwax.hpp
include/afnix/wax/Predwax.hpp
include/afnix/wax/XhtmlBase.hpp
include/afnix/wax/XhtmlBody.hpp
include/afnix/wax/XhtmlBr.hpp
+include/afnix/wax/XhtmlCanvas.hpp
include/afnix/wax/XhtmlCaption.hpp
include/afnix/wax/XhtmlCgr.hpp
include/afnix/wax/XhtmlCol.hpp
@@ -441,9 +462,9 @@ include/afnix/xpe/XmlInclude.hpp
include/afnix/xpe/XmlPlist.hpp
include/afnix/xpe/XmlPrintTable.hpp
include/afnix/xpe/XmlProcessor.hpp
-lib/afnix/afnix-std-adp.axl
-lib/afnix/afnix-std-axp.axl
-lib/afnix/afnix-std-tls.axl
+lib/afnix/axl/afnix-std-adp.axl
+lib/afnix/axl/afnix-std-axp.axl
+lib/afnix/axl/afnix-std-tls.axl
lib/libafnix-csm.a
lib/libafnix-csm.so
lib/libafnix-csm.so.2
@@ -528,29 +549,3 @@ man/man7/afnix::guide.7.gz
man/man7/afnix::license.7.gz
man/man7/afnix::notes.7.gz
man/man7/afnix::reference.7.gz
-%%PORTDOCS%%%%DOCSDIR%%/adp.xht
-%%PORTDOCS%%%%DOCSDIR%%/afnix.png
-%%PORTDOCS%%%%DOCSDIR%%/axc.xht
-%%PORTDOCS%%%%DOCSDIR%%/axd.xht
-%%PORTDOCS%%%%DOCSDIR%%/axi.xht
-%%PORTDOCS%%%%DOCSDIR%%/axl.xht
-%%PORTDOCS%%%%DOCSDIR%%/axp.xht
-%%PORTDOCS%%%%DOCSDIR%%/csm.xht
-%%PORTDOCS%%%%DOCSDIR%%/eul.xht
-%%PORTDOCS%%%%DOCSDIR%%/gfx.xht
-%%PORTDOCS%%%%DOCSDIR%%/itu.xht
-%%PORTDOCS%%%%DOCSDIR%%/mth.xht
-%%PORTDOCS%%%%DOCSDIR%%/net.xht
-%%PORTDOCS%%%%DOCSDIR%%/nwg.xht
-%%PORTDOCS%%%%DOCSDIR%%/sec.xht
-%%PORTDOCS%%%%DOCSDIR%%/sio.xht
-%%PORTDOCS%%%%DOCSDIR%%/sps.xht
-%%PORTDOCS%%%%DOCSDIR%%/style.css
-%%PORTDOCS%%%%DOCSDIR%%/sys.xht
-%%PORTDOCS%%%%DOCSDIR%%/txt.xht
-%%PORTDOCS%%%%DOCSDIR%%/vol-0.xht
-%%PORTDOCS%%%%DOCSDIR%%/vol-1.xht
-%%PORTDOCS%%%%DOCSDIR%%/vol-2.xht
-%%PORTDOCS%%%%DOCSDIR%%/wax.xht
-%%PORTDOCS%%%%DOCSDIR%%/xml.xht
-%%PORTDOCS%%%%DOCSDIR%%/xpe.xht