aboutsummaryrefslogtreecommitdiff
path: root/lang/alisp/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-09-28 10:57:21 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-09-28 10:57:21 +0000
commit90117cbf4245960f0eba5064515e9d22afa4a676 (patch)
treef05395a9818206bde6b3293ac08fa9c383a56e29 /lang/alisp/Makefile
parent2e8978edb184d6082ea0a03beffdda04218d6399 (diff)
Notes
Diffstat (limited to 'lang/alisp/Makefile')
-rw-r--r--lang/alisp/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/lang/alisp/Makefile b/lang/alisp/Makefile
new file mode 100644
index 000000000000..828c402ef1e8
--- /dev/null
+++ b/lang/alisp/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: ArrowLISP
+# Date created: 12 Aug 2003
+# Whom: Nils M Holm <nmh@t3x.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= alisp
+PORTVERSION= 8
+CATEGORIES= lang devel
+MASTER_SITES= http://t3x.dyndns.org/files/ \
+ http://www.t3x.org/files/
+DISTNAME= alisp${PORTVERSION}
+
+MAINTAINER= nmh@t3x.org
+COMMENT= A tail-recursive interpreter for purely symbolic LISP
+
+BUILD_DEPENDS= tx:${PORTSDIR}/lang/t3x \
+ ${LOCALBASE}/t3x/r8/tide:${PORTSDIR}/devel/tide
+
+MAN7= alisp.7
+MANCOMPRESSED= no
+
+MAKE_ENV+= T3XDIR=${LOCALBASE}/t3x/r8
+
+USE_REINPLACE= yes
+
+post-patch:
+ ${REINPLACE_CMD} \
+ -e 's,/usr/local,${PREFIX},g' \
+ ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} \
+ -e 's,/usr/local,${PREFIX},g' \
+ ${WRKSRC}/cnf/dfl_unix.rc
+
+.include <bsd.port.mk>