aboutsummaryrefslogtreecommitdiff
path: root/lang/asis
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-06-10 00:34:33 +0000
committerJohn Marino <marino@FreeBSD.org>2016-06-10 00:34:33 +0000
commite94e672950eb59711a157281376c5768d23d4351 (patch)
treeff6c24cffc2a1a6a67466f499ad1da6c384395f6 /lang/asis
parentc4b2280a235459b036946fc031a644f9d4778894 (diff)
downloadports-e94e672950eb59711a157281376c5768d23d4351.tar.gz
ports-e94e672950eb59711a157281376c5768d23d4351.zip
Notes
Diffstat (limited to 'lang/asis')
-rw-r--r--lang/asis/Makefile28
-rw-r--r--lang/asis/distinfo5
-rw-r--r--lang/asis/files/patch-asis_a4g-gnat__int.adb22
-rw-r--r--lang/asis/files/patch-asis_a4g-mapping.adb10
-rw-r--r--lang/asis/pkg-plist3
5 files changed, 32 insertions, 36 deletions
diff --git a/lang/asis/Makefile b/lang/asis/Makefile
index fdf26b255beb..54220ad0b23d 100644
--- a/lang/asis/Makefile
+++ b/lang/asis/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= asis
-PORTVERSION= 2015
-PORTREVISION= 2
+PORTVERSION= 2016
CATEGORIES= lang
MASTER_SITES= http://downloads.dragonlace.net/src/
DISTNAME= ${PORTNAME}-gpl-${PORTVERSION}-src
@@ -22,7 +21,11 @@ USES= ada gmake
NO_MTREE= yes
MAKE_ENV= PROCESSORS=${MAKE_JOBS_NUMBER}
GUSTATIC= ${LOCALBASE}/lib/gnat_util/libgnat_util.a
-PORTDOCS= html pdf *.txt
+PORTDOCS= *
+
+OPTIONS_DEFINE= DOCS
+
+DOCS_BUILD_DEPENDS= sphinx-build:textproc/py-sphinx
post-extract:
@${REINPLACE_CMD} -e 's|OPSYS|ASISOPSYS|g' \
@@ -37,29 +40,24 @@ do-build:
# MAKE_JOBS_UNSAFE=yes would break PROCESSORS value
(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} all)
+do-build-DOCS-on:
+ (cd ${WRKSRC}/doc && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} html-all)
+
do-install:
# gprinstall seems to be malfunctioning, just install manually
${MKDIR} ${STAGEDIR}${PREFIX}/bin \
${STAGEDIR}${PREFIX}/include/asis \
${STAGEDIR}${PREFIX}/lib/asis \
- ${STAGEDIR}${PREFIX}/lib/gnat \
- ${STAGEDIR}${PREFIX}/share/gps/plug-ins \
- ${STAGEDIR}${DOCSDIR}/html \
- ${STAGEDIR}${DOCSDIR}/pdf
+ ${STAGEDIR}${PREFIX}/lib/gnat
${INSTALL_PROGRAM} ${WRKSRC}/tools/asistant/asistant \
${STAGEDIR}${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/asis/*.ad[bs] \
${STAGEDIR}${PREFIX}/include/asis
${INSTALL_DATA} ${WRKSRC}/lib/*.ali ${STAGEDIR}${PREFIX}/lib/asis
${INSTALL_DATA} ${WRKSRC}/lib/*.a ${STAGEDIR}${PREFIX}/lib/asis
- ${INSTALL_DATA} ${WRKSRC}/documentation/*.html \
- ${STAGEDIR}${DOCSDIR}/html
- ${INSTALL_DATA} ${WRKSRC}/documentation/*.pdf \
- ${STAGEDIR}${DOCSDIR}/pdf
- ${INSTALL_DATA} ${WRKSRC}/documentation/*.txt \
- ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/documentation/asis.xml \
- ${STAGEDIR}${PREFIX}/share/gps/plug-ins
${INSTALL_DATA} ${FILESDIR}/asis.gpr ${STAGEDIR}${PREFIX}/lib/gnat
+do-install-DOCS-on:
+ (cd ${WRKSRC}/doc/html && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
+
.include <bsd.port.mk>
diff --git a/lang/asis/distinfo b/lang/asis/distinfo
index f1973304c197..9c16b09ddd94 100644
--- a/lang/asis/distinfo
+++ b/lang/asis/distinfo
@@ -1,2 +1,3 @@
-SHA256 (asis-gpl-2015-src.tar.gz) = 5c011786ed4173d14bda2194c5f0255dfcde4c102ee7b428567014f6c5c87bbb
-SIZE (asis-gpl-2015-src.tar.gz) = 4792357
+TIMESTAMP = 1465515802
+SHA256 (asis-gpl-2016-src.tar.gz) = 3e36e0835e291dafe6dd2246748ed12b449d33044c32209d3af012c83064c38e
+SIZE (asis-gpl-2016-src.tar.gz) = 5240554
diff --git a/lang/asis/files/patch-asis_a4g-gnat__int.adb b/lang/asis/files/patch-asis_a4g-gnat__int.adb
index 84ad94c17e8b..3e1322e44d67 100644
--- a/lang/asis/files/patch-asis_a4g-gnat__int.adb
+++ b/lang/asis/files/patch-asis_a4g-gnat__int.adb
@@ -1,6 +1,6 @@
---- asis/a4g-gnat_int.adb.orig 2015-05-06 10:56:06 UTC
+--- asis/a4g-gnat_int.adb.orig 2016-05-16 09:17:27 UTC
+++ asis/a4g-gnat_int.adb
-@@ -231,40 +231,10 @@ package body A4G.GNAT_Int is
+@@ -231,46 +231,10 @@ package body A4G.GNAT_Int is
Opt.Tree_Read;
if Strong_Version_Check then
@@ -16,19 +16,25 @@
- Last_A_Idx := Index (Source => ASIS_GNAT_V,
- Pattern => ")") - 1;
-
-- if Index (Source => ASIS_GNAT_V, Pattern => "-") /= 0 then
-- Last_A_Idx := Index (Source => ASIS_GNAT_V,
-- Pattern => "-") - 1;
+- if Index
+- (Source => ASIS_GNAT_V (First_A_Idx .. Last_A_Idx),
+- Pattern => "-") /= 0
+- then
+- Last_A_Idx :=
+- Index (Source => ASIS_GNAT_V (First_A_Idx .. Last_A_Idx),
+- Pattern => "-") - 1;
- end if;
-
- Last_T_Idx := Index (Source => Tree_Version_String.all,
- Pattern => ")") - 1;
-
-- if Index (Source => Tree_Version_String.all, Pattern => "-") /=
-- 0
+- if Index
+- (Source => Tree_Version_String.all (First_T_Idx .. Last_T_Idx),
+- Pattern => "-") /= 0
- then
- Last_T_Idx :=
-- Index (Source => Tree_Version_String.all,
+- Index (Source =>
+- Tree_Version_String.all (First_T_Idx .. Last_T_Idx),
- Pattern => "-") - 1;
- end if;
-
diff --git a/lang/asis/files/patch-asis_a4g-mapping.adb b/lang/asis/files/patch-asis_a4g-mapping.adb
deleted file mode 100644
index 6167d1a066b1..000000000000
--- a/lang/asis/files/patch-asis_a4g-mapping.adb
+++ /dev/null
@@ -1,10 +0,0 @@
---- asis/a4g-mapping.adb.orig 2015-05-06 10:56:05 UTC
-+++ asis/a4g-mapping.adb
-@@ -1933,7 +1933,6 @@ package body A4G.Mapping is
- Attribute_Chars = Name_Target_Name or else
- Attribute_Chars = Name_To_Address or else
- Attribute_Chars = Name_Type_Class or else
-- Attribute_Chars = Name_UET_Address or else
- Attribute_Chars = Name_Universal_Literal_String or else
- Attribute_Chars = Name_Unrestricted_Access or else
- Attribute_Chars = Name_Update or else
diff --git a/lang/asis/pkg-plist b/lang/asis/pkg-plist
index d02b7d1458bd..447c44b1df4a 100644
--- a/lang/asis/pkg-plist
+++ b/lang/asis/pkg-plist
@@ -47,6 +47,7 @@ include/asis/a4g-get_unit.adb
include/asis/a4g-get_unit.ads
include/asis/a4g-gnat_int.adb
include/asis/a4g-gnat_int.ads
+include/asis/a4g-gnsa_switch.ads
include/asis/a4g-int_knds.ads
include/asis/a4g-itests.adb
include/asis/a4g-itests.ads
@@ -159,6 +160,7 @@ lib/asis/a4g-encl_el.ali
lib/asis/a4g-expr_sem.ali
lib/asis/a4g-get_unit.ali
lib/asis/a4g-gnat_int.ali
+lib/asis/a4g-gnsa_switch.ali
lib/asis/a4g-int_knds.ali
lib/asis/a4g-itests.ali
lib/asis/a4g-knd_conv.ali
@@ -208,4 +210,3 @@ lib/asis/asis-text.ali
lib/asis/asis.ali
lib/asis/libasis.a
lib/gnat/asis.gpr
-share/gps/plug-ins/asis.xml