aboutsummaryrefslogtreecommitdiff
path: root/lang/atlast/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2005-12-21 19:49:43 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2005-12-21 19:49:43 +0000
commit2196ce4482a339d93003bf9888d296d47e5f31b3 (patch)
treee08452490e78e917609cbeea345c71ae4edff7b2 /lang/atlast/Makefile
parent2953a3d9bf39b2c89596ed9e2fee708c9e4f5bd8 (diff)
downloadports-2196ce4482a339d93003bf9888d296d47e5f31b3.tar.gz
ports-2196ce4482a339d93003bf9888d296d47e5f31b3.zip
Notes
Diffstat (limited to 'lang/atlast/Makefile')
-rw-r--r--lang/atlast/Makefile29
1 files changed, 19 insertions, 10 deletions
diff --git a/lang/atlast/Makefile b/lang/atlast/Makefile
index 76e61763b4c7..be8ea9b6b638 100644
--- a/lang/atlast/Makefile
+++ b/lang/atlast/Makefile
@@ -1,31 +1,40 @@
# New ports collection makefile for: atlast
-# Date created: 26 Ag 97
-# Whom: Pedro Giffuni
+# Date created: 26 Aug 97
+# Whom: Pedro Giffuni
#
# $FreeBSD$
#
PORTNAME= atlast
-PORTVERSION= 1.0
-PORTREVISION= 1
+PORTVERSION= 1.1
CATEGORIES= lang
MASTER_SITES= http://www.fourmilab.ch/atlast/ \
http://www.fourmilab.to/atlast/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= laszlof@vonostingroup.com
COMMENT= Autodesk Threaded Language Application System Toolkit
-MAKE_ARGS= CFLAGS="${CFLAGS} -DMEMSTAT -DALIGNMENT -DEXPORT -DNOMEMCHECK"
+SRC= atlast.c atlmain.c
+DEFINES= -DMEMSTAT -DALIGNMENT -DEXPORT
+LDFLAGS+= -lm
PLIST_FILES= bin/atlast
PORTDOCS= atlast.ps atlast.rtf
+do-build:
+.for f in ${SRC}
+ ${CC} ${CFLAGS} ${DEFINES} -c ${WRKSRC}/${f} -o ${WRKSRC}/${f:C/\.c$/.o/}
+.endfor
+ ${CC} ${LDFLAGS} ${SRC:C/(.*)\.c$/${WRKSRC}\/\1.o/} \
+ -o ${WRKSRC}/${PORTNAME}
+
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/atlast ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/atlast.ps ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/atlast.rtf ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
.endif
.include <bsd.port.mk>