aboutsummaryrefslogtreecommitdiff
path: root/lang/bas2tap/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-07-11 19:18:08 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-07-11 19:18:08 +0000
commit507163705c82f9aec29e81879653e7cc8f3aafdb (patch)
tree987d5ef92a45b7b374d3dbf4a2baa337d7bbf34c /lang/bas2tap/Makefile
parentfb607972800985f363c83835a3f9961e1a92b6f2 (diff)
downloadports-507163705c82f9aec29e81879653e7cc8f3aafdb.tar.gz
ports-507163705c82f9aec29e81879653e7cc8f3aafdb.zip
Notes
Diffstat (limited to 'lang/bas2tap/Makefile')
-rw-r--r--lang/bas2tap/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/lang/bas2tap/Makefile b/lang/bas2tap/Makefile
new file mode 100644
index 000000000000..1aa59eae5ae1
--- /dev/null
+++ b/lang/bas2tap/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: bas2tap
+# Date created: 2007-06-26
+# Whom: Rene Ladan <r.c.ladan@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bas2tap
+PORTVERSION= 2.4
+CATEGORIES= lang
+MASTER_SITES= ftp://ftp.worldofspectrum.org/pub/sinclair/tools/generic/
+DISTNAME= ${PORTNAME}${PORTVERSION:C/\.//}-generic
+
+MAINTAINER= r.c.ladan@gmail.com
+COMMENT= Convert 48k/128k ZX Spectrum BASIC text files to TAP files
+
+USE_ZIP= yes
+
+NO_WRKSUBDIR= yes
+PORTDOCS= ${PORTNAME}.doc
+PLIST_FILES= bin/${PORTNAME}
+
+do-build:
+ ${CC} ${WRKSRC}/${PORTNAME}.c -o ${WRKSRC}/${PORTNAME} -lm ${CFLAGS}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+.ifndef NOPORTDOCS
+ @${MKDIR} ${DOCSDIR}
+.for file in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>