aboutsummaryrefslogtreecommitdiff
path: root/lang/basic256/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-02-22 12:11:25 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-02-22 12:11:25 +0000
commita3a35753b2980e697dc7d90e7039c8cb9bed43ab (patch)
tree31f11520ead6d28fb65f1227959e9aa10f09c37c /lang/basic256/Makefile
parente0519be3919d29bb29a230f3c00edf1cf2106eaa (diff)
Notes
Diffstat (limited to 'lang/basic256/Makefile')
-rw-r--r--lang/basic256/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/lang/basic256/Makefile b/lang/basic256/Makefile
index 3fe71b29c673..d32ecbb3f2e9 100644
--- a/lang/basic256/Makefile
+++ b/lang/basic256/Makefile
@@ -2,12 +2,11 @@
# $FreeBSD$
PORTNAME= basic256
-PORTVERSION= 1.0.0.0
+PORTVERSION= 1.1.0.0
CATEGORIES= lang
MASTER_SITES= SF
MASTER_SITE_SUBDIR= kidbasic/${PORTNAME}
-DISTNAME= ${PORTNAME}_${PORTVERSION}
-EXTRACT_SUFX= .tgz
+DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
MAINTAINER= fernando.apesteguia@gmail.com
COMMENT= Easy to use BASIC language and IDE for education
@@ -16,16 +15,16 @@ BUILD_DEPENDS= espeak:${PORTSDIR}/audio/espeak \
sqlite3:${PORTSDIR}/databases/sqlite3 \
flex:${PORTSDIR}/textproc/flex
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
USES= bison dos2unix qmake
USE_SDL= sdl mixer
USE_QT4= corelib gui network xml webkit moc_build rcc_build uic_build
QMAKE_SOURCE_PATH= BASIC256.pro
-NO_WRKSUBDIR= yes
MAKE_JOBS_UNSAFE= yes
post-patch:
- @${REINPLACE_CMD} -e 's/mutex/mymutex/' ${WRKSRC}/*.cpp
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/BASIC256.pro
.include <bsd.port.mk>