aboutsummaryrefslogtreecommitdiff
path: root/lang/bigloo/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-01-10 23:19:40 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-01-10 23:19:40 +0000
commit6658c05243f4950e6cf4af3c53c221667c2e9ce5 (patch)
tree1a6e9fc142481f24660dd1396e01b619f24dc011 /lang/bigloo/Makefile
parent2800d27348338cfd3d789caa9c0df3f1853ec6ed (diff)
Notes
Diffstat (limited to 'lang/bigloo/Makefile')
-rw-r--r--lang/bigloo/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/lang/bigloo/Makefile b/lang/bigloo/Makefile
index 8ff6bf7a656b..33e2a3a26293 100644
--- a/lang/bigloo/Makefile
+++ b/lang/bigloo/Makefile
@@ -6,15 +6,17 @@
#
PORTNAME= bigloo
-PORTVERSION= 3.0c
+PORTVERSION= 3.0c.4
CATEGORIES= lang scheme
MASTER_SITES= ftp://ftp-sop.inria.fr/mimosa/fp/Bigloo/ \
ftp://kaolin.unice.fr/pub/Bigloo/
-DISTNAME= ${PORTNAME}${PORTVERSION}
+DISTNAME= ${PORTNAME}${PORTVERSION:R}-${PORTVERSION:E}
MAINTAINER= ports@FreeBSD.org
COMMENT= A Scheme interpreter and native code compiler
+WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION:R}
+
USE_EMACS= yes
USE_GMAKE= yes
HAS_CONFIGURE= yes
@@ -25,8 +27,8 @@ CONFIGURE_ARGS= --prefix=${PREFIX} \
--jvm=no
ALL_TARGET= # empty
INSTALL_TARGET= install-progs compile-bee install-bee
-USE_LDCONFIG= ${PREFIX}/lib ${PREFIX}/lib/bigloo/${PORTVERSION}
-PLIST_SUB= BIGLOO_VERSION="${PORTVERSION}"
+USE_LDCONFIG= ${PREFIX}/lib ${PREFIX}/lib/bigloo/${PORTVERSION:R}
+PLIST_SUB= BIGLOO_VERSION="${PORTVERSION:R}"
MAN1= bigloo.1
INFO= bigloo
@@ -39,8 +41,8 @@ post-patch:
${WRKSRC}/api/multimedia/src/Unix/bglmixer.c
post-configure:
- @${REINPLACE_CMD} -e 's/BGL_HAVE_SENDFILE 1/BGL_HAVE_SENDFILE 0/' \
- ${WRKSRC}/lib/${PORTVERSION}/bigloo_config.h
+ @${FIND} ${WRKSRC} -name "bigloo_config.h" | ${XARGS} \
+ ${REINPLACE_CMD} -e 's/BGL_HAVE_SENDFILE 1/BGL_HAVE_SENDFILE 0/'
.include <bsd.port.pre.mk>