aboutsummaryrefslogtreecommitdiff
path: root/lang/bigloo/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-12-14 18:45:58 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-12-14 18:45:58 +0000
commite9a92943d6badf0aaaff0cf9a26898904e800239 (patch)
tree6df7c541fddb4a140e09223f432f3238def1d151 /lang/bigloo/Makefile
parent6a87512884c920e3f625e1267ed231dc06dab232 (diff)
Notes
Diffstat (limited to 'lang/bigloo/Makefile')
-rw-r--r--lang/bigloo/Makefile38
1 files changed, 21 insertions, 17 deletions
diff --git a/lang/bigloo/Makefile b/lang/bigloo/Makefile
index 57b6ceae9b66..8ff6bf7a656b 100644
--- a/lang/bigloo/Makefile
+++ b/lang/bigloo/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= bigloo
-PORTVERSION= 2.6b
-PORTREVISION= 3
+PORTVERSION= 3.0c
CATEGORIES= lang scheme
MASTER_SITES= ftp://ftp-sop.inria.fr/mimosa/fp/Bigloo/ \
ftp://kaolin.unice.fr/pub/Bigloo/
@@ -16,28 +15,28 @@ DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A Scheme interpreter and native code compiler
-USE_GMAKE= yes
-ALL_TARGET=
-INSTALL_TARGET= install compile-bee install-bee
USE_EMACS= yes
-EMACS_PORT_NAME?= emacs21
-MAN1= bigloo.1
-INFO= bigloo
-PLIST_SUB= BIGLOO_VERSION=${PORTVERSION}
-INSTALLS_SHLIB= yes
-LDCONFIG_DIRS= %%PREFIX%%/lib/bigloo/%%BIGLOO_VERSION%%
-
+USE_GMAKE= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} \
--emacs=${EMACS_NAME} \
--lispdir=${LOCALBASE}/${EMACS_SITE_LISPDIR}/bigloo \
--native=yes \
--jvm=no
+ALL_TARGET= # empty
+INSTALL_TARGET= install-progs compile-bee install-bee
+USE_LDCONFIG= ${PREFIX}/lib ${PREFIX}/lib/bigloo/${PORTVERSION}
+PLIST_SUB= BIGLOO_VERSION="${PORTVERSION}"
-INSTALL_INFO?= install-info
+MAN1= bigloo.1
+INFO= bigloo
post-patch:
- @${REINPLACE_CMD} -e 's|prefix/doc|prefix/share/doc|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|"-O3"|""|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|"-pthread"|"${PTHREAD_LIBS}"|g' \
+ ${WRKSRC}/autoconf/pthread
+ @${REINPLACE_CMD} -e 's|machine/soundcard|sys/soundcard|g' \
+ ${WRKSRC}/api/multimedia/src/Unix/bglmixer.c
post-configure:
@${REINPLACE_CMD} -e 's/BGL_HAVE_SENDFILE 1/BGL_HAVE_SENDFILE 0/' \
@@ -46,12 +45,17 @@ post-configure:
.include <bsd.port.pre.mk>
.if ${ARCH} != "i386"
-BROKEN= "Does not compile on !i386"
+BROKEN= Does not compile on !i386
.endif
post-install:
- @${SED} "s|%%PREFIX%%|${PREFIX}|g" < ${FILESDIR}/bigloo.sh | ${SED} "s|%%BIGLOO_VERSION%%|${PORTVERSION}|g" > ${PREFIX}/etc/rc.d/000.bigloo.sh
- @${CHMOD} 750 ${PREFIX}/etc/rc.d/000.bigloo.sh
+ ${INSTALL_MAN} ${WRKSRC}/manuals/bigloo.man ${MANPREFIX}/man/man1/${MAN1}
+ ${INSTALL_DATA} ${WRKSRC}/manuals/bigloo.info ${PREFIX}/${INFO_PATH}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/manuals/*.html ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/manuals/*.sui ${DOCSDIR}
+.endif
test: build
@(cd ${WRKSRC}; ${GMAKE} test)