aboutsummaryrefslogtreecommitdiff
path: root/lang/bigloo/files
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-02-10 07:52:02 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-02-10 07:52:02 +0000
commitcbb450de563775d3a0c52106e03f72d01a5c4b35 (patch)
treef991e9777850c739ffed7433de4c2445659149da /lang/bigloo/files
parent455193145e633da79189c644887e589f00b60564 (diff)
Notes
Diffstat (limited to 'lang/bigloo/files')
-rw-r--r--lang/bigloo/files/patch-autoconf__flac49
-rw-r--r--lang/bigloo/files/patch-autoconf__gmp12
-rw-r--r--lang/bigloo/files/patch-autoconf__mpg12340
-rw-r--r--lang/bigloo/files/patch-bde__Makefile11
-rw-r--r--lang/bigloo/files/patch-cigloo__Makfefile11
-rw-r--r--lang/bigloo/files/patch-configure85
6 files changed, 208 insertions, 0 deletions
diff --git a/lang/bigloo/files/patch-autoconf__flac b/lang/bigloo/files/patch-autoconf__flac
new file mode 100644
index 000000000000..22e9de9073dd
--- /dev/null
+++ b/lang/bigloo/files/patch-autoconf__flac
@@ -0,0 +1,49 @@
+--- autoconf/flac.orig
++++ autoconf/flac
+@@ -14,7 +14,7 @@
+ #* flags */
+ #*---------------------------------------------------------------------*/
+ cflags=
+-flaclib=-lFLAC
++libs=
+
+ #*---------------------------------------------------------------------*/
+ #* We parse the arguments */
+@@ -27,8 +27,8 @@
+ --cflags=*|-cflags=*)
+ cflags="`echo $1 | sed 's/^[-a-z]*=//'`";;
+
+- --flaclib=*)
+- flaclib="`echo $1 | sed 's/^[-a-z]*=//'`";;
++ --libs=*)
++ libs="`echo $1 | sed 's/^[-a-z]*=//'`";;
+
+ -*)
+ echo "Unknown option \"$1\", ignored" >&2;;
+@@ -43,7 +43,7 @@
+ #*---------------------------------------------------------------------*/
+ #* compile */
+ #*---------------------------------------------------------------------*/
+-compile="$CC $cflags $file.c -o $aout $flaclib >/dev/null"
++compile="$CC $cflags $file.c -o $aout $libs >/dev/null"
+
+ #*---------------------------------------------------------------------*/
+ #* The test C file */
+@@ -88,7 +88,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
+-#include "FLAC/stream_decoder.h"
++#include "stream_decoder.h"
+
+ static FLAC__StreamDecoderWriteStatus write_callback(const FLAC__StreamDecoder *decoder, const FLAC__Frame *frame, const FLAC__int32 * const buffer[], void *client_data);
+ static void metadata_callback(const FLAC__StreamDecoder *decoder, const FLAC__StreamMetadata *metadata, void *client_data);
+@@ -252,7 +252,7 @@
+ #* Compilation test */
+ #*---------------------------------------------------------------------*/
+ if eval "$BUILDSH $compile"; then
+- echo "$flaclib"
++ echo "yes"
+ else
+ echo "no"
+ fi
diff --git a/lang/bigloo/files/patch-autoconf__gmp b/lang/bigloo/files/patch-autoconf__gmp
new file mode 100644
index 000000000000..c2ffb4a07f03
--- /dev/null
+++ b/lang/bigloo/files/patch-autoconf__gmp
@@ -0,0 +1,12 @@
+--- autoconf/gmp.orig
++++ autoconf/gmp
+@@ -27,6 +27,9 @@
+ --cflags=*|-cflags=*)
+ cflags="`echo $1 | sed 's/^[-a-z]*=//'`";;
+
++ --gmplib=*)
++ gmplib="`echo $1 | sed 's/^[-a-z]*=//'`";;
++
+ --type=*|-type=*)
+ type="`echo $1 | sed 's/^[-a-z]*=//'`";;
+
diff --git a/lang/bigloo/files/patch-autoconf__mpg123 b/lang/bigloo/files/patch-autoconf__mpg123
new file mode 100644
index 000000000000..a524eca9cb4a
--- /dev/null
+++ b/lang/bigloo/files/patch-autoconf__mpg123
@@ -0,0 +1,40 @@
+--- autoconf/mpg123.orig
++++ autoconf/mpg123
+@@ -14,7 +14,7 @@
+ #* flags */
+ #*---------------------------------------------------------------------*/
+ cflags=
+-mpg123lib=-lmpg123
++libs=
+
+ #*---------------------------------------------------------------------*/
+ #* We parse the arguments */
+@@ -27,8 +27,8 @@
+ --cflags=*|-cflags=*)
+ cflags="`echo $1 | sed 's/^[-a-z]*=//'`";;
+
+- --mpg123lib=*)
+- mpg123lib="`echo $1 | sed 's/^[-a-z]*=//'`";;
++ --libs=*)
++ libs="`echo $1 | sed 's/^[-a-z]*=//'`";;
+
+ -*)
+ echo "Unknown option \"$1\", ignored" >&2;;
+@@ -43,7 +43,7 @@
+ #*---------------------------------------------------------------------*/
+ #* compile */
+ #*---------------------------------------------------------------------*/
+-compile="$CC $cflags $file.c -o $aout $mpg123lib >/dev/null"
++compile="$CC $cflags $file.c -o $aout $libs >/dev/null"
+
+ #*---------------------------------------------------------------------*/
+ #* The test C file */
+@@ -154,7 +154,7 @@
+ #* Compilation test */
+ #*---------------------------------------------------------------------*/
+ if eval "$BUILDSH $compile"; then
+- echo "$mpg123lib"
++ echo "yes"
+ else
+ echo "no"
+ fi
diff --git a/lang/bigloo/files/patch-bde__Makefile b/lang/bigloo/files/patch-bde__Makefile
new file mode 100644
index 000000000000..9dc152b37045
--- /dev/null
+++ b/lang/bigloo/files/patch-bde__Makefile
@@ -0,0 +1,11 @@
+--- bde/Makefile.orig
++++ bde/Makefile
+@@ -117,7 +117,7 @@
+ dobmem
+
+ boot:
+- $(MAKE) all BFLAGS="$(BFLAGS) -ld-relative"
++ $(MAKE) all BFLAGS="$(BFLAGS) -ld-relative -ldopt \"$(LDFLAGS)\""
+
+ dobmem: $(BOOTBINDIR)/$(AFILE_EXE)
+ @ if [ "$(LDPRELOADSUPPORT)" = "yes" \
diff --git a/lang/bigloo/files/patch-cigloo__Makfefile b/lang/bigloo/files/patch-cigloo__Makfefile
new file mode 100644
index 000000000000..eaf8a42f4e30
--- /dev/null
+++ b/lang/bigloo/files/patch-cigloo__Makfefile
@@ -0,0 +1,11 @@
+--- cigloo/Makefile.orig
++++ cigloo/Makefile
+@@ -106,7 +106,7 @@
+ #*---------------------------------------------------------------------*/
+ $(CIGLOO_DEST): $(O_OBJECTS)
+ @ echo "Linking:"
+- @ $(BIGLOO) $(BFLAGS) $(EFLAGS) $(O_OBJECTS) -o $(CIGLOO_DEST)
++ @ $(BIGLOO) $(BFLAGS) $(EFLAGS) -ldopt "$(LDFLAGS)" $(O_OBJECTS) -o $(CIGLOO_DEST)
+ @- $(STRIP) $(CIGLOO_DEST)
+ @ echo "Cigloo Done..."
+ @ echo "-------------------------------"
diff --git a/lang/bigloo/files/patch-configure b/lang/bigloo/files/patch-configure
new file mode 100644
index 000000000000..9368d54b2cfa
--- /dev/null
+++ b/lang/bigloo/files/patch-configure
@@ -0,0 +1,85 @@
+--- configure.orig
++++ configure
+@@ -2014,12 +2014,10 @@
+ #*---------------------------------------------------------------------*/
+ # find out the C library for mpg123
+ if [ "$mpg123 " = " " ]; then
+- mpg123libs=`$autoconf mpg123 --cflags="$cflags $mpg123cflags"` || exit 1;
++ mpg123libs=`$autoconf bgl-pkg-config --libs libmpg123`
++ mpg123cflags=`$autoconf bgl-pkg-config --cflags libmpg123`
+
+- if [ "$mpg123libs " = "no " -a "$mpg123cflags " = " " ]; then
+- mpg123cflags="-D_FILE_OFFSET_BITS=64"
+- mpg123libs=`$autoconf mpg123 --cflags="$cflags $mpg123cflags"` || exit 1;
+- fi
++ mpg123=`$autoconf mpg123 --cflags="$mpg123cflags" --libs="$mpg123libs"` || exit 1;
+ fi
+
+ #*---------------------------------------------------------------------*/
+@@ -2027,7 +2025,10 @@
+ #*---------------------------------------------------------------------*/
+ # find out the C library for flac
+ if [ "$flac " = " " ]; then
+- flaclibs=`$autoconf flac --cflags="$cflags"` || exit 1;
++ flaclibs=`$autoconf bgl-pkg-config --libs flac`
++ flaccflags=`$autoconf bgl-pkg-config --cflags flac`
++
++ flac=`$autoconf flac --cflags="$flaccflags" --libs="$flaclibs"` || exit 1;
+ fi
+
+ #*---------------------------------------------------------------------*/
+@@ -2040,7 +2041,7 @@
+ #*---------------------------------------------------------------------*/
+ if [ "$regexp " = " " ]; then
+ # find out the C library for pcre
+- pcrelibs=`$autoconf pcre --cflags="$cflags"` || exit 1;
++ pcrelibs=`$autoconf pcre --cflags="$cflags" --pcrelib="$pcrelib"` || exit 1;
+
+ if [ "$pcrelibs " != "no " ]; then
+ featureflags="-srfi enable-pcre $featureflags";
+@@ -2226,7 +2227,7 @@
+ featureflags="-srfi enable-gmp $featureflags";
+ extralibs="-lbigloogmp-$release $extralibs"
+ elif [ "$gmpversion " = " " ]; then
+- gmpversion=`$autoconf gmp` || exit 1
++ gmpversion=`$autoconf gmp --cflags="$cflags" --gmplib="$gmplib"` || exit 1
+
+ if [ $gmpversion = "no" ]; then
+ havegmp=0;
+@@ -2359,8 +2360,8 @@
+ fi
+ fi
+
+- long_limbs=`$autoconf limbs --type="long" --cflags="-I$bootdir/lib/$release -L$bootdir/lib/$release"` || exit 1
+- longlong_limbs=`$autoconf limbs --type="$longlong" --cflags="-I$bootdir/lib/$release -L$bootdir/lib/$release"` || exit 1
++ long_limbs=`$autoconf limbs --type="long" --cflags="-I$bootdir/lib/$release -L$bootdir/lib/$release $cflags"` || exit 1
++ longlong_limbs=`$autoconf limbs --type="$longlong" --cflags="-I$bootdir/lib/$release -L$bootdir/lib/$release $cflags"` || exit 1
+
+ long_sign_bit=`$autoconf signbit --type=long --alignment="$alignment"` || exit 1
+ elong_sign_bit=`$autoconf signbit --type=long --alignment=0` || exit 1
+@@ -3277,7 +3278,7 @@
+ fi
+
+ # MPG123
+- if [ "$mpg123libs " != "no " ]; then
++ if [ "$mpg123 " != "no " ]; then
+ echo "MPG123=$mpg123" >> $makefile_cfg
+ echo "MPG123LIBS=$mpg123libs" >> $makefile_cfg
+ echo "MPG123CFLAGS=$mpg123cflags" >> $makefile_cfg
+@@ -3302,13 +3303,14 @@
+ apis=$napis;
+ echo "MPG123=" >> $makefile_cfg
+ echo "MPG123LIBS=" >> $makefile_cfg
+- echo "MPG123FLAGS=" >> $makefile_cfg
++ echo "MPG123CFLAGS=" >> $makefile_cfg
+ fi
+
+ # FLAC
+- if [ "$flaclibs " != "no " ]; then
++ if [ "$flac " != "no " ]; then
+ echo "FLAC=$flac" >> $makefile_cfg
+ echo "FLACLIBS=$flaclibs" >> $makefile_cfg
++ echo "FLACCFLAGS=$flaccflags" >> $makefile_cfg
+
+ # Patch the code of the FLAC init file
+ echo ";; automatically generated. Don't edit" > api/flac/src/Misc/flac.init