aboutsummaryrefslogtreecommitdiff
path: root/lang/ccl/Makefile
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2010-01-15 11:13:51 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2010-01-15 11:13:51 +0000
commit80524222e8c3c4789b701f91def7d9f2b01ef275 (patch)
tree4ea9efa80717bb682852e6c403b2428125be4ce1 /lang/ccl/Makefile
parent9e01f0029ca4a3a6fb1fb2c87ce1dda0edc021fc (diff)
Notes
Diffstat (limited to 'lang/ccl/Makefile')
-rw-r--r--lang/ccl/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/lang/ccl/Makefile b/lang/ccl/Makefile
index ff8c644a8c63..fd608e43b8ca 100644
--- a/lang/ccl/Makefile
+++ b/lang/ccl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ccl
PORTVERSION= 1.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang lisp
MASTER_SITES= ftp://ftp.clozure.com/pub/release/${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}-freebsdx86
@@ -19,6 +19,8 @@ WRKSRC= ${WRKDIR}/ccl
ONLY_FOR_ARCHS= i386 amd64
+MANUAL_PACKAGE_BUILD=yes
+
CCL_DIRECTORY= ${PREFIX}/lib/ccl
CCL_PLIST= ${WRKDIR}/pkg-plist
# the following files will not be installed
@@ -41,7 +43,8 @@ SUB_FILES= ccl.sh
post-patch:
@${SED} -i '' -e 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/tools/asdf.lisp
- @${FIND} ${WRKSRC} -name .svn -or -name .cvsignore | ${XARGS} ${RM} -r -f
+ @${FIND} ${WRKSRC} -name .svn -or -name .cvsignore -or -name "*.orig" \
+ | ${XARGS} ${RM} -r -f
do-build:
@${RM} -f ${WRKSRC}/fx86cl ${WRKSRC}/fx86cl64
@@ -52,6 +55,8 @@ do-build:
fi
@cd ${WRKSRC} && ${ECHO_CMD} | ./${FX86CL} --no-init --batch --quiet \
--eval "(ccl:rebuild-ccl :full t)" \
+ --eval "(require 'asdf)" \
+ --eval "(asdf:operate 'asdf:load-op 'asdf-install)" \
--eval "(quit)"
do-install: