aboutsummaryrefslogtreecommitdiff
path: root/lang/ccscript
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-02-20 09:57:20 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-02-20 09:57:20 +0000
commit40243c4bf79131351be3719c76c795d0d076d1d2 (patch)
tree0922db407624e6e67ecf0ef7ef709b7d04497dd4 /lang/ccscript
parent1f5a12229ece5ee46934dfab58cd7c6b31c4e36b (diff)
downloadports-40243c4bf79131351be3719c76c795d0d076d1d2.tar.gz
ports-40243c4bf79131351be3719c76c795d0d076d1d2.zip
Notes
Diffstat (limited to 'lang/ccscript')
-rw-r--r--lang/ccscript/Makefile24
-rw-r--r--lang/ccscript/distinfo1
-rw-r--r--lang/ccscript/files/patch-config:ltmain.sh15
-rw-r--r--lang/ccscript/files/patch-src:script.cpp11
-rw-r--r--lang/ccscript/pkg-plist1
5 files changed, 37 insertions, 15 deletions
diff --git a/lang/ccscript/Makefile b/lang/ccscript/Makefile
index dfc79764bc07..40fed2ef69e0 100644
--- a/lang/ccscript/Makefile
+++ b/lang/ccscript/Makefile
@@ -9,29 +9,25 @@ PORTNAME= ccscript
PORTVERSION= 2.5.6
PORTREVISION= 1
CATEGORIES= lang
-MASTER_SITES= ${MASTER_SITE_GNU}
-MASTER_SITE_SUBDIR= ccscript
+MASTER_SITES= ${MASTER_SITE_GNU:S/$/:gnu/} \
+ ${MASTER_SITE_SOURCEFORGE:S/$/:sf/}
+MASTER_SITE_SUBDIR= ccaudio/:gnu \
+ bayonne/:sf
+DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:gnu \
+ ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:sf
MAINTAINER= ports@FreeBSD.org
COMMENT= State-event driven class extendible C++ script interpreter
-LIB_DEPENDS= ccgnu2-1.0.0:${PORTSDIR}/devel/commoncpp
+LIB_DEPENDS= ccgnu2-1.1.0:${PORTSDIR}/devel/commoncpp
-BROKEN= "Broken dependency"
-
-USE_GMAKE= yes
-USE_LIBTOOL= yes
-USE_AUTOCONF= yes
-WANT_AUTOCONF_VER= 257
+USE_GNOME= gnometarget
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install man
INSTALLS_SHLIB= yes
-CONFIGURE_TARGET=
-
MAN3= ScriptCommand.3cc ScriptImage.3cc ScriptInterp.3cc \
ScriptModule.3cc ScriptSymbol.3cc Script_Locks.3cc \
Script_Package.3cc Script_Property.3cc Script_Session.3cc
-post-install:
- (cd ${WRKSRC} ; ${MAKE} man)
-
.include <bsd.port.mk>
diff --git a/lang/ccscript/distinfo b/lang/ccscript/distinfo
index 53b59bb36ae7..c6146324ab33 100644
--- a/lang/ccscript/distinfo
+++ b/lang/ccscript/distinfo
@@ -1 +1,2 @@
MD5 (ccscript-2.5.6.tar.gz) = c0e664ab13e054b37e0f7da40a7b488e
+SIZE (ccscript-2.5.6.tar.gz) = 375473
diff --git a/lang/ccscript/files/patch-config:ltmain.sh b/lang/ccscript/files/patch-config:ltmain.sh
new file mode 100644
index 000000000000..664ec529fbf0
--- /dev/null
+++ b/lang/ccscript/files/patch-config:ltmain.sh
@@ -0,0 +1,15 @@
+--- config/ltmain.sh.orig Fri Feb 20 17:50:28 2004
++++ config/ltmain.sh Fri Feb 20 17:50:39 2004
+@@ -5428,10 +5428,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false ; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/lang/ccscript/files/patch-src:script.cpp b/lang/ccscript/files/patch-src:script.cpp
new file mode 100644
index 000000000000..4318af360f82
--- /dev/null
+++ b/lang/ccscript/files/patch-src:script.cpp
@@ -0,0 +1,11 @@
+--- src/script.cpp.orig Fri Feb 20 17:51:13 2004
++++ src/script.cpp Fri Feb 20 17:52:01 2004
+@@ -1209,7 +1209,7 @@
+ #endif
+ for(;;)
+ {
+- scrname = dir.getName();
++ scrname = (char*)dir.getName();
+ if(!scrname)
+ break;
+ ext = strchr(scrname, '.');
diff --git a/lang/ccscript/pkg-plist b/lang/ccscript/pkg-plist
index 676c969b9705..4054475c0ce9 100644
--- a/lang/ccscript/pkg-plist
+++ b/lang/ccscript/pkg-plist
@@ -1,7 +1,6 @@
bin/ccscript
include/cc++2/cc++/script.h
lib/libccscript2.a
-lib/libccscript2.la
lib/libccscript2.so
lib/libccscript2-0.5.so
lib/libccscript2-0.5.so.3