aboutsummaryrefslogtreecommitdiff
path: root/lang/cjs/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-12-30 20:13:46 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-12-30 20:13:46 +0000
commitb28f4972855f1b355b5b156ffca59f4135e0e4c8 (patch)
treef8d16b26e7f6882796704c78c3316de2d96ca435 /lang/cjs/Makefile
parent83b4f7b7528232f46a80c28193ac942e4e8c2f83 (diff)
downloadports-b28f4972855f1b355b5b156ffca59f4135e0e4c8.tar.gz
ports-b28f4972855f1b355b5b156ffca59f4135e0e4c8.zip
Update cinnamon to 2.4, this should fix [1] and [2].
Update totem to 3.14 now that we have gstreamer 1.4 and minor gnome updates. Update evolution suite to 3.12.9. Make sure gtk30 pulls in adwait-icon-theme, since it now the default theme [3]. PR: 195290 [1], 195289 [2], 195455 [3] Obtained from: gnome devel repo
Notes
Notes: svn path=/head/; revision=375852
Diffstat (limited to 'lang/cjs/Makefile')
-rw-r--r--lang/cjs/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/lang/cjs/Makefile b/lang/cjs/Makefile
index 8be263bef545..1ef9d4b90405 100644
--- a/lang/cjs/Makefile
+++ b/lang/cjs/Makefile
@@ -1,9 +1,8 @@
# Created by: Gustau Perez i Querol <gustau.perez@gmail.com>
# $FreeBSD$
-# $MCom: ports/trunk/lang/cjs/Makefile 20008 2014-10-21 15:13:35Z gusi $
PORTNAME= cjs
-PORTVERSION= 2.2.2
+PORTVERSION= 2.4.1
CATEGORIES= lang gnome
MASTER_SITES= http://github.com/linuxmint/${PORTNAME}/archive/${PORTVERSION}.tar.gz?dummy=/
DIST_SUBDIR= gnome3
@@ -13,7 +12,7 @@ COMMENT= JavaScript bindings based on gobject-introspection
BUILD_DEPENDS= gnome-autogen.sh:${PORTSDIR}/devel/gnome-common
LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
- libmozjs185.so:${PORTSDIR}/lang/spidermonkey185
+ libmozjs-24.so:${PORTSDIR}/lang/spidermonkey24
CONFLICTS_BUILD=spidermonkey17-1.7.*
@@ -30,7 +29,6 @@ LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
CONFIGURE_ARGS+=--enable-compile-warnings=no
-SHEBANG_FILES= scripts/make-tests
python_OLD_CMD= /usr/bin/env python
python_CMD= ${PYTHON_CMD}