aboutsummaryrefslogtreecommitdiff
path: root/lang/clang
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2012-06-26 10:10:40 +0000
committerDima Panov <fluffy@FreeBSD.org>2012-06-26 10:10:40 +0000
commit59a6890bf5878296c9e0c09e30bdc90aec4fef47 (patch)
tree4cc80d1f25e355f44bc2750b8962ccfd67c8d129 /lang/clang
parent4079c05aed888a48e5c3608c34ce9bb13a6b9cb1 (diff)
downloadports-59a6890bf5878296c9e0c09e30bdc90aec4fef47.tar.gz
ports-59a6890bf5878296c9e0c09e30bdc90aec4fef47.zip
Notes
Diffstat (limited to 'lang/clang')
-rw-r--r--lang/clang/Makefile32
-rw-r--r--lang/clang/distinfo8
-rw-r--r--lang/clang/files/patch-tools_clang_include_clang_Analysis_Analyses_FormatString.h12
-rw-r--r--lang/clang/files/patch-utils_llvm-build_llvmbuild_main.py20
-rw-r--r--lang/clang/pkg-plist66
5 files changed, 87 insertions, 51 deletions
diff --git a/lang/clang/Makefile b/lang/clang/Makefile
index 302be2fc332c..c7559a0b4abd 100644
--- a/lang/clang/Makefile
+++ b/lang/clang/Makefile
@@ -6,9 +6,10 @@
#
PORTNAME= clang
-PORTVERSION= 3.0
+PORTVERSION= 3.1
CATEGORIES= lang devel
MASTER_SITES= http://llvm.org/releases/${PORTVERSION}/
+DISTNAME= ${PORTNAME}-${PORTVERSION}.src
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
${LLVM_SOURCE}
EXTRACT_ONLY= ${LLVM_SOURCE}
@@ -18,12 +19,12 @@ COMMENT= C, Objective-C, and (alpha-quality) C++ compiler
CONFLICTS= clang-devel-[23]*
-CLANG_NAME= clang-${PORTVERSION}
+CLANG_NAME= clang-${PORTVERSION}.src
CLANG_SOURCE= ${CLANG_NAME}${EXTRACT_SUFX}
-LLVM_NAME= llvm-${PORTVERSION}
+LLVM_NAME= llvm-${PORTVERSION}.src
LLVM_SOURCE= ${LLVM_NAME}${EXTRACT_SUFX}
-WRKSRC= ${WRKDIR}/${LLVM_NAME}.src
+WRKSRC= ${WRKDIR}/${LLVM_NAME}
BUILD_WRKSRC= ${WRKSRC}/tools/clang
INSTALL_WRKSRC= ${WRKSRC}/tools/clang
@@ -44,13 +45,11 @@ USE_PERL5= yes
USE_PYTHON= yes
MAKE_JOBS_SAFE= yes
-MAKE_ARGS= CLANG_TBLGEN=${WRKSRC}/Release/bin/clang-tblgen \
+MAKE_ARGS= CLANG_TBLGEN=${WRKSRC}/Release+Asserts/bin/clang-tblgen \
LLVMIncDir=${LOCALBASE}/include \
LLVMToolDir=${LOCALBASE}/bin \
LLVMLibDir=${LOCALBASE}/lib
-CONFIGURE_ARGS+= --enable-shared
-
.if defined(MAINTAINER_MODE)
CONFIGURE_ARGS+= --with-f2c=${LOCALBASE}
.else
@@ -74,7 +73,7 @@ BROKEN= Does not compile on sparc64
post-extract:
cd ${WRKSRC}/tools && \
tar xf ${DISTDIR}/${CLANG_SOURCE} && \
- ${MV} ${CLANG_NAME}.src clang
+ ${MV} ${CLANG_NAME} clang
post-patch:
${REINPLACE_CMD} -e 's|\(PROJ_docsdir.*:=\).*$$|\1${DOCSDIR}|g' \
@@ -90,17 +89,12 @@ post-patch:
${WRKSRC}/tools/clang/tools/scan-view/scan-view
pre-build:
- ${LN} -sf ${LOCALBASE}/include/llvm/Intrinsics.gen \
- ${WRKSRC}/include/llvm/
- ${MKDIR} ${WRKSRC}/Release/lib
- ${LN} -sf ${LOCALBASE}/lib/libLLVM-${PORTVERSION}.so \
- ${WRKSRC}/Release/lib/
- ${LN} -sf ${LOCALBASE}/lib/libLLVMTableGen.a \
- ${WRKSRC}/Release/lib/
- ${LN} -sf ${LOCALBASE}/lib/libLLVMSupport.a \
- ${WRKSRC}/Release/lib/
- cd ${WRKSRC}/utils/unittest/UnitTestMain && ${GMAKE}
- cd ${WRKSRC}/utils/unittest/googletest && ${GMAKE}
+ ${LN} -sf ${LOCALBASE}/include/llvm/Intrinsics.gen ${WRKSRC}/include/llvm/
+ ${MKDIR} ${WRKSRC}/Release+Asserts/lib
+ ${LN} -sf ${LOCALBASE}/lib/libLLVM-${PORTVERSION}.so ${WRKSRC}/Release+Asserts/lib/
+ ${LN} -sf ${LOCALBASE}/lib/libLLVMTableGen.a ${WRKSRC}/Release+Asserts/lib/
+ ${LN} -sf ${LOCALBASE}/lib/libLLVMSupport.a ${WRKSRC}/Release+Asserts/lib/
+ cd ${WRKSRC}/utils/unittest && ${GMAKE}
.if defined(NOPORTDOCS)
post-build:
diff --git a/lang/clang/distinfo b/lang/clang/distinfo
index 1a058a452db6..0103d94048c5 100644
--- a/lang/clang/distinfo
+++ b/lang/clang/distinfo
@@ -1,4 +1,4 @@
-SHA256 (clang-3.0.tar.gz) = b64e72da356d7c3428cfd7ac620d49ec042c84eaee13c26024879f555f4e126d
-SIZE (clang-3.0.tar.gz) = 7240578
-SHA256 (llvm-3.0.tar.gz) = 519eb11d3499ce99c6ffdb8718651fc91425ed7690eac91c8d6853474f7c0477
-SIZE (llvm-3.0.tar.gz) = 10350539
+SHA256 (clang-3.1.src.tar.gz) = ff63e215dcd3e2838ffdea38502f8d35bab17e487f3c3799579961e452d5a786
+SIZE (clang-3.1.src.tar.gz) = 8158418
+SHA256 (llvm-3.1.src.tar.gz) = 1ea05135197b5400c1f88d00ff280d775ce778f8f9ea042e25a1e1e734a4b9ab
+SIZE (llvm-3.1.src.tar.gz) = 11077429
diff --git a/lang/clang/files/patch-tools_clang_include_clang_Analysis_Analyses_FormatString.h b/lang/clang/files/patch-tools_clang_include_clang_Analysis_Analyses_FormatString.h
index 42d66e555f18..5db58d679de1 100644
--- a/lang/clang/files/patch-tools_clang_include_clang_Analysis_Analyses_FormatString.h
+++ b/lang/clang/files/patch-tools_clang_include_clang_Analysis_Analyses_FormatString.h
@@ -1,16 +1,16 @@
-$FreeBSD: /tmp/pcvs/ports/lang/clang/files/patch-tools_clang_include_clang_Analysis_Analyses_FormatString.h,v 1.1 2010-10-08 14:00:31 brooks Exp $
+$FreeBSD: /tmp/pcvs/ports/lang/clang/files/patch-tools_clang_include_clang_Analysis_Analyses_FormatString.h,v 1.2 2012-06-26 10:10:40 fluffy Exp $
--- tools/clang/include/clang/Analysis/Analyses/FormatString.h.orig
+++ tools/clang/include/clang/Analysis/Analyses/FormatString.h
-@@ -139,6 +139,10 @@
- SArg,
-
+@@ -143,6 +143,10 @@
+
// ** Printf-specific **
-+
+
+ // FreeBSD specific specifiers
+ bArg,
+ DArg,
-
++
// Objective-C specific specifiers.
ObjCObjArg, // '@'
+ ObjCBeg = ObjCObjArg, ObjCEnd = ObjCObjArg,
diff --git a/lang/clang/files/patch-utils_llvm-build_llvmbuild_main.py b/lang/clang/files/patch-utils_llvm-build_llvmbuild_main.py
new file mode 100644
index 000000000000..1e2de0273d55
--- /dev/null
+++ b/lang/clang/files/patch-utils_llvm-build_llvmbuild_main.py
@@ -0,0 +1,20 @@
+
+$FreeBSD$
+
+--- utils/llvm-build/llvmbuild/main.py.orig
++++ utils/llvm-build/llvmbuild/main.py
+@@ -633,7 +633,13 @@
+
+ # We handle a few special cases of target names here for historical
+ # reasons, as these are the names configure currently comes up with.
+- native_target_name = { 'x86' : 'X86',
++ native_target_name = { 'amd64' : 'X86',
++ 'arm' : 'ARM',
++ 'i386' : 'X86',
++ 'mips' : 'Mips',
++ 'powerpc' : 'PowerPC',
++ 'sparc64' : 'Sparc',
++ 'x86' : 'X86',
+ 'x86_64' : 'X86',
+ 'Unknown' : None }.get(opts.native_target,
+ opts.native_target)
diff --git a/lang/clang/pkg-plist b/lang/clang/pkg-plist
index e8de5def3ee8..a5a622bcfe48 100644
--- a/lang/clang/pkg-plist
+++ b/lang/clang/pkg-plist
@@ -22,6 +22,7 @@ include/clang/AST/Attr.h
include/clang/AST/AttrImpl.inc
include/clang/AST/Attrs.inc
include/clang/AST/BaseSubobject.h
+include/clang/AST/BuiltinTypes.def
include/clang/AST/CXXInheritance.h
include/clang/AST/CanonicalType.h
include/clang/AST/CharUnits.h
@@ -32,6 +33,7 @@ include/clang/AST/DeclCXX.h
include/clang/AST/DeclContextInternals.h
include/clang/AST/DeclFriend.h
include/clang/AST/DeclGroup.h
+include/clang/AST/DeclLookups.h
include/clang/AST/DeclNodes.inc
include/clang/AST/DeclObjC.h
include/clang/AST/DeclTemplate.h
@@ -44,7 +46,9 @@ include/clang/AST/ExprCXX.h
include/clang/AST/ExprObjC.h
include/clang/AST/ExternalASTSource.h
include/clang/AST/GlobalDecl.h
+include/clang/AST/LambdaMangleContext.h
include/clang/AST/Mangle.h
+include/clang/AST/NSAPI.h
include/clang/AST/NestedNameSpecifier.h
include/clang/AST/OperationKinds.h
include/clang/AST/ParentMap.h
@@ -70,12 +74,13 @@ include/clang/AST/TypeNodes.def
include/clang/AST/TypeOrdering.h
include/clang/AST/TypeVisitor.h
include/clang/AST/UnresolvedSet.h
-include/clang/AST/UsuallyTinyPtrVector.h
include/clang/AST/VTTBuilder.h
include/clang/AST/VTableBuilder.h
include/clang/Analysis/Analyses/CFGReachabilityAnalysis.h
+include/clang/Analysis/Analyses/Dominators.h
include/clang/Analysis/Analyses/FormatString.h
include/clang/Analysis/Analyses/LiveVariables.h
+include/clang/Analysis/Analyses/PostOrderCFGView.h
include/clang/Analysis/Analyses/PseudoConstantAnalysis.h
include/clang/Analysis/Analyses/ReachableCode.h
include/clang/Analysis/Analyses/ThreadSafety.h
@@ -84,28 +89,29 @@ include/clang/Analysis/AnalysisContext.h
include/clang/Analysis/AnalysisDiagnostic.h
include/clang/Analysis/CFG.h
include/clang/Analysis/CFGStmtMap.h
+include/clang/Analysis/CallGraph.h
include/clang/Analysis/DomainSpecific/CocoaConventions.h
include/clang/Analysis/FlowSensitive/DataflowSolver.h
include/clang/Analysis/FlowSensitive/DataflowValues.h
include/clang/Analysis/ProgramPoint.h
include/clang/Analysis/Support/BlkExprDeclBitVector.h
include/clang/Analysis/Support/BumpVector.h
-include/clang/Analysis/Support/SaveAndRestore.h
include/clang/Analysis/Visitors/CFGRecStmtDeclVisitor.h
include/clang/Analysis/Visitors/CFGRecStmtVisitor.h
include/clang/Analysis/Visitors/CFGStmtVisitor.h
include/clang/Basic/ABI.h
include/clang/Basic/AddressSpaces.h
+include/clang/Basic/AllDiagnostics.h
include/clang/Basic/AttrKinds.h
include/clang/Basic/AttrList.inc
include/clang/Basic/Builtins.def
include/clang/Basic/Builtins.h
include/clang/Basic/BuiltinsARM.def
+include/clang/Basic/BuiltinsHexagon.def
include/clang/Basic/BuiltinsPPC.def
include/clang/Basic/BuiltinsPTX.def
include/clang/Basic/BuiltinsX86.def
include/clang/Basic/ConvertUTF.h
-include/clang/Basic/DelayedCleanupPool.h
include/clang/Basic/Diagnostic.h
include/clang/Basic/DiagnosticASTKinds.inc
include/clang/Basic/DiagnosticAnalysisKinds.inc
@@ -119,6 +125,7 @@ include/clang/Basic/DiagnosticIndexName.inc
include/clang/Basic/DiagnosticLexKinds.inc
include/clang/Basic/DiagnosticParseKinds.inc
include/clang/Basic/DiagnosticSemaKinds.inc
+include/clang/Basic/DiagnosticSerializationKinds.inc
include/clang/Basic/ExceptionSpecificationType.h
include/clang/Basic/ExpressionTraits.h
include/clang/Basic/FileManager.h
@@ -126,10 +133,12 @@ include/clang/Basic/FileSystemOptions.h
include/clang/Basic/FileSystemStatCache.h
include/clang/Basic/IdentifierTable.h
include/clang/Basic/LLVM.h
+include/clang/Basic/Lambda.h
include/clang/Basic/LangOptions.def
include/clang/Basic/LangOptions.h
include/clang/Basic/Linkage.h
include/clang/Basic/MacroBuilder.h
+include/clang/Basic/Module.h
include/clang/Basic/OnDiskHashTable.h
include/clang/Basic/OpenCL.h
include/clang/Basic/OpenCLExtensions.def
@@ -156,6 +165,7 @@ include/clang/Basic/arm_neon.inc
include/clang/CodeGen/BackendUtil.h
include/clang/CodeGen/CodeGenAction.h
include/clang/CodeGen/ModuleBuilder.h
+include/clang/Config/config.h
include/clang/Driver/Action.h
include/clang/Driver/Arg.h
include/clang/Driver/ArgList.h
@@ -166,7 +176,6 @@ include/clang/Driver/CC1Options.inc
include/clang/Driver/Compilation.h
include/clang/Driver/Driver.h
include/clang/Driver/DriverDiagnostic.h
-include/clang/Driver/HostInfo.h
include/clang/Driver/Job.h
include/clang/Driver/ObjCRuntime.h
include/clang/Driver/OptSpecifier.h
@@ -180,17 +189,24 @@ include/clang/Driver/ToolChain.h
include/clang/Driver/Types.def
include/clang/Driver/Types.h
include/clang/Driver/Util.h
+include/clang/Edit/Commit.h
+include/clang/Edit/EditedSource.h
+include/clang/Edit/EditsReceiver.h
+include/clang/Edit/FileOffset.h
+include/clang/Edit/Rewriters.h
include/clang/Frontend/ASTConsumers.h
include/clang/Frontend/ASTUnit.h
include/clang/Frontend/Analyses.def
include/clang/Frontend/AnalyzerOptions.h
include/clang/Frontend/ChainedDiagnosticConsumer.h
+include/clang/Frontend/ChainedIncludesSource.h
include/clang/Frontend/CodeGenOptions.h
include/clang/Frontend/CommandLineSourceLoc.h
include/clang/Frontend/CompilerInstance.h
include/clang/Frontend/CompilerInvocation.h
include/clang/Frontend/DependencyOutputOptions.h
include/clang/Frontend/DiagnosticOptions.h
+include/clang/Frontend/DiagnosticRenderer.h
include/clang/Frontend/FrontendAction.h
include/clang/Frontend/FrontendActions.h
include/clang/Frontend/FrontendDiagnostic.h
@@ -199,28 +215,19 @@ include/clang/Frontend/FrontendPluginRegistry.h
include/clang/Frontend/HeaderSearchOptions.h
include/clang/Frontend/LangStandard.h
include/clang/Frontend/LangStandards.def
+include/clang/Frontend/LayoutOverrideSource.h
include/clang/Frontend/LogDiagnosticPrinter.h
+include/clang/Frontend/MigratorOptions.h
include/clang/Frontend/MultiplexConsumer.h
include/clang/Frontend/PreprocessorOptions.h
include/clang/Frontend/PreprocessorOutputOptions.h
+include/clang/Frontend/SerializedDiagnosticPrinter.h
+include/clang/Frontend/TextDiagnostic.h
include/clang/Frontend/TextDiagnosticBuffer.h
include/clang/Frontend/TextDiagnosticPrinter.h
include/clang/Frontend/Utils.h
include/clang/Frontend/VerifyDiagnosticConsumer.h
include/clang/FrontendTool/Utils.h
-include/clang/Index/ASTLocation.h
-include/clang/Index/Analyzer.h
-include/clang/Index/CallGraph.h
-include/clang/Index/DeclReferenceMap.h
-include/clang/Index/Entity.h
-include/clang/Index/GlobalSelector.h
-include/clang/Index/Handlers.h
-include/clang/Index/IndexProvider.h
-include/clang/Index/Indexer.h
-include/clang/Index/Program.h
-include/clang/Index/STLExtras.h
-include/clang/Index/SelectorMap.h
-include/clang/Index/TranslationUnit.h
include/clang/Lex/AttrSpellings.inc
include/clang/Lex/CodeCompletionHandler.h
include/clang/Lex/DirectoryLookup.h
@@ -232,6 +239,7 @@ include/clang/Lex/Lexer.h
include/clang/Lex/LiteralSupport.h
include/clang/Lex/MacroInfo.h
include/clang/Lex/ModuleLoader.h
+include/clang/Lex/ModuleMap.h
include/clang/Lex/MultipleIncludeOpt.h
include/clang/Lex/PPCallbacks.h
include/clang/Lex/PTHLexer.h
@@ -258,6 +266,9 @@ include/clang/Rewrite/Rewriter.h
include/clang/Rewrite/Rewriters.h
include/clang/Rewrite/TokenRewriter.h
include/clang/Sema/AnalysisBasedWarnings.h
+include/clang/Sema/AttrParsedAttrKinds.inc
+include/clang/Sema/AttrParsedAttrList.inc
+include/clang/Sema/AttrTemplateInstantiate.inc
include/clang/Sema/AttributeList.h
include/clang/Sema/CXXFieldCollector.h
include/clang/Sema/CodeCompleteConsumer.h
@@ -269,7 +280,6 @@ include/clang/Sema/IdentifierResolver.h
include/clang/Sema/Initialization.h
include/clang/Sema/LocInfoType.h
include/clang/Sema/Lookup.h
-include/clang/Sema/MultiInitializer.h
include/clang/Sema/ObjCMethodList.h
include/clang/Sema/Overload.h
include/clang/Sema/Ownership.h
@@ -292,11 +302,12 @@ include/clang/Serialization/ASTReader.h
include/clang/Serialization/ASTWriter.h
include/clang/Serialization/AttrPCHRead.inc
include/clang/Serialization/AttrPCHWrite.inc
-include/clang/Serialization/ChainedIncludesSource.h
include/clang/Serialization/ContinuousRangeMap.h
include/clang/Serialization/Module.h
include/clang/Serialization/ModuleManager.h
+include/clang/Serialization/SerializationDiagnostic.h
include/clang/StaticAnalyzer/Checkers/ClangCheckers.h
+include/clang/StaticAnalyzer/Checkers/CommonBugCategories.h
include/clang/StaticAnalyzer/Checkers/DereferenceChecker.h
include/clang/StaticAnalyzer/Checkers/LocalCheckers.h
include/clang/StaticAnalyzer/Core/BugReporter/BugReporter.h
@@ -318,11 +329,12 @@ include/clang/StaticAnalyzer/Core/PathSensitive/CoreEngine.h
include/clang/StaticAnalyzer/Core/PathSensitive/Environment.h
include/clang/StaticAnalyzer/Core/PathSensitive/ExplodedGraph.h
include/clang/StaticAnalyzer/Core/PathSensitive/ExprEngine.h
-include/clang/StaticAnalyzer/Core/PathSensitive/ExprEngineBuilders.h
+include/clang/StaticAnalyzer/Core/PathSensitive/FunctionSummary.h
include/clang/StaticAnalyzer/Core/PathSensitive/MemRegion.h
include/clang/StaticAnalyzer/Core/PathSensitive/ObjCMessage.h
include/clang/StaticAnalyzer/Core/PathSensitive/ProgramState.h
include/clang/StaticAnalyzer/Core/PathSensitive/ProgramStateTrait.h
+include/clang/StaticAnalyzer/Core/PathSensitive/ProgramState_Fwd.h
include/clang/StaticAnalyzer/Core/PathSensitive/SValBuilder.h
include/clang/StaticAnalyzer/Core/PathSensitive/SVals.h
include/clang/StaticAnalyzer/Core/PathSensitive/Store.h
@@ -330,15 +342,20 @@ include/clang/StaticAnalyzer/Core/PathSensitive/StoreRef.h
include/clang/StaticAnalyzer/Core/PathSensitive/SubEngine.h
include/clang/StaticAnalyzer/Core/PathSensitive/SummaryManager.h
include/clang/StaticAnalyzer/Core/PathSensitive/SymbolManager.h
+include/clang/StaticAnalyzer/Core/PathSensitive/TaintManager.h
+include/clang/StaticAnalyzer/Core/PathSensitive/TaintTag.h
include/clang/StaticAnalyzer/Core/PathSensitive/WorkList.h
include/clang/StaticAnalyzer/Frontend/CheckerRegistration.h
include/clang/StaticAnalyzer/Frontend/FrontendActions.h
+include/clang/Tooling/CompilationDatabase.h
+include/clang/Tooling/Tooling.h
lib/clang/%%PORTVERSION%%/include/arm_neon.h
lib/clang/%%PORTVERSION%%/include/emmintrin.h
lib/clang/%%PORTVERSION%%/include/immintrin.h
lib/clang/%%PORTVERSION%%/include/mm3dnow.h
lib/clang/%%PORTVERSION%%/include/mm_malloc.h
lib/clang/%%PORTVERSION%%/include/mmintrin.h
+lib/clang/%%PORTVERSION%%/include/module.map
lib/clang/%%PORTVERSION%%/include/nmmintrin.h
lib/clang/%%PORTVERSION%%/include/pmmintrin.h
lib/clang/%%PORTVERSION%%/include/smmintrin.h
@@ -353,9 +370,9 @@ lib/libclangAnalysis.a
lib/libclangBasic.a
lib/libclangCodeGen.a
lib/libclangDriver.a
+lib/libclangEdit.a
lib/libclangFrontend.a
lib/libclangFrontendTool.a
-lib/libclangIndex.a
lib/libclangLex.a
lib/libclangParse.a
lib/libclangRewrite.a
@@ -364,14 +381,17 @@ lib/libclangSerialization.a
lib/libclangStaticAnalyzerCheckers.a
lib/libclangStaticAnalyzerCore.a
lib/libclangStaticAnalyzerFrontend.a
+lib/libclangTooling.a
%%DATADIR%%/scanview.css
%%DATADIR%%/sorttable.js
%%PORTDOCS%%%%DOCSDIR%%/html.tar.gz
+%%PORTDOCS%%%%DOCSDIR%%/html/AddressSanitizer.html
%%PORTDOCS%%%%DOCSDIR%%/html/AnalyzerRegions.html
%%PORTDOCS%%%%DOCSDIR%%/html/AutomaticReferenceCounting.html
%%PORTDOCS%%%%DOCSDIR%%/html/DriverInternals.html
%%PORTDOCS%%%%DOCSDIR%%/html/InternalsManual.html
%%PORTDOCS%%%%DOCSDIR%%/html/LanguageExtensions.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ObjectiveCLiterals.html
%%PORTDOCS%%%%DOCSDIR%%/html/PCHInternals.html
%%PORTDOCS%%%%DOCSDIR%%/html/PTHInternals.html
%%PORTDOCS%%%%DOCSDIR%%/html/ReleaseNotes.html
@@ -389,6 +409,7 @@ lib/libclangStaticAnalyzerFrontend.a
@dirrm lib/clang/%%PORTVERSION%%/include
@dirrm lib/clang/%%PORTVERSION%%
@dirrm lib/clang
+@dirrm include/clang/Tooling
@dirrm include/clang/StaticAnalyzer/Frontend
@dirrm include/clang/StaticAnalyzer/Core/PathSensitive
@dirrm include/clang/StaticAnalyzer/Core/BugReporter
@@ -400,10 +421,11 @@ lib/libclangStaticAnalyzerFrontend.a
@dirrm include/clang/Rewrite
@dirrm include/clang/Parse
@dirrm include/clang/Lex
-@dirrm include/clang/Index
@dirrm include/clang/FrontendTool
@dirrm include/clang/Frontend
+@dirrm include/clang/Edit
@dirrm include/clang/Driver
+@dirrm include/clang/Config
@dirrm include/clang/CodeGen
@dirrm include/clang/Basic
@dirrm include/clang/Analysis/Visitors