aboutsummaryrefslogtreecommitdiff
path: root/lang/clang
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2013-05-22 21:56:53 +0000
committerBrooks Davis <brooks@FreeBSD.org>2013-05-22 21:56:53 +0000
commit52a5054a99435ac54b7e3beab7a111ddceeb5f6b (patch)
tree98f0d298831c1c29f9c21334beb4c941748ebdb8 /lang/clang
parente6d37282b224b4e5170cca57cf25e682c389ab02 (diff)
Install a more complete set of intrinsics header files[0].
Add a couple upstream svn revs that have been comitted to base[1]: r172354: Refactor the x86 CPU name logic in the driver and pass -march and -mcpu flag information down from the Clang driver into the Gold linker plugin for LTO. This allows specifying -march on the linker commandline and should hopefully have it pass all the way through to the LTO optimizer. r175919: Driver: Pass down the -march setting down to -cc1as on x86 too. The assembler historically didn't make use of any target features, but this has changed when support for old CPUs that don't support long nops was added. Requested by: dim[1], eadler[0]
Notes
Notes: svn path=/head/; revision=318799
Diffstat (limited to 'lang/clang')
-rw-r--r--lang/clang/Makefile17
1 files changed, 16 insertions, 1 deletions
diff --git a/lang/clang/Makefile b/lang/clang/Makefile
index b6845ccad5e4..9f5cbf438aca 100644
--- a/lang/clang/Makefile
+++ b/lang/clang/Makefile
@@ -7,7 +7,7 @@
PORTNAME= clang
PORTVERSION= 3.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang devel
MASTER_SITES= http://llvm.org/releases/${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
@@ -180,4 +180,19 @@ build-plist:
${SED} -e 's|${DATADIR}|@dirrm %%DATADIR%%|' \
-e 's|${DOCSDIR}|%%PORTDOCS%%@dirrm %%DOCSDIR%%|' >> ${PLIST}
+.if make(svn-patch)
+.if !defined(PATCH_REV)
+.error svn-patch requires that PATCH_REV be set
+.endif
+_PATCH_FILE=${FILESDIR}/patch-svn-${PATCH_REV}
+_LLVM_BASE=http://llvm.org/svn/llvm-project/cfe/trunk
+svn-patch:
+ printf "$$%s$$\n" FreeBSD > ${_PATCH_FILE}
+ svn log -c ${PATCH_REV} ${_LLVM_BASE} >> ${_PATCH_FILE}
+ svn diff -c ${PATCH_REV} ${_LLVM_BASE} | \
+ sed -e 's;^--- ;--- tools/clang/;' | \
+ sed -e 's;^+++ ;+++ tools/clang/;' >> \
+ ${_PATCH_FILE}
+.endif
+
.include <bsd.port.post.mk>