aboutsummaryrefslogtreecommitdiff
path: root/lang/cling/files
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2017-01-03 08:06:59 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2017-01-03 08:06:59 +0000
commitb4fa50f637e8b7a7033f8f5e6481e22b877cd884 (patch)
tree3298201f8216e9e9baaf38b431e74b0e9099bd84 /lang/cling/files
parent6f019c90b38cefb0b798496384e88067b3bb87a9 (diff)
downloadports-b4fa50f637e8b7a7033f8f5e6481e22b877cd884.tar.gz
ports-b4fa50f637e8b7a7033f8f5e6481e22b877cd884.zip
Notes
Diffstat (limited to 'lang/cling/files')
-rw-r--r--lang/cling/files/llvm-wrapper.sh.in10
-rw-r--r--lang/cling/files/patch-projects_CMakeLists.txt13
-rw-r--r--lang/cling/files/patch-tools_cling_lib_Interpreter_CIFactory.cpp13
-rw-r--r--lang/cling/files/patch-tools_cling_tools_driver_cling.cpp11
4 files changed, 47 insertions, 0 deletions
diff --git a/lang/cling/files/llvm-wrapper.sh.in b/lang/cling/files/llvm-wrapper.sh.in
new file mode 100644
index 000000000000..0a460f3156e5
--- /dev/null
+++ b/lang/cling/files/llvm-wrapper.sh.in
@@ -0,0 +1,10 @@
+#!/bin/sh
+# $FreeBSD$
+
+LLVM_PREFIX="%%LLVM_PREFIX%%"
+LLVM_SUFFIX="%%LLVM_SUFFIX%%"
+
+tool=$(basename $0)
+tool="${LLVM_PREFIX}/bin/${tool%${LLVM_SUFFIX}}"
+LD_LIBRARY_PATH="${LD_LIBRARY_PATH:+${LD_LIBRARY_PATH}:}${LLVM_PREFIX}/lib" \
+ "${tool}" "${@}"
diff --git a/lang/cling/files/patch-projects_CMakeLists.txt b/lang/cling/files/patch-projects_CMakeLists.txt
new file mode 100644
index 000000000000..e5427434d088
--- /dev/null
+++ b/lang/cling/files/patch-projects_CMakeLists.txt
@@ -0,0 +1,13 @@
+--- projects/CMakeLists.txt.orig 2017-01-01 11:36:50 UTC
++++ projects/CMakeLists.txt
+@@ -25,7 +25,9 @@ if(${LLVM_BUILD_RUNTIME})
+ # first.
+ add_llvm_external_project(libcxxabi)
+ add_llvm_external_project(libcxx)
+- add_llvm_external_project(libunwind)
++ if(FALSE)
++ add_llvm_external_project(libunwind)
++ endif()
+ endif()
+ if(NOT LLVM_BUILD_EXTERNAL_COMPILER_RT)
+ add_llvm_external_project(compiler-rt)
diff --git a/lang/cling/files/patch-tools_cling_lib_Interpreter_CIFactory.cpp b/lang/cling/files/patch-tools_cling_lib_Interpreter_CIFactory.cpp
new file mode 100644
index 000000000000..35b52819aa0d
--- /dev/null
+++ b/lang/cling/files/patch-tools_cling_lib_Interpreter_CIFactory.cpp
@@ -0,0 +1,13 @@
+--- tools/cling/lib/Interpreter/CIFactory.cpp.orig 2016-12-29 13:54:44 UTC
++++ tools/cling/lib/Interpreter/CIFactory.cpp
+@@ -307,8 +307,8 @@ namespace {
+ // Note: On FreeBSD it uses getprogpath().
+ // Note: Otherwise it uses dladdr().
+ //
+- resourcePath
+- = CompilerInvocation::GetResourcesPath("cling",
++ resourcePath = CompilerInvocation::GetResourcesPath(
++ "%%LLVM_PREFIX%%/bin/cling",
+ (void*)intptr_t(GetExecutablePath));
+ } else {
+ llvm::SmallString<512> tmp(llvmdir);
diff --git a/lang/cling/files/patch-tools_cling_tools_driver_cling.cpp b/lang/cling/files/patch-tools_cling_tools_driver_cling.cpp
new file mode 100644
index 000000000000..061411d0390b
--- /dev/null
+++ b/lang/cling/files/patch-tools_cling_tools_driver_cling.cpp
@@ -0,0 +1,11 @@
+--- tools/cling/tools/driver/cling.cpp.orig 2016-12-29 13:54:45 UTC
++++ tools/cling/tools/driver/cling.cpp
+@@ -51,7 +51,7 @@ int main( int argc, char **argv ) {
+ #endif
+
+ // Set up the interpreter
+- cling::Interpreter interp(argc, argv);
++ cling::Interpreter interp(argc, argv, "%%LLVM_PREFIX%%/");
+ if (interp.getOptions().Help) {
+ return 0;
+ }