aboutsummaryrefslogtreecommitdiff
path: root/lang/clisp
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2005-09-04 04:49:53 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2005-09-04 04:49:53 +0000
commit3da2ba016456d171884458150450e2a399b9c034 (patch)
tree566d6c976b65800bcb9df3e2bec126dd0a13ef0b /lang/clisp
parent3c1afd3073beed476aa79ca5e02537d31a853fc2 (diff)
downloadports-3da2ba016456d171884458150450e2a399b9c034.tar.gz
ports-3da2ba016456d171884458150450e2a399b9c034.zip
Notes
Diffstat (limited to 'lang/clisp')
-rw-r--r--lang/clisp/Makefile21
-rw-r--r--lang/clisp/distinfo4
-rw-r--r--lang/clisp/files/patch-makemake.in11
-rw-r--r--lang/clisp/pkg-descr35
-rw-r--r--lang/clisp/pkg-plist17
5 files changed, 44 insertions, 44 deletions
diff --git a/lang/clisp/Makefile b/lang/clisp/Makefile
index 5baaa316b930..d129af07144e 100644
--- a/lang/clisp/Makefile
+++ b/lang/clisp/Makefile
@@ -6,14 +6,15 @@
#
PORTNAME= clisp
-PORTVERSION= 2.33.2
-PORTREVISION= 1
+PORTVERSION= 2.35
CATEGORIES= lang lisp
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR=${PORTNAME}/release/${PORTVERSION}
MAINTAINER= jakub@rehor.net
-COMMENT= An ANSI Common Lisp
+COMMENT= A Common Lisp implementation
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libsigsegv.a:${PORTSDIR}/devel/libsigsegv
USE_BZIP2= yes
USE_ICONV= yes
@@ -23,19 +24,13 @@ USE_GETTEXT= yes
# Build subdirectory
BUILD_DIRNAME=${CONFIGURE_TARGET}
-# Check ./configure --help in the distribution to see all modules
-MAKEMAKE_ARGS=--prefix=${PREFIX} --with-readline --with-gettext \
- --with-dynamic-ffi --with-module=regexp --with-export-syscalls
+# Check ./configure --list-modules in the distribution to see all modules
+MAKEMAKE_ARGS=--prefix=${PREFIX} --mandir=${PREFIX}/man --with-dynamic-ffi \
+ --with-module=rawsock --with-module=wildcard \
+ --with-module=clx/new-clx --srcdir=${WRKSRC}/src
.include <bsd.port.pre.mk>
-# Does not compile on 64-bit architectures
-# See http://sourceforge.net/mailarchive/message.php?msg_id=7103089
-# for discussion.
-.if ${ARCH} == "alpha" || ${ARCH} == "ia64" || ${ARCH} == "amd64" || ${ARCH} == "sparc64"
-BROKEN= "Does not compile on 64-bit architectures"
-.endif
-
# The source doesn't include a top-level Makefile, so we'll fake one.
post-extract:
@cd ${WRKSRC} && \
diff --git a/lang/clisp/distinfo b/lang/clisp/distinfo
index 94fe20e70e06..f8003e2efb5d 100644
--- a/lang/clisp/distinfo
+++ b/lang/clisp/distinfo
@@ -1,2 +1,2 @@
-MD5 (clisp-2.33.2.tar.bz2) = ee4ea316db1e843dcb16094bf500012f
-SIZE (clisp-2.33.2.tar.bz2) = 6091273
+MD5 (clisp-2.35.tar.bz2) = a8e3136c4ecfb5deb65fe53e22ca2c07
+SIZE (clisp-2.35.tar.bz2) = 7902817
diff --git a/lang/clisp/files/patch-makemake.in b/lang/clisp/files/patch-makemake.in
deleted file mode 100644
index ac2db5c42f00..000000000000
--- a/lang/clisp/files/patch-makemake.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/makemake.in.orig Thu May 27 10:43:39 2004
-+++ src/makemake.in Tue Feb 15 21:23:34 2005
-@@ -1550,7 +1550,7 @@
- echol "exec_prefix = ${EXEC_PREFIX}"
- echol "bindir = \$(exec_prefix)${NEXT_}bin"
- echol "shared = \$(prefix)${NEXT_}share"
--echol "mandir = \$(shared)${NEXT_}man"
-+echol "mandir = \$(prefix)${NEXT_}man"
- echol "docdir = \$(shared)${NEXT_}doc"
- case "$fsstnd" in
- suse)
diff --git a/lang/clisp/pkg-descr b/lang/clisp/pkg-descr
index 03fd2a160b9e..eabf485d70d9 100644
--- a/lang/clisp/pkg-descr
+++ b/lang/clisp/pkg-descr
@@ -1,23 +1,24 @@
-Common Lisp is a high-level, all-purpose, object-oriented, dynamic,
-functional programming language.
+ANSI Common Lisp is a high-level, general-purpose programming language.
+GNU CLISP is a Common Lisp implementation by Bruno Haible of Karlsruhe
+University and Michael Stoll of Munich University, both in Germany.
+It mostly supports the Lisp described in the ANSI Common Lisp standard.
+It runs on most Unix workstations (GNU/Linux, FreeBSD, NetBSD, OpenBSD,
+Solaris, Tru64, HP-UX, BeOS, NeXTstep, IRIX, AIX and others) and on
+other systems (Windows NT/2000/XP, Windows 95/98/ME) and needs only
+4 MB of RAM.
-CLISP is a Common Lisp implementation by Bruno Haible of Karlsruhe
-University and Michael Stoll of Munich University, both in Germany. It
-mostly supports the Lisp described in the ANSI Common Lisp standard.
+It is Free Software and may be distributed under the terms of GNU GPL,
+while it is possible to distribute commercial proprietary applications
+compiled with GNU CLISP.
-CLISP includes an interpreter, a compiler, a large subset of CLOS, a
-foreign language interface and a socket interface. An X11 interface is
-available through CLX and Garnet. Command line editing is provided by
-readline.
+The user interface comes in English, German, French, Spanish, Dutch,
+Russian and Danish, and can be changed at run time.
-CLISP is free software and may be distributed under the terms of GNU
-GPL. You may distribute commercial applications compiled with CLISP,
-see file COPYRIGHT in the CLISP distribution.
-
-The user interface comes in German, English, French and Spanish, and
-can be changed at run time.
-
-WWW: http://clisp.sourceforge.net/
+GNU CLISP includes an interpreter, a compiler, a debugger, CLOS, MOP,
+a foreign language interface, sockets, i18n, fast bignums and more.
+An X11 interface is available through CLX, Garnet, CLUE/CLIO.
+GNU CLISP runs Maxima, ACL2 and many other Common Lisp packages.
+WWW: http://clisp.cons.org/
- Jakub Rehor
jakub@rehor.net
diff --git a/lang/clisp/pkg-plist b/lang/clisp/pkg-plist
index e946c7eca750..67ef480d659d 100644
--- a/lang/clisp/pkg-plist
+++ b/lang/clisp/pkg-plist
@@ -1,4 +1,6 @@
bin/clisp
+lib/clisp/base/calls.o
+lib/clisp/base/gettext.o
lib/clisp/base/libavcall.a
lib/clisp/base/libcallback.a
lib/clisp/base/libcharset.a
@@ -9,9 +11,15 @@ lib/clisp/base/lispinit.mem
lib/clisp/base/makevars
lib/clisp/base/modules.h
lib/clisp/base/modules.o
+lib/clisp/base/regex.o
+lib/clisp/base/regexi.o
+lib/clisp/base/regexp.dvi
lib/clisp/clisp-link
lib/clisp/data/UnicodeDataFull.txt
lib/clisp/data/clhs.txt
+lib/clisp/full/calls.o
+lib/clisp/full/clx.o
+lib/clisp/full/gettext.o
lib/clisp/full/libavcall.a
lib/clisp/full/libcallback.a
lib/clisp/full/libcharset.a
@@ -22,10 +30,13 @@ lib/clisp/full/lispinit.mem
lib/clisp/full/makevars
lib/clisp/full/modules.h
lib/clisp/full/modules.o
+lib/clisp/full/rawsock.o
+lib/clisp/full/regex.o
lib/clisp/full/regexi.o
lib/clisp/full/regexp.dvi
+lib/clisp/full/wildcard.dvi
+lib/clisp/full/wildcard.o
lib/clisp/linkkit/clisp.h
-lib/clisp/linkkit/exporting.lisp
lib/clisp/linkkit/modprep.lisp
lib/clisp/linkkit/modules.c
lib/clisp/linkkit/modules.d
@@ -40,6 +51,7 @@ lib/clisp/linkkit/modules.d
%%PORTDOCS%%%%DOCSDIR%%/SUMMARY
%%PORTDOCS%%%%DOCSDIR%%/clisp.dvi
%%PORTDOCS%%%%DOCSDIR%%/clisp.html
+%%PORTDOCS%%%%DOCSDIR%%/clisp.pdf
%%PORTDOCS%%%%DOCSDIR%%/clisp.ps
%%PORTDOCS%%%%DOCSDIR%%/doc/CLOS-guide.txt
%%PORTDOCS%%%%DOCSDIR%%/doc/LISP-tutorial.txt
@@ -47,10 +59,13 @@ lib/clisp/linkkit/modules.d
%%PORTDOCS%%%%DOCSDIR%%/doc/clisp.dvi
%%PORTDOCS%%%%DOCSDIR%%/doc/clisp.html
%%PORTDOCS%%%%DOCSDIR%%/doc/clisp.png
+%%PORTDOCS%%%%DOCSDIR%%/doc/clisp.pdf
%%PORTDOCS%%%%DOCSDIR%%/doc/clisp.ps
%%PORTDOCS%%%%DOCSDIR%%/doc/editors.txt
%%PORTDOCS%%%%DOCSDIR%%/doc/impnotes.css
%%PORTDOCS%%%%DOCSDIR%%/doc/impnotes.html
+share/locale/da/LC_MESSAGES/clisp.mo
+share/locale/da/LC_MESSAGES/clisplow.mo
share/locale/de/LC_MESSAGES/clisp.mo
share/locale/de/LC_MESSAGES/clisplow.mo
share/locale/en/LC_MESSAGES/clisp.mo