aboutsummaryrefslogtreecommitdiff
path: root/lang/clojure
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2007-10-21 02:49:51 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2007-10-21 02:49:51 +0000
commit6410bf15596daa3f4320fea14d5dcb1f0c1697f1 (patch)
treefd3edf7975d33cd43608a8c38009993a14b008a7 /lang/clojure
parent802d08b8a13752fa7251013ab991707aa9556944 (diff)
downloadports-6410bf15596daa3f4320fea14d5dcb1f0c1697f1.tar.gz
ports-6410bf15596daa3f4320fea14d5dcb1f0c1697f1.zip
Notes
Diffstat (limited to 'lang/clojure')
-rw-r--r--lang/clojure/Makefile31
-rw-r--r--lang/clojure/distinfo3
-rw-r--r--lang/clojure/files/clojure.in5
-rw-r--r--lang/clojure/pkg-descr18
-rw-r--r--lang/clojure/pkg-plist4
5 files changed, 61 insertions, 0 deletions
diff --git a/lang/clojure/Makefile b/lang/clojure/Makefile
new file mode 100644
index 000000000000..e2348794567f
--- /dev/null
+++ b/lang/clojure/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# Ports collection makefile for: clojure
+# Date created: Oct 21. 2007
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= clojure
+PORTVERSION= 20071020
+CATEGORIES= lang lisp java
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= ijliao@FreeBSD.org
+COMMENT= A dynamic programming language for the JVM
+
+USE_ZIP= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.5+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+SUB_FILES= clojure
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/clojure ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/clojure.jar ${JAVAJARDIR}
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKDIR}/src/boot.clj ${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/lang/clojure/distinfo b/lang/clojure/distinfo
new file mode 100644
index 000000000000..f3d232c1a842
--- /dev/null
+++ b/lang/clojure/distinfo
@@ -0,0 +1,3 @@
+MD5 (clojure_20071020.zip) = 4813d4eff1e6b2ceefa737baf652eb98
+SHA256 (clojure_20071020.zip) = 2cc381fe33a0a10d93efc94c4901ac58a93529e9992e37306d49b843c9d6489e
+SIZE (clojure_20071020.zip) = 547090
diff --git a/lang/clojure/files/clojure.in b/lang/clojure/files/clojure.in
new file mode 100644
index 000000000000..e3bd1c6ce8b4
--- /dev/null
+++ b/lang/clojure/files/clojure.in
@@ -0,0 +1,5 @@
+#!/bin/sh
+#
+# $FreeBSD$
+
+JAVA_VERSION="1.5+" "%%LOCALBASE%%/bin/java" -cp "%%JAVAJARDIR%%/clojure.jar" clojure.lang.Compiler %%DATADIR%%/boot.clj
diff --git a/lang/clojure/pkg-descr b/lang/clojure/pkg-descr
new file mode 100644
index 000000000000..c6d1548bc0ee
--- /dev/null
+++ b/lang/clojure/pkg-descr
@@ -0,0 +1,18 @@
+Clojure is a dynamic programming language that targets the Java Virtual
+Machine. It is designed to be a general-purpose language, combining the
+approachability and interactive development of a scripting language with
+an efficient and robust infrastructure for multithreaded programming.
+Clojure is a compiled language - it compiles directly to JVM bytecode,
+yet remains completely dynamic. Every feature supported by Clojure is
+supported at runtime. Clojure provides easy access to the Java frameworks,
+with optional type hints and type inference, to ensure that calls to Java
+can avoid reflection.
+
+Clojure is a dialect of Lisp, and shares with Lisp the code-as-data
+philosophy and a powerful macro system. Clojure is predominantly a
+functional programming language, and features a rich set of immutable,
+persistent data structures. When mutable state is needed, Clojure offers a
+software transactional memory system that ensures clean, correct,
+multithreaded designs.
+
+WWW: http://clojure.sourceforge.net/
diff --git a/lang/clojure/pkg-plist b/lang/clojure/pkg-plist
new file mode 100644
index 000000000000..af4e7f84c978
--- /dev/null
+++ b/lang/clojure/pkg-plist
@@ -0,0 +1,4 @@
+bin/clojure
+%%JAVAJARDIR%%/clojure.jar
+%%DATADIR%%/boot.clj
+@dirrm %%DATADIR%%