aboutsummaryrefslogtreecommitdiff
path: root/lang/clover
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-09-17 18:07:25 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-09-17 18:07:25 +0000
commit05360ec71eab4f178074bd97c1373e7659a59bbb (patch)
treea430ad3dbd823ddb88d16ecc11a7a7035985cf79 /lang/clover
parent7bc4660db0fb55cc34f11c9263904d676fc7445b (diff)
Notes
Diffstat (limited to 'lang/clover')
-rw-r--r--lang/clover/Makefile39
-rw-r--r--lang/clover/pkg-descr5
-rw-r--r--lang/clover/pkg-plist9
3 files changed, 53 insertions, 0 deletions
diff --git a/lang/clover/Makefile b/lang/clover/Makefile
new file mode 100644
index 000000000000..31268c07c86d
--- /dev/null
+++ b/lang/clover/Makefile
@@ -0,0 +1,39 @@
+# $FreeBSD$
+
+PORTNAME= clover
+PORTVERSION= ${MESAVERSION}
+PORTREVISION= 0
+CATEGORIES= lang
+
+COMMENT= Mesa "Clover" OpenCL library
+
+BUILD_DEPENDS= opencl>=0:${PORTSDIR}/devel/opencl
+LIB_DEPENDS= libdrm.so:${PORTSDIR}/graphics/libdrm \
+ libOpenCL.so:${PORTSDIR}/devel/ocl-icd \
+ libexpat.so:${PORTSDIR}/textproc/expat2
+RUN_DEPENDS= opencl>=0:${PORTSDIR}/devel/opencl
+
+USE_XORG= glproto x11 xext xxf86vm xdamage xfixes dri2proto \
+ presentproto xvmc xshmfence
+
+ONLY_FOR_ARCHS= i386 amd64 powerpc64
+ONLY_FOR_ARCHS_REASON= Clover needs a graphics driver supported by the Radeon KMS driver
+
+.include <bsd.port.options.mk>
+.include "${.CURDIR}/../../graphics/libGL/Makefile.common"
+
+#MESA_BUILD_WRKSRC= src/util src/glsl src/mesa src/gallium
+MESA_INSTALL_WRKSRC= src/gallium/targets/opencl src/gallium/targets/pipe-loader
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1001514 && ${ARCH} == powerpc64
+IGNORE= Clover is only support on powerpc64 in FreeBSD 10.2
+.elif ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000 && ${ARCH} != powerpc64
+IGNORE= Clover is only supported on FreeBSD 10.1 and newer
+.endif
+
+.include "${.CURDIR}/../../graphics/libGL/Makefile.targets"
+
+post-install:
+ @${MV} ${STAGEDIR}/etc/OpenCL ${STAGEDIR}${PREFIX}/etc/
+
+.include <bsd.port.mk>
diff --git a/lang/clover/pkg-descr b/lang/clover/pkg-descr
new file mode 100644
index 000000000000..0385eee7880f
--- /dev/null
+++ b/lang/clover/pkg-descr
@@ -0,0 +1,5 @@
+This package contains the Mesa "Clover" libOpenCL implementation. This
+implementation is build onto GALLIUM and as such can only be used on Radeon
+cards.
+
+WWW: http://dri.freedesktop.org/wiki/GalliumCompute/
diff --git a/lang/clover/pkg-plist b/lang/clover/pkg-plist
new file mode 100644
index 000000000000..5686603b7ee4
--- /dev/null
+++ b/lang/clover/pkg-plist
@@ -0,0 +1,9 @@
+etc/OpenCL/vendors/mesa.icd
+lib/gallium-pipe/pipe_r300.so
+lib/gallium-pipe/pipe_r600.so
+lib/gallium-pipe/pipe_radeonsi.so
+lib/gallium-pipe/pipe_swrast.so
+lib/gallium-pipe/pipe_vmwgfx.so
+lib/libMesaOpenCL.so
+lib/libMesaOpenCL.so.1
+lib/libMesaOpenCL.so.1.0.0