aboutsummaryrefslogtreecommitdiff
path: root/lang/clover
diff options
context:
space:
mode:
authorEmmanuel Vadot <manu@FreeBSD.org>2020-06-05 09:13:57 +0000
committerEmmanuel Vadot <manu@FreeBSD.org>2020-06-05 09:13:57 +0000
commit899ab84a708e6a1eb0ddd9430f10f317ab26ea8d (patch)
tree46dc34f96239ee7dda64716539c2d7c64bf533f8 /lang/clover
parentae49030f4bd5b6f837f3770d9b8656a006271a52 (diff)
Notes
Diffstat (limited to 'lang/clover')
-rw-r--r--lang/clover/Makefile29
-rw-r--r--lang/clover/pkg-plist1
2 files changed, 22 insertions, 8 deletions
diff --git a/lang/clover/Makefile b/lang/clover/Makefile
index 77f39abce652..541823ae4422 100644
--- a/lang/clover/Makefile
+++ b/lang/clover/Makefile
@@ -18,18 +18,31 @@ ONLY_FOR_ARCHS_REASON= Clover needs a GPU supported by the Radeon KMS driver
.include <bsd.port.options.mk>
.include "${.CURDIR:H:H}/graphics/mesa-dri/Makefile.common"
-CONFIGURE_ARGS+= --enable-opencl --enable-opencl-icd --disable-dri \
- --disable-egl --disable-gbm --disable-gles2 --disable-glx \
- --disable-va --disable-vdpau --disable-xvmc \
- --with-gallium-drivers=r600,radeonsi # only supported GPUs
-LDFLAGS_i386= -Wl,-znotext
+MESON_ARGS+= -Ddri-drivers="" \
+ -Dgallium-drivers=r600,radeonsi \
+ -Dvulkan-drivers="" \
+ -Dplatforms="" \
+ -Dgallium-vdpau=false \
+ -Dgallium-omx=disabled \
+ -Dgallium-va=false \
+ -Dgallium-opencl=disabled \
+ -Dgallium-xa=false \
+ -Dgallium-xvmc=false \
+ -Dgallium-nine=false \
+ -Dgles1=false \
+ -Dgles2=false \
+ -Dopengl=false \
+ -Dglx=disabled \
+ -Degl=false \
+ -Dgbm=false \
+ -Dgallium-opencl=icd \
+ -Dtools=""
-#MESA_BUILD_WRKSRC= src/util src/compiler src/mesa src/gallium
-MESA_INSTALL_WRKSRC= src/gallium/targets/opencl src/gallium/targets/pipe-loader
+LDFLAGS_i386= -Wl,-znotext
.include "${MASTERDIR}/Makefile.targets"
-pre-configure:
+pre-patch:
@if [ -e ${LOCALBASE}/bin/llvm-config${LLVM_DEFAULT} ] && \
! [ -e ${LOCALBASE}/bin/clang${LLVM_DEFAULT} ]; then \
${ECHO_MSG} "Your llvm${LLVM_DEFAULT} is not built with clang support, which is required."; \
diff --git a/lang/clover/pkg-plist b/lang/clover/pkg-plist
index eb9d5242ea4b..7625534c598f 100644
--- a/lang/clover/pkg-plist
+++ b/lang/clover/pkg-plist
@@ -4,3 +4,4 @@ lib/gallium-pipe/pipe_radeonsi.so
lib/libMesaOpenCL.so
lib/libMesaOpenCL.so.1
lib/libMesaOpenCL.so.1.0.0
+@comment share/drirc.d/00-mesa-defaults.conf