aboutsummaryrefslogtreecommitdiff
path: root/lang/cmucl/Makefile
diff options
context:
space:
mode:
authorMartin Cracauer <cracauer@FreeBSD.org>1997-07-15 14:35:20 +0000
committerMartin Cracauer <cracauer@FreeBSD.org>1997-07-15 14:35:20 +0000
commite79ebfe1e0e19597c2acc748c6d3cd7f5657a667 (patch)
tree36dfd85ad14d9e5f4f4eba1dd9f8726b7863c45d /lang/cmucl/Makefile
parentba6a1f2759c71b250b9411a86f5f081b58b2e638 (diff)
downloadports-e79ebfe1e0e19597c2acc748c6d3cd7f5657a667.tar.gz
ports-e79ebfe1e0e19597c2acc748c6d3cd7f5657a667.zip
Notes
Diffstat (limited to 'lang/cmucl/Makefile')
-rw-r--r--lang/cmucl/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/lang/cmucl/Makefile b/lang/cmucl/Makefile
new file mode 100644
index 000000000000..f8be05ad1aea
--- /dev/null
+++ b/lang/cmucl/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: CMUCL
+# Version required: 18a
+# Date created: Jul, 15, 1997
+# Whom: cracauer@cons.org "Martin Cracauer"
+#
+# $Id: Makefile,v 1.5 1997/07/15 13:35:10 cracauer Exp $
+#
+#
+
+DISTNAME= cmucl-18a.x86.FreeBSD21
+PKGNAME= cmucl-18a
+CATEGORIES= lang
+MASTER_SITES= ftp://ftp2.cons.org/pub/languages/lisp/cmucl/binaries/
+
+MAINTAINER= cracauer@cons.org
+
+NO_CONFIGURE= yes
+NO_BUILD= yes
+MAN1= lisp.1 cmucl.1
+
+do-install:
+ ${INSTALL} -c -o ${BINOWN} -g ${BINGRP} work/bin/lisp ${PREFIX}/bin
+ -$(MKDIR) ${PREFIX}/lib/cmucl
+ (cd work && tar fc - lib) | (cd ${PREFIX}/lib/cmucl && tar fx -)
+ ${INSTALL} -c -o ${BINOWN} -g ${BINGRP} work/README.1st \
+ ${PREFIX}/lib/cmucl
+ ${INSTALL} -c -o ${BINOWN} -g ${BINGRP} work/man/man1/cmucl.1 \
+ ${PREFIX}/man/man1
+ ${INSTALL} -c -o ${BINOWN} -g ${BINGRP} work/man/man1/lisp.1 \
+ ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
+