aboutsummaryrefslogtreecommitdiff
path: root/lang/cmucl
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-10-04 01:25:18 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-10-04 01:25:18 +0000
commit5555d89b50c7710cb97fb22ca6af251e6404e404 (patch)
tree700b4c9a8ec0af3f2f98ea0c4dc852268cc67aaf /lang/cmucl
parent42b9878de05e3fd31b1537c7fb21ea8d4260e335 (diff)
downloadports-5555d89b50c7710cb97fb22ca6af251e6404e404.tar.gz
ports-5555d89b50c7710cb97fb22ca6af251e6404e404.zip
Remove always-false/true conditions based on OSVERSION 500000
Notes
Notes: svn path=/head/; revision=200774
Diffstat (limited to 'lang/cmucl')
-rw-r--r--lang/cmucl/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/lang/cmucl/Makefile b/lang/cmucl/Makefile
index be331c898d4f..f2ea9fb76766 100644
--- a/lang/cmucl/Makefile
+++ b/lang/cmucl/Makefile
@@ -19,6 +19,8 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-x86-FreeBSD
MAINTAINER= cracauer@cons.org
COMMENT= The CMU implementation of Common Lisp
+LIB_DEPENDS= c.4:${PORTSDIR}/misc/compat4x
+
# To make available on other archs, has to be cross-compiled (there is a
# script for this, but a configuration file has to be written).
IA32_BINARY_PORT= yes
@@ -29,13 +31,6 @@ MAN1= lisp.1 cmucl.1
PLIST_SUB= VER=${PORTVERSION}
-.include <bsd.port.pre.mk>
-
-# portlint wants this earlier but this doesn't work because weneed OSVERSION
-.if ${OSVERSION} >= 500000
-LIB_DEPENDS+= c.4:${PORTSDIR}/misc/compat4x
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKDIR}/bin/lisp ${PREFIX}/bin
cd ${WRKDIR} && ${FIND} lib | \
@@ -47,4 +42,4 @@ do-install:
${INSTALL_DATA} ${WRKDIR}/doc/cmucl/* ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>