aboutsummaryrefslogtreecommitdiff
path: root/lang/crystal/Makefile
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-08-02 13:30:40 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-08-02 13:30:40 +0000
commitf18538b989095df1895337d776faf103f4057d83 (patch)
treee12f88296b60e412fef69c80307407d6d19ae370 /lang/crystal/Makefile
parentb9b8e8725edab0e3004502717af99eb74b418b09 (diff)
Notes
Diffstat (limited to 'lang/crystal/Makefile')
-rw-r--r--lang/crystal/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/lang/crystal/Makefile b/lang/crystal/Makefile
index 35c4deb569be..4de0cdd2674d 100644
--- a/lang/crystal/Makefile
+++ b/lang/crystal/Makefile
@@ -2,6 +2,7 @@
PORTNAME= crystal
DISTVERSION= 0.28.0
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= https://unrelentingtech.s3.dualstack.eu-west-1.amazonaws.com/crystal/:bootstrap
DISTFILES= ${BOOTSTRAP_PATH}:bootstrap
@@ -32,6 +33,7 @@ LLVM_VERSION= 60
BOOTSTRAP_PATH= crystal-${BOOTSTRAP_VER}-freebsd${BOOTSTRAP_OSREL}-${ARCH}
BOOTSTRAP_VER?= 0.27.2
+MAKE_ENV= LD_LIBMAP="libevent-2.1.so.6=libevent-2.1.so.7"
MAKE_ARGS= SHELL=sh \
LLVM_CONFIG="${LOCALBASE}/bin/llvm-config${LLVM_VERSION}" \
FLAGS="--release --no-debug --progress --threads=${MAKE_JOBS_NUMBER}" \