aboutsummaryrefslogtreecommitdiff
path: root/lang/csharp-mode.el/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2006-06-19 10:02:05 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2006-06-19 10:02:05 +0000
commit3d264d251825085e1b19b74b46b53eae5cec5c65 (patch)
treef3c45c98f894fa9755f820f6088f7446cfe2ebb8 /lang/csharp-mode.el/Makefile
parent34ff7dab0c31f4898cc028d834a6355782cc9c93 (diff)
Notes
Diffstat (limited to 'lang/csharp-mode.el/Makefile')
-rw-r--r--lang/csharp-mode.el/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/lang/csharp-mode.el/Makefile b/lang/csharp-mode.el/Makefile
new file mode 100644
index 000000000000..f414a2aebf3d
--- /dev/null
+++ b/lang/csharp-mode.el/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: csharp-mode.el
+# Date created: 19 Jun 2006
+# Whom: Jean-Yves Lefort <jylefort@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= csharp-mode.el
+PORTVERSION= 0.5.0
+CATEGORIES= lang elisp
+MASTER_SITES= http://mfgames.com/linux/releases/
+DISTNAME= ${PORTNAME:S|.el$||}-${PORTVERSION}
+
+MAINTAINER= jylefort@FreeBSD.org
+COMMENT= Emacs/XEmacs major mode for editing C\# source code
+
+USE_BZIP2= yes
+NO_WRKSUBDIR= yes
+
+USE_EMACS= yes
+EMACS_PORT_NAME?= emacs22
+CSHARP_MODE_DIR= ${EMACS_LIBDIR_WITH_VER}/lisp
+
+PLIST_FILES= ${CSHARP_MODE_DIR}/csharp-mode.el \
+ ${CSHARP_MODE_DIR}/csharp-mode.elc
+
+post-patch:
+ @${MV} ${WRKSRC}/csharp-mode-${PORTVERSION}.el ${WRKSRC}/csharp-mode.el
+
+do-build:
+ cd ${WRKSRC} && ${EMACS_CMD} -batch -q -f batch-byte-compile csharp-mode.el
+
+do-install:
+ ${MKDIR} ${PREFIX}/${CSHARP_MODE_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/csharp-mode.* ${PREFIX}/${CSHARP_MODE_DIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>