aboutsummaryrefslogtreecommitdiff
path: root/lang/cython
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-03-15 19:48:19 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-03-15 19:48:19 +0000
commit1e52c09da2fc81a20fafc4109a20fb02709ebcac (patch)
treefaf69007c32635629be9dcd75c50c57653bbfa0a /lang/cython
parentcdb2ba77a0a522bea181269b099c44ad10d058c3 (diff)
- Update to 0.11
PR: 132663 Submitted by: Wen heping <wenheping@gmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=230160
Diffstat (limited to 'lang/cython')
-rw-r--r--lang/cython/Makefile5
-rw-r--r--lang/cython/distinfo6
-rw-r--r--lang/cython/pkg-plist16
3 files changed, 22 insertions, 5 deletions
diff --git a/lang/cython/Makefile b/lang/cython/Makefile
index cc07187a8a1f..0480ead3d80d 100644
--- a/lang/cython/Makefile
+++ b/lang/cython/Makefile
@@ -6,9 +6,10 @@
#
PORTNAME= cython
-PORTVERSION= 0.10.3
+PORTVERSION= 0.11
CATEGORIES= lang python
-MASTER_SITES= http://www.cython.org/
+MASTER_SITES= http://www.cython.org/ \
+ CHEESESHOP
DISTNAME= Cython-${PORTVERSION}
MAINTAINER= wenheping@gmail.com
diff --git a/lang/cython/distinfo b/lang/cython/distinfo
index b99e5567363b..1ffd85dea973 100644
--- a/lang/cython/distinfo
+++ b/lang/cython/distinfo
@@ -1,3 +1,3 @@
-MD5 (Cython-0.10.3.tar.gz) = 684103ed37472d9beef3a38e0d5c431d
-SHA256 (Cython-0.10.3.tar.gz) = a9ac41b270743c067456272a1a0c788008b41f64f388488dfbac54e2a78303b8
-SIZE (Cython-0.10.3.tar.gz) = 2560409
+MD5 (Cython-0.11.tar.gz) = 368364fe8b309dfea19c25fb96008891
+SHA256 (Cython-0.11.tar.gz) = 67c14e87f37b837e11c1f02ea6667744eeb67f3784e4f69a51e6451b502a886a
+SIZE (Cython-0.11.tar.gz) = 3000953
diff --git a/lang/cython/pkg-plist b/lang/cython/pkg-plist
index ad8c8b0bfc4a..dc7e354662a8 100644
--- a/lang/cython/pkg-plist
+++ b/lang/cython/pkg-plist
@@ -1,4 +1,7 @@
bin/cython
+%%PYTHON_SITELIBDIR%%/cython.py
+%%PYTHON_SITELIBDIR%%/cython.pyc
+%%PYTHON_SITELIBDIR%%/cython.pyo
%%PYTHON_SITELIBDIR%%/Cython/__init__.py
%%PYTHON_SITELIBDIR%%/Cython/CodeWriter.py
%%PYTHON_SITELIBDIR%%/Cython/Debugging.py
@@ -30,6 +33,12 @@ bin/cython
%%PYTHON_SITELIBDIR%%/Cython/Compiler/Options.py
%%PYTHON_SITELIBDIR%%/Cython/Compiler/ParseTreeTransforms.py
%%PYTHON_SITELIBDIR%%/Cython/Compiler/Parsing.py
+%%PYTHON_SITELIBDIR%%/Cython/Compiler/Parsing.pxd
+%%PYTHON_SITELIBDIR%%/Cython/Compiler/Parsing.so
+%%PYTHON_SITELIBDIR%%/Cython/Compiler/Scanning.pxd
+%%PYTHON_SITELIBDIR%%/Cython/Compiler/Scanning.so
+%%PYTHON_SITELIBDIR%%/Cython/Compiler/Visitor.pxd
+%%PYTHON_SITELIBDIR%%/Cython/Compiler/Visitor.so
%%PYTHON_SITELIBDIR%%/Cython/Compiler/PyrexTypes.py
%%PYTHON_SITELIBDIR%%/Cython/Compiler/Scanning.py
%%PYTHON_SITELIBDIR%%/Cython/Compiler/StringEncoding.py
@@ -151,6 +160,11 @@ bin/cython
%%PYTHON_SITELIBDIR%%/Cython/Unix/LinuxSystem.pyc
%%PYTHON_SITELIBDIR%%/Cython/Unix/__init__.pyo
%%PYTHON_SITELIBDIR%%/Cython/Unix/LinuxSystem.pyo
+%%PYTHON_SITELIBDIR%%/Cython/Runtime/__init__.py
+%%PYTHON_SITELIBDIR%%/Cython/Runtime/__init__.pyc
+%%PYTHON_SITELIBDIR%%/Cython/Runtime/__init__.pyo
+%%PYTHON_SITELIBDIR%%/Cython/Runtime/refnanny.pyx
+%%PYTHON_SITELIBDIR%%/Cython/Runtime/refnanny.so
%%PYTHON_SITELIBDIR%%/Cython/Plex/__init__.py
%%PYTHON_SITELIBDIR%%/Cython/Plex/Actions.py
%%PYTHON_SITELIBDIR%%/Cython/Plex/DFA.py
@@ -158,6 +172,7 @@ bin/cython
%%PYTHON_SITELIBDIR%%/Cython/Plex/Lexicons.py
%%PYTHON_SITELIBDIR%%/Cython/Plex/Machines.py
%%PYTHON_SITELIBDIR%%/Cython/Plex/Regexps.py
+%%PYTHON_SITELIBDIR%%/Cython/Plex/Scanners.pxd
%%PYTHON_SITELIBDIR%%/Cython/Plex/Scanners.py
%%PYTHON_SITELIBDIR%%/Cython/Plex/test_tm.py
%%PYTHON_SITELIBDIR%%/Cython/Plex/Timing.py
@@ -256,6 +271,7 @@ bin/cython
@dirrm %%PYTHON_SITELIBDIR%%/Cython/Mac
@dirrm %%PYTHON_SITELIBDIR%%/Cython/Unix
@dirrm %%PYTHON_SITELIBDIR%%/Cython/Plex
+@dirrm %%PYTHON_SITELIBDIR%%/Cython/Runtime
@dirrm %%PYTHON_SITELIBDIR%%/Cython/Tests
@dirrm %%PYTHON_SITELIBDIR%%/Cython/Includes
@dirrm %%PYTHON_SITELIBDIR%%/Cython