aboutsummaryrefslogtreecommitdiff
path: root/lang/diveintopython/Makefile
diff options
context:
space:
mode:
authorJohann Visagie <wjv@FreeBSD.org>2002-01-08 10:40:03 +0000
committerJohann Visagie <wjv@FreeBSD.org>2002-01-08 10:40:03 +0000
commit2cc796105536ec8c18cb5250a3daa2c4988a7652 (patch)
tree94b4ccd8aed63f453c432ba2ca77bbcab3fc18e2 /lang/diveintopython/Makefile
parent7577c67e2147e7c1185a9ca814f9d4235e1f2886 (diff)
downloadports-2cc796105536ec8c18cb5250a3daa2c4988a7652.tar.gz
ports-2cc796105536ec8c18cb5250a3daa2c4988a7652.zip
- Install examples to EXAMPLESDIR
- Fix file modes after installation - Bump PORTREVISION PR: 33461 Submitted by: Alan Eldridge <ports@geeksrus.net>
Notes
Notes: svn path=/head/; revision=52756
Diffstat (limited to 'lang/diveintopython/Makefile')
-rw-r--r--lang/diveintopython/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/lang/diveintopython/Makefile b/lang/diveintopython/Makefile
index 4cba33ba3ed5..992b0b5d6965 100644
--- a/lang/diveintopython/Makefile
+++ b/lang/diveintopython/Makefile
@@ -7,6 +7,7 @@
PORTNAME= diveintopython
PORTVERSION= 3.9.1
+PORTREVISION= 1
CATEGORIES= lang python
MASTER_SITES= http://diveintopython.org/download/
DISTNAME= ${PORTNAME}
@@ -42,10 +43,16 @@ do-install:
@ ${MKDIR} ${DIPDLDIR}
@ cd ${WRKSRC} && find *.html *.css images \
| ${CPIO} ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
+ @ cd ${WRKDIR}/py && find * \
+ | ${CPIO} ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
.for format in html html-flat pdf text examples
@ ${INSTALL_DATA} \
${DISTDIR}/${DIST_SUBDIR}/${PORTNAME}-${format}-${VERSIONSTR}.zip \
${DIPDLDIR}
.endfor
+post-install:
+ @ ${CHMOD} -R ${SHAREMODE} ${DOCSDIR} ${EXAMPLESDIR}
+ @ ${CHMOD} -R ugo+X ${DOCSDIR} ${EXAMPLESDIR}
+
.include <bsd.port.mk>