aboutsummaryrefslogtreecommitdiff
path: root/lang/dmd2
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2011-01-03 22:07:48 +0000
committerCy Schubert <cy@FreeBSD.org>2011-01-03 22:07:48 +0000
commit69b11a2379f033d825184f48d733879e962729eb (patch)
tree27782ced9b26b3594d9c6d6ece620b61eb38efcb /lang/dmd2
parentfbea872f25241a3dd0a0f8b284b9eca60341bd0e (diff)
downloadports-69b11a2379f033d825184f48d733879e962729eb.tar.gz
ports-69b11a2379f033d825184f48d733879e962729eb.zip
Notes
Diffstat (limited to 'lang/dmd2')
-rw-r--r--lang/dmd2/Makefile113
-rw-r--r--lang/dmd2/distinfo4
-rw-r--r--lang/dmd2/files/patch-druntime-src-core-stdc-math.d11
-rw-r--r--lang/dmd2/files/patch-phobos-std-c-freebsd-socket.d80
-rw-r--r--lang/dmd2/pkg-descr9
-rw-r--r--lang/dmd2/pkg-plist378
6 files changed, 374 insertions, 221 deletions
diff --git a/lang/dmd2/Makefile b/lang/dmd2/Makefile
index 4b98cb17723d..622bcff37d2d 100644
--- a/lang/dmd2/Makefile
+++ b/lang/dmd2/Makefile
@@ -1,105 +1,92 @@
-# New ports collection makefile for: dmd
-# Date created: November 15 2010
+# New ports collection makefile for: dmd2
+# Date created: November 29 2010
# Whom: Ruben <chromium@hybridsource.org>
#
# $FreeBSD$
#
PORTNAME= dmd
-PORTVERSION= 1.065
+PKGNAMESUFFIX= 2
+PORTVERSION= 2.051
CATEGORIES= lang
MASTER_SITES= http://ftp.digitalmars.com/
-DISTNAME= ${PORTNAME}.${PORTVERSION}
+DISTNAME= dmd.${PORTVERSION}
MAINTAINER= cy@FreeBSD.org
-COMMENT= Official compiler for the D 1.0 programming language
+COMMENT= D 2.0 compiler, not officially validated for FreeBSD
-NO_PACKAGE= Packages are not validation-tested by the developer
ONLY_FOR_ARCHS= i386
USE_ZIP= yes
-MAN1= dmd.1
-MAN5= dmd.conf.5
-PORTDOCS= *.txt html/ phobos/
-WRKSRC= ${WRKDIR}/${PORTNAME}/src/${PORTNAME}
+USE_GMAKE= yes
+MAKEFILE= freebsd.mak
+MAN1= dmd2.1
+MAN5= dmd2.conf.5
+EXAMPLESDIR= ${PREFIX}/share/examples/dmd2
+DOCSDIR= ${PREFIX}/share/doc/dmd2
+PORTDOCS= *.txt druntime/ html/ phobos/
+WRKSRC= ${WRKDIR}/dmd2/src/${PORTNAME}
LICENSE_COMB= multi
-LICENSE= ART10 ZLIB DMD
+LICENSE= ART10 ZLIB DMD BSL
LICENSE_NAME_ZLIB= zlib license
LICENSE_PERMS_ZLIB= ${_LICENSE_PERMS_DEFAULT}
LICENSE_FILE_ZLIB= ${WRKSRC}/../phobos/phoboslicense.txt
-LICENSE_NAME_DMD= digital mars license
-LICENSE_FILE_DMD= ${WRKSRC}/../../license.txt
-LICENSE_PERMS_DMD= no-pkg-mirror auto-accept
-
-OPTIONS= SOURCE "Compile dmd and phobos from source" off
+LICENSE_NAME_DMD= Digital Mars license
+LICENSE_FILE_DMD= ${WRKSRC}/backendlicense.txt
+LICENSE_PERMS_DMD= no-dist-mirror no-dist-sell no-pkg-mirror no-pkg-sell auto-accept
.include <bsd.port.pre.mk>
-MODULEDIR= ${PREFIX}/include/d/phobos
-
-.if defined(WITH_SOURCE)
-MAKEFILE= freebsd.mak
-.else
-NO_BUILD= yes
-PLIST_FILES= bin/dmd.conf
-.endif
+MODULEDIR= ${PREFIX}/include/d/phobos2
post-patch:
-.if defined(WITH_SOURCE)
- @${REINPLACE_CMD} -e "s|gcc|${CC}|" \
- ${WRKSRC}/../phobos/freebsd.mak \
- ${WRKSRC}/../phobos/etc/c/zlib/freebsd.mak \
- ${WRKSRC}/../phobos/internal/gc/freebsd.mak \
- ${WRKSRC}/freebsd.mak
- @${REINPLACE_CMD} -e "s|g++|${CXX}|" \
- ${WRKSRC}/../phobos/freebsd.mak \
- ${WRKSRC}/freebsd.mak
+ @${REINPLACE_CMD} -e "s|gcc|${CC}|" ${WRKSRC}/freebsd.mak \
+ ${WRKSRC}/../phobos/etc/c/zlib/freebsd.mak
+ @${REINPLACE_CMD} -e "s|g++|${CXX}|" ${WRKSRC}/freebsd.mak
+ @${REINPLACE_CMD} -e "s|cc|${CC}|" ${WRKSRC}/../phobos/posix.mak
@${REINPLACE_CMD} -e "s|/etc|${PREFIX}/etc|" \
- ${WRKDIR}/dmd/man/man1/dmd.1 \
- ${WRKDIR}/dmd/man/man1/dmd.conf.5
+ -e "s|\(dmd\)|\12|gI" \
+ -e "s|\\\BR|.BR|" \
+ ${WRKDIR}/dmd2/man/man1/dmd.1 \
+ ${WRKDIR}/dmd2/man/man1/dmd.conf.5
@${REINPLACE_CMD} -e 's|"/etc/"|"${PREFIX}/etc/"|' ${WRKSRC}/inifile.c
-.endif
- @${REINPLACE_CMD} -e "s|%@P%/../../src/phobos|${MODULEDIR}|" ${WRKDIR}/dmd/freebsd/bin/dmd.conf
- @${CP} ${WRKDIR}/dmd/freebsd/bin/dmd.conf ${WRKDIR}/dmd/freebsd/bin/dmd.conf.tango
- @${REINPLACE_CMD} -e "s|phobos|tango -defaultlib=tango -version=freebsd|" ${WRKDIR}/dmd/freebsd/bin/dmd.conf.tango
- @${REINPLACE_CMD} -e "1s|^|# You'll need to recompile libtango.a with dmd and install it yourself.|" ${WRKDIR}/dmd/freebsd/bin/dmd.conf.tango
- @${REINPLACE_CMD} -e "s|%@P%/../lib|${PREFIX}/lib|" \
- ${WRKDIR}/dmd/freebsd/bin/dmd.conf \
- ${WRKDIR}/dmd/freebsd/bin/dmd.conf.tango
+ @${REINPLACE_CMD} -e 's|dmd.conf|dmd2.conf|' ${WRKSRC}/mars.c
+ @${REINPLACE_CMD} -e "s|%@P%/../../src/phobos|${MODULEDIR}|" \
+ -e "s|%@P%/../lib|${PREFIX}/lib|" \
+ -e "s|%@P%/../../src/druntime|${PREFIX}/include/d/druntime|" \
+ ${WRKDIR}/dmd2/linux/bin/dmd.conf
post-build:
- @${REINPLACE_CMD} -e "s| etc/c/zlib/gzio.o||" ${WRKSRC}/../phobos/freebsd.mak
+ cd ${WRKSRC}/../druntime && \
+ ${SETENV} PATH=${WRKSRC}:${PATH} ${GMAKE} ${MAKE_FLAGS} posix.mak
cd ${WRKSRC}/../phobos && \
- ${SETENV} PATH=${PATH}:${WRKSRC} ${MAKE} ${MAKE_FLAGS} freebsd.mak
+ ${SETENV} PATH=${WRKSRC}:${PATH} ${GMAKE} ${MAKE_FLAGS} posix.mak
do-install:
- ${INSTALL_MAN} ${WRKDIR}/dmd/man/man1/dmd.1 ${MANPREFIX}/man/man1
- ${INSTALL_MAN} ${WRKDIR}/dmd/man/man1/dmd.conf.5 ${MANPREFIX}/man/man5
-.if !exists(${PREFIX}/etc/dmd.conf)
- ${INSTALL_DATA} ${WRKDIR}/dmd/freebsd/bin/dmd.conf ${PREFIX}/etc
-.endif
-.if defined(WITH_SOURCE)
- ${INSTALL_PROGRAM} ${WRKSRC}/dmd ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/../phobos/libphobos.a ${PREFIX}/lib
-.else
- ${INSTALL_PROGRAM} ${WRKDIR}/dmd/freebsd/bin/dmd ${PREFIX}/bin
- ${LN} -sf ${PREFIX}/etc/dmd.conf ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKDIR}/dmd/freebsd/lib/libphobos.a ${PREFIX}/lib
+ ${INSTALL_MAN} ${WRKDIR}/dmd2/man/man1/dmd.1 ${MANPREFIX}/man/man1/dmd2.1
+ ${INSTALL_MAN} ${WRKDIR}/dmd2/man/man1/dmd.conf.5 ${MANPREFIX}/man/man5/dmd2.conf.5
+.if !exists(${PREFIX}/etc/dmd2.conf)
+ ${INSTALL_DATA} ${WRKDIR}/dmd2/linux/bin/dmd.conf ${PREFIX}/etc/dmd2.conf
.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/dmd ${PREFIX}/bin/dmd2
+ ${INSTALL_DATA} ${WRKSRC}/../phobos/generated/freebsd/release/libphobos2.a ${PREFIX}/lib
${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKDIR}/dmd/freebsd/bin/dmd.conf ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKDIR}/dmd/freebsd/bin/dmd.conf.tango ${EXAMPLESDIR}
- cd ${WRKDIR}/dmd && ${COPYTREE_SHARE} samples ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKDIR}/dmd2/linux/bin/dmd.conf ${EXAMPLESDIR}/dmd2.conf
+ cd ${WRKDIR}/dmd2 && ${COPYTREE_SHARE} samples ${EXAMPLESDIR}
${MKDIR} ${MODULEDIR}
${INSTALL_DATA} ${WRKSRC}/../phobos/*.d ${MODULEDIR}
- ${MKDIR} ${MODULEDIR}/etc
- ${INSTALL_DATA} ${WRKSRC}/../phobos/etc/gamma.d ${MODULEDIR}/etc
${MKDIR} ${MODULEDIR}/etc/c
${INSTALL_DATA} ${WRKSRC}/../phobos/etc/c/zlib.d ${MODULEDIR}/etc/c
cd ${WRKSRC}/../phobos && ${COPYTREE_SHARE} std ${MODULEDIR}
+ ${MKDIR} ${MODULEDIR}/../druntime
+ cd ${WRKSRC}/../druntime && ${COPYTREE_SHARE} import ${MODULEDIR}/../druntime
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/*.txt ${DOCSDIR}
- cd ${WRKDIR}/dmd && ${COPYTREE_SHARE} html ${DOCSDIR}
+ cd ${WRKDIR}/dmd2 && ${COPYTREE_SHARE} html ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR}/druntime
+ ${INSTALL_DATA} ${WRKSRC}/../druntime/LICENSE_1_0.txt ${DOCSDIR}/druntime
+ ${INSTALL_DATA} ${WRKSRC}/../druntime/README.txt ${DOCSDIR}/druntime
+ cd ${WRKSRC}/../druntime && ${COPYTREE_SHARE} doc ${DOCSDIR}/druntime
${MKDIR} ${DOCSDIR}/phobos
${INSTALL_DATA} ${WRKSRC}/../phobos/phoboslicense.txt ${DOCSDIR}/phobos
${INSTALL_DATA} ${WRKSRC}/../phobos/std.ddoc ${DOCSDIR}/phobos
diff --git a/lang/dmd2/distinfo b/lang/dmd2/distinfo
index 0e61e477d03c..2a764db5b048 100644
--- a/lang/dmd2/distinfo
+++ b/lang/dmd2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dmd.1.065.zip) = 6e15f96447adbdd8f496253af4d579e98ae95dffe56aab021cccce652e5fcab0
-SIZE (dmd.1.065.zip) = 8967817
+SHA256 (dmd.2.051.zip) = 7540a3763c82e98dc3ca30e3b2ffb09ae06d4b7f45a8d9ac6bf43a76dc6c68a2
+SIZE (dmd.2.051.zip) = 10747172
diff --git a/lang/dmd2/files/patch-druntime-src-core-stdc-math.d b/lang/dmd2/files/patch-druntime-src-core-stdc-math.d
new file mode 100644
index 000000000000..3841b622129f
--- /dev/null
+++ b/lang/dmd2/files/patch-druntime-src-core-stdc-math.d
@@ -0,0 +1,11 @@
+--- ../druntime/src/core/stdc/math.d.orig 2010-11-30 13:56:26.000000000 +0000
++++ ../druntime/src/core/stdc/math.d 2010-11-30 13:56:50.000000000 +0000
+@@ -479,7 +479,7 @@
+ // but we can approximate.
+ version( FreeBSD )
+ {
+- version (all) // < 8-CURRENT
++ version (none) // < 8-CURRENT
+ {
+ real acosl(real x) { return acos(x); }
+ real asinl(real x) { return asin(x); }
diff --git a/lang/dmd2/files/patch-phobos-std-c-freebsd-socket.d b/lang/dmd2/files/patch-phobos-std-c-freebsd-socket.d
new file mode 100644
index 000000000000..7ce83d9b8747
--- /dev/null
+++ b/lang/dmd2/files/patch-phobos-std-c-freebsd-socket.d
@@ -0,0 +1,80 @@
+--- /dev/null
++++ ../phobos/std/c/freebsd/socket.d
+@@ -0,0 +1,77 @@
++// Written in the D programming language.
++
++/*
++ * This module is just for making std.socket work under FreeBSD, and these
++ * definitions should actually be in druntime. (core.sys.posix.netdb or sth)
++ */
++module std.c.freebsd.socket;
++
++import core.sys.posix.sys.socket;
++
++extern(C):
++
++enum // <sys/socket.h> __BSD_VISIBLE
++{
++ AF_APPLETALK = 16,
++ AF_IPX = 23,
++}
++
++enum // <sys/socket.h> __BSD_VISIBLE
++{
++ SOCK_RDM = 4,
++}
++
++enum // <sys/socket.h> __BSD_VISIBLE
++{
++ MSG_NOSIGNAL = 0x20000,
++}
++
++enum // <netinet/in.h> __BSD_VISIBLE
++{
++ IPPROTO_IGMP = 2,
++ IPPROTO_GGP = 3,
++ IPPROTO_PUP = 12,
++ IPPROTO_IDP = 22,
++ IPPROTO_ND = 77,
++ IPPROTO_MAX = 256,
++}
++
++enum // <netinet/in.h>
++{
++ INADDR_LOOPBACK = 0x7f000001,
++ INADDR_NONE = 0xffffffff,
++}
++
++
++/*========== <netdb.h> ==========*/
++
++struct hostent
++{
++ char* h_name;
++ char** h_aliases;
++ int h_addrtype;
++ int h_length;
++ char** h_addr_list;
++}
++
++struct servent
++{
++ char* s_name;
++ char** s_aliases;
++ int s_port;
++ char* s_proto;
++}
++
++struct protoent
++{
++ char* p_name;
++ char** p_aliases;
++ int p_proto;
++}
++
++hostent* gethostbyaddr(in void*, socklen_t, int); // obsolete
++hostent* gethostbyname(in char*); // obsolete
++protoent* getprotobyname(in char *);
++protoent* getprotobynumber(int);
++servent* getservbyname(in char*, in char*);
++servent* getservbyport(int, in char*);
diff --git a/lang/dmd2/pkg-descr b/lang/dmd2/pkg-descr
index b51870806c72..a1bfb8d16b90 100644
--- a/lang/dmd2/pkg-descr
+++ b/lang/dmd2/pkg-descr
@@ -12,4 +12,11 @@ It is not governed by a corporate agenda or any overarching theory of
programming. The needs and contributions of the D programming community form
the direction it goes.
-WWW: http://digitalmars.com/d/1.0/
+This is an unofficial port that compiles directly from source, so it has not
+been officially validated or tested on the FreeBSD platform by the developer.
+
+This Software is copyrighted and comes with a single user license, and may not
+be redistributed. If you wish to obtain a redistribution license, please
+contact Digital Mars.
+
+WWW: http://digitalmars.com/d/2.0/
diff --git a/lang/dmd2/pkg-plist b/lang/dmd2/pkg-plist
index e4ec21be0ba3..210d1b9b783d 100644
--- a/lang/dmd2/pkg-plist
+++ b/lang/dmd2/pkg-plist
@@ -1,180 +1,248 @@
-bin/dmd
-@unexec if cmp -s %D/%%EXAMPLESDIR%%/dmd.conf %D/etc/dmd.conf; then rm -f %D/etc/dmd.conf; fi
-%%EXAMPLESDIR%%/dmd.conf
-@exec if [ ! -f %D/etc/dmd.conf ]; then cp -p %D/%%EXAMPLESDIR%%/dmd.conf %D/etc/dmd.conf; fi
-%%EXAMPLESDIR%%/dmd.conf.tango
+bin/dmd2
+lib/libphobos2.a
+@unexec if cmp -s %D/%%EXAMPLESDIR%%/dmd2.conf %D/etc/dmd2.conf; then rm -f %D/etc/dmd2.conf; fi
+%%EXAMPLESDIR%%/dmd2.conf
+@exec if [ ! -f %D/etc/dmd2.conf ]; then cp -p %D/%%EXAMPLESDIR%%/dmd2.conf %D/etc/dmd2.conf; fi
%%EXAMPLESDIR%%/samples/d/all.sh
+%%EXAMPLESDIR%%/samples/d/build.bat
%%EXAMPLESDIR%%/samples/d/chello.d
+%%EXAMPLESDIR%%/samples/d/clean.bat
%%EXAMPLESDIR%%/samples/d/d2html.d
+%%EXAMPLESDIR%%/samples/d/d2html.kwd
%%EXAMPLESDIR%%/samples/d/dclient.d
%%EXAMPLESDIR%%/samples/d/dhry.d
%%EXAMPLESDIR%%/samples/d/dserver.d
-%%EXAMPLESDIR%%/samples/d/dserver.def
%%EXAMPLESDIR%%/samples/d/hello.d
-%%EXAMPLESDIR%%/samples/d/hello2.html
%%EXAMPLESDIR%%/samples/d/htmlget.d
%%EXAMPLESDIR%%/samples/d/listener.d
%%EXAMPLESDIR%%/samples/d/mydll/build.bat
%%EXAMPLESDIR%%/samples/d/mydll/dll.d
%%EXAMPLESDIR%%/samples/d/mydll/mydll.d
%%EXAMPLESDIR%%/samples/d/mydll/mydll.def
-%%EXAMPLESDIR%%/samples/d/mydll/mydll2.d
+%%EXAMPLESDIR%%/samples/d/mydll/mydll.di
%%EXAMPLESDIR%%/samples/d/mydll/test.d
%%EXAMPLESDIR%%/samples/d/pi.d
-%%EXAMPLESDIR%%/samples/d/run.bat
%%EXAMPLESDIR%%/samples/d/sieve.d
%%EXAMPLESDIR%%/samples/d/wc.d
%%EXAMPLESDIR%%/samples/d/wc2.d
%%EXAMPLESDIR%%/samples/d/winsamp.d
%%EXAMPLESDIR%%/samples/d/winsamp.def
-lib/libphobos.a
-include/d/phobos/crc32.d
-include/d/phobos/etc/gamma.d
-include/d/phobos/etc/c/zlib.d
-include/d/phobos/gcstats.d
-include/d/phobos/object.d
-include/d/phobos/phobos.d
-include/d/phobos/std/array.d
-include/d/phobos/std/asserterror.d
-include/d/phobos/std/base64.d
-include/d/phobos/std/bind.d
-include/d/phobos/std/bitarray.d
-include/d/phobos/std/boxer.d
-include/d/phobos/std/c/fenv.d
-include/d/phobos/std/c/freebsd/freebsd.d
-include/d/phobos/std/c/freebsd/math.d
-include/d/phobos/std/c/freebsd/pthread.d
-include/d/phobos/std/c/freebsd/socket.d
-include/d/phobos/std/c/linux/linux.d
-include/d/phobos/std/c/linux/linuxextern.d
-include/d/phobos/std/c/linux/pthread.d
-include/d/phobos/std/c/linux/socket.d
-include/d/phobos/std/c/locale.d
-include/d/phobos/std/c/math.d
-include/d/phobos/std/c/osx/dyld.d
-include/d/phobos/std/c/osx/getsect.d
-include/d/phobos/std/c/osx/loader.d
-include/d/phobos/std/c/osx/osx.d
-include/d/phobos/std/c/posix/posix.d
-include/d/phobos/std/c/posix/pthread.d
-include/d/phobos/std/c/posix/socket.d
-include/d/phobos/std/c/process.d
-include/d/phobos/std/c/solaris/pthread.d
-include/d/phobos/std/c/solaris/socket.d
-include/d/phobos/std/c/solaris/solaris.d
-include/d/phobos/std/c/stdarg.d
-include/d/phobos/std/c/stddef.d
-include/d/phobos/std/c/stdio.d
-include/d/phobos/std/c/stdlib.d
-include/d/phobos/std/c/string.d
-include/d/phobos/std/c/time.d
-include/d/phobos/std/c/windows/com.d
-include/d/phobos/std/c/windows/stat.d
-include/d/phobos/std/c/windows/windows.d
-include/d/phobos/std/c/windows/winsock.d
-include/d/phobos/std/compiler.d
-include/d/phobos/std/conv.d
-include/d/phobos/std/cover.d
-include/d/phobos/std/cpuid.d
-include/d/phobos/std/cstream.d
-include/d/phobos/std/ctype.d
-include/d/phobos/std/date.d
-include/d/phobos/std/dateparse.d
-include/d/phobos/std/demangle.d
-include/d/phobos/std/file.d
-include/d/phobos/std/format.d
-include/d/phobos/std/gc.d
-include/d/phobos/std/intrinsic.d
-include/d/phobos/std/loader.d
-include/d/phobos/std/math.d
-include/d/phobos/std/math2.d
-include/d/phobos/std/md5.d
-include/d/phobos/std/metastrings.d
-include/d/phobos/std/mmfile.d
-include/d/phobos/std/moduleinit.d
-include/d/phobos/std/openrj.d
-include/d/phobos/std/outbuffer.d
-include/d/phobos/std/outofmemory.d
-include/d/phobos/std/path.d
-include/d/phobos/std/perf.d
-include/d/phobos/std/process.d
-include/d/phobos/std/random.d
-include/d/phobos/std/regexp.d
-include/d/phobos/std/signals.d
-include/d/phobos/std/socket.d
-include/d/phobos/std/socketstream.d
-include/d/phobos/std/stdarg.d
-include/d/phobos/std/stdint.d
-include/d/phobos/std/stdio.d
-include/d/phobos/std/stream.d
-include/d/phobos/std/string.d
-include/d/phobos/std/switcherr.d
-include/d/phobos/std/syserror.d
-include/d/phobos/std/system.d
-include/d/phobos/std/thread.d
-include/d/phobos/std/thread_helper.d
-include/d/phobos/std/traits.d
-include/d/phobos/std/typeinfo/ti_AC.d
-include/d/phobos/std/typeinfo/ti_Acdouble.d
-include/d/phobos/std/typeinfo/ti_Acfloat.d
-include/d/phobos/std/typeinfo/ti_Acreal.d
-include/d/phobos/std/typeinfo/ti_Adouble.d
-include/d/phobos/std/typeinfo/ti_Afloat.d
-include/d/phobos/std/typeinfo/ti_Ag.d
-include/d/phobos/std/typeinfo/ti_Aint.d
-include/d/phobos/std/typeinfo/ti_Along.d
-include/d/phobos/std/typeinfo/ti_Areal.d
-include/d/phobos/std/typeinfo/ti_Ashort.d
-include/d/phobos/std/typeinfo/ti_C.d
-include/d/phobos/std/typeinfo/ti_byte.d
-include/d/phobos/std/typeinfo/ti_cdouble.d
-include/d/phobos/std/typeinfo/ti_cfloat.d
-include/d/phobos/std/typeinfo/ti_char.d
-include/d/phobos/std/typeinfo/ti_creal.d
-include/d/phobos/std/typeinfo/ti_dchar.d
-include/d/phobos/std/typeinfo/ti_delegate.d
-include/d/phobos/std/typeinfo/ti_double.d
-include/d/phobos/std/typeinfo/ti_float.d
-include/d/phobos/std/typeinfo/ti_idouble.d
-include/d/phobos/std/typeinfo/ti_ifloat.d
-include/d/phobos/std/typeinfo/ti_int.d
-include/d/phobos/std/typeinfo/ti_ireal.d
-include/d/phobos/std/typeinfo/ti_long.d
-include/d/phobos/std/typeinfo/ti_ptr.d
-include/d/phobos/std/typeinfo/ti_real.d
-include/d/phobos/std/typeinfo/ti_short.d
-include/d/phobos/std/typeinfo/ti_ubyte.d
-include/d/phobos/std/typeinfo/ti_uint.d
-include/d/phobos/std/typeinfo/ti_ulong.d
-include/d/phobos/std/typeinfo/ti_ushort.d
-include/d/phobos/std/typeinfo/ti_void.d
-include/d/phobos/std/typeinfo/ti_wchar.d
-include/d/phobos/std/typetuple.d
-include/d/phobos/std/uni.d
-include/d/phobos/std/uri.d
-include/d/phobos/std/utf.d
-include/d/phobos/std/windows/charset.d
-include/d/phobos/std/windows/iunknown.d
-include/d/phobos/std/windows/registry.d
-include/d/phobos/std/windows/syserror.d
-include/d/phobos/std/zip.d
-include/d/phobos/std/zlib.d
-include/d/phobos/unittest.d
+include/d/druntime/import/core/atomic.di
+include/d/druntime/import/core/bitop.di
+include/d/druntime/import/core/cpuid.di
+include/d/druntime/import/core/demangle.di
+include/d/druntime/import/core/dll_helper.di
+include/d/druntime/import/core/exception.di
+include/d/druntime/import/core/memory.di
+include/d/druntime/import/core/runtime.di
+include/d/druntime/import/core/stdc/complex.di
+include/d/druntime/import/core/stdc/config.di
+include/d/druntime/import/core/stdc/ctype.di
+include/d/druntime/import/core/stdc/errno.di
+include/d/druntime/import/core/stdc/fenv.di
+include/d/druntime/import/core/stdc/float_.di
+include/d/druntime/import/core/stdc/inttypes.di
+include/d/druntime/import/core/stdc/limits.di
+include/d/druntime/import/core/stdc/locale.di
+include/d/druntime/import/core/stdc/math.di
+include/d/druntime/import/core/stdc/signal.di
+include/d/druntime/import/core/stdc/stdarg.di
+include/d/druntime/import/core/stdc/stddef.di
+include/d/druntime/import/core/stdc/stdint.di
+include/d/druntime/import/core/stdc/stdio.di
+include/d/druntime/import/core/stdc/stdlib.di
+include/d/druntime/import/core/stdc/string.di
+include/d/druntime/import/core/stdc/tgmath.di
+include/d/druntime/import/core/stdc/time.di
+include/d/druntime/import/core/stdc/wchar_.di
+include/d/druntime/import/core/stdc/wctype.di
+include/d/druntime/import/core/sync/barrier.di
+include/d/druntime/import/core/sync/condition.di
+include/d/druntime/import/core/sync/config.di
+include/d/druntime/import/core/sync/exception.di
+include/d/druntime/import/core/sync/mutex.di
+include/d/druntime/import/core/sync/rwmutex.di
+include/d/druntime/import/core/sync/semaphore.di
+include/d/druntime/import/core/sys/osx/mach/kern_return.di
+include/d/druntime/import/core/sys/osx/mach/port.di
+include/d/druntime/import/core/sys/osx/mach/semaphore.di
+include/d/druntime/import/core/sys/osx/mach/thread_act.di
+include/d/druntime/import/core/sys/posix/arpa/inet.di
+include/d/druntime/import/core/sys/posix/config.di
+include/d/druntime/import/core/sys/posix/dirent.di
+include/d/druntime/import/core/sys/posix/dlfcn.di
+include/d/druntime/import/core/sys/posix/fcntl.di
+include/d/druntime/import/core/sys/posix/inttypes.di
+include/d/druntime/import/core/sys/posix/net/if_.di
+include/d/druntime/import/core/sys/posix/netinet/in_.di
+include/d/druntime/import/core/sys/posix/netinet/tcp.di
+include/d/druntime/import/core/sys/posix/poll.di
+include/d/druntime/import/core/sys/posix/pthread.di
+include/d/druntime/import/core/sys/posix/pwd.di
+include/d/druntime/import/core/sys/posix/sched.di
+include/d/druntime/import/core/sys/posix/semaphore.di
+include/d/druntime/import/core/sys/posix/setjmp.di
+include/d/druntime/import/core/sys/posix/signal.di
+include/d/druntime/import/core/sys/posix/stdio.di
+include/d/druntime/import/core/sys/posix/stdlib.di
+include/d/druntime/import/core/sys/posix/sys/ipc.di
+include/d/druntime/import/core/sys/posix/sys/mman.di
+include/d/druntime/import/core/sys/posix/sys/select.di
+include/d/druntime/import/core/sys/posix/sys/shm.di
+include/d/druntime/import/core/sys/posix/sys/socket.di
+include/d/druntime/import/core/sys/posix/sys/stat.di
+include/d/druntime/import/core/sys/posix/sys/time.di
+include/d/druntime/import/core/sys/posix/sys/types.di
+include/d/druntime/import/core/sys/posix/sys/uio.di
+include/d/druntime/import/core/sys/posix/sys/wait.di
+include/d/druntime/import/core/sys/posix/termios.di
+include/d/druntime/import/core/sys/posix/time.di
+include/d/druntime/import/core/sys/posix/ucontext.di
+include/d/druntime/import/core/sys/posix/unistd.di
+include/d/druntime/import/core/sys/posix/utime.di
+include/d/druntime/import/core/sys/windows/windows.di
+include/d/druntime/import/core/thread.di
+include/d/druntime/import/core/thread_helper.di
+include/d/druntime/import/core/time.di
+include/d/druntime/import/core/vararg.di
+include/d/druntime/import/object.di
+include/d/druntime/import/std/intrinsic.di
+include/d/phobos2/crc32.d
+include/d/phobos2/etc/c/zlib.d
+include/d/phobos2/phobos.d
+include/d/phobos2/std/__fileinit.d
+include/d/phobos2/std/algorithm.d
+include/d/phobos2/std/array.d
+include/d/phobos2/std/atomics.d
+include/d/phobos2/std/base64.d
+include/d/phobos2/std/bigint.d
+include/d/phobos2/std/bind.d
+include/d/phobos2/std/bitarray.d
+include/d/phobos2/std/bitmanip.d
+include/d/phobos2/std/boxer.d
+include/d/phobos2/std/c/fenv.d
+include/d/phobos2/std/c/freebsd/socket.d
+include/d/phobos2/std/c/freebsd/socket.d.orig
+include/d/phobos2/std/c/linux/linux.d
+include/d/phobos2/std/c/linux/pthread.d
+include/d/phobos2/std/c/linux/socket.d
+include/d/phobos2/std/c/linux/termios.d
+include/d/phobos2/std/c/linux/tipc.d
+include/d/phobos2/std/c/locale.d
+include/d/phobos2/std/c/math.d
+include/d/phobos2/std/c/osx/socket.d
+include/d/phobos2/std/c/process.d
+include/d/phobos2/std/c/stdarg.d
+include/d/phobos2/std/c/stddef.d
+include/d/phobos2/std/c/stdio.d
+include/d/phobos2/std/c/stdlib.d
+include/d/phobos2/std/c/string.d
+include/d/phobos2/std/c/time.d
+include/d/phobos2/std/c/wcharh.d
+include/d/phobos2/std/c/windows/com.d
+include/d/phobos2/std/c/windows/stat.d
+include/d/phobos2/std/c/windows/windows.d
+include/d/phobos2/std/c/windows/winsock.d
+include/d/phobos2/std/compiler.d
+include/d/phobos2/std/complex.d
+include/d/phobos2/std/concurrency.d
+include/d/phobos2/std/container.d
+include/d/phobos2/std/contracts.d
+include/d/phobos2/std/conv.d
+include/d/phobos2/std/cpuid.d
+include/d/phobos2/std/cstream.d
+include/d/phobos2/std/ctype.d
+include/d/phobos2/std/date.d
+include/d/phobos2/std/datebase.d
+include/d/phobos2/std/dateparse.d
+include/d/phobos2/std/datetime.d
+include/d/phobos2/std/demangle.d
+include/d/phobos2/std/encoding.d
+include/d/phobos2/std/exception.d
+include/d/phobos2/std/file.d
+include/d/phobos2/std/format.d
+include/d/phobos2/std/functional.d
+include/d/phobos2/std/getopt.d
+include/d/phobos2/std/gregorian.d
+include/d/phobos2/std/internal/math/biguintcore.d
+include/d/phobos2/std/internal/math/biguintnoasm.d
+include/d/phobos2/std/internal/math/biguintx86.d
+include/d/phobos2/std/internal/math/errorfunction.d
+include/d/phobos2/std/internal/math/gammafunction.d
+include/d/phobos2/std/intrinsic.d
+include/d/phobos2/std/iterator.d
+include/d/phobos2/std/json.d
+include/d/phobos2/std/loader.d
+include/d/phobos2/std/math.d
+include/d/phobos2/std/mathspecial.d
+include/d/phobos2/std/md5.d
+include/d/phobos2/std/metastrings.d
+include/d/phobos2/std/mmfile.d
+include/d/phobos2/std/numeric.d
+include/d/phobos2/std/openrj.d
+include/d/phobos2/std/outbuffer.d
+include/d/phobos2/std/path.d
+include/d/phobos2/std/perf.d
+include/d/phobos2/std/process.d
+include/d/phobos2/std/random.d
+include/d/phobos2/std/range.d
+include/d/phobos2/std/regex.d
+include/d/phobos2/std/regexp.d
+include/d/phobos2/std/signals.d
+include/d/phobos2/std/socket.d
+include/d/phobos2/std/socketstream.d
+include/d/phobos2/std/stdarg.d
+include/d/phobos2/std/stdint.d
+include/d/phobos2/std/stdio.d
+include/d/phobos2/std/stdiobase.d
+include/d/phobos2/std/stream.d
+include/d/phobos2/std/string.d
+include/d/phobos2/std/syserror.d
+include/d/phobos2/std/system.d
+include/d/phobos2/std/traits.d
+include/d/phobos2/std/typecons.d
+include/d/phobos2/std/typetuple.d
+include/d/phobos2/std/uni.d
+include/d/phobos2/std/uri.d
+include/d/phobos2/std/utf.d
+include/d/phobos2/std/variant.d
+include/d/phobos2/std/windows/charset.d
+include/d/phobos2/std/windows/iunknown.d
+include/d/phobos2/std/windows/registry.d
+include/d/phobos2/std/windows/syserror.d
+include/d/phobos2/std/xml.d
+include/d/phobos2/std/zip.d
+include/d/phobos2/std/zlib.d
+include/d/phobos2/unittest.d
@dirrm %%EXAMPLESDIR%%/samples/d/mydll
@dirrm %%EXAMPLESDIR%%/samples/d
@dirrm %%EXAMPLESDIR%%/samples
@dirrm %%EXAMPLESDIR%%
-@dirrm include/d/phobos/std/windows
-@dirrm include/d/phobos/std/typeinfo
-@dirrm include/d/phobos/std/c/windows
-@dirrm include/d/phobos/std/c/solaris
-@dirrm include/d/phobos/std/c/posix
-@dirrm include/d/phobos/std/c/osx
-@dirrm include/d/phobos/std/c/linux
-@dirrm include/d/phobos/std/c/freebsd
-@dirrm include/d/phobos/std/c
-@dirrm include/d/phobos/std
-@dirrm include/d/phobos/etc/c
-@dirrm include/d/phobos/etc
-@dirrm include/d/phobos
+@dirrm include/d/phobos2/std/windows
+@dirrm include/d/phobos2/std/internal/math
+@dirrm include/d/phobos2/std/internal
+@dirrm include/d/phobos2/std/c/windows
+@dirrm include/d/phobos2/std/c/osx
+@dirrm include/d/phobos2/std/c/linux
+@dirrm include/d/phobos2/std/c/freebsd
+@dirrm include/d/phobos2/std/c
+@dirrm include/d/phobos2/std
+@dirrm include/d/phobos2/etc/c
+@dirrm include/d/phobos2/etc
+@dirrm include/d/phobos2
+@dirrm include/d/druntime/import/std
+@dirrm include/d/druntime/import/core/sys/windows
+@dirrm include/d/druntime/import/core/sys/posix/sys
+@dirrm include/d/druntime/import/core/sys/posix/netinet
+@dirrm include/d/druntime/import/core/sys/posix/net
+@dirrm include/d/druntime/import/core/sys/posix/arpa
+@dirrm include/d/druntime/import/core/sys/posix
+@dirrm include/d/druntime/import/core/sys/osx/mach
+@dirrm include/d/druntime/import/core/sys/osx
+@dirrm include/d/druntime/import/core/sys
+@dirrm include/d/druntime/import/core/sync
+@dirrm include/d/druntime/import/core/stdc
+@dirrm include/d/druntime/import/core
+@dirrm include/d/druntime/import
+@dirrm include/d/druntime
@dirrmtry include/d